Remove stitching in existing PDFs when exporting for screens.

New Here ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

I receive PDF files from advertisers that often have the faint "stitching lines". They don't show up in print so it's never been a problem but we now have a digital edition of our magazine and I don't want these lines to show up. I create an indesign file and import pdfs into that file and then create a pdf. I've tried every preset haven't found a solution that works with viewing for screens.

TOPICS
Publish online

Views

149

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct Answers

Most Valuable Participant , Dec 08, 2020 Dec 08, 2020
You cannot put an egg back in the shell after you make an omellet. The damage is done. Tell the advertisers to provide PDF/X4 files.

Likes

translate

Translate

Translate
Enthusiast , Dec 08, 2020 Dec 08, 2020
Nothing you can do, really. What is happening is that transparency flattening is creating small chunks of areas that are flattened and are abutting each other. As you have noticed, this is fine in print, but the lower resolution of the screen view may* (*totally will) pick up the edges of them. and, without the source there's no way to go back. A suggestion: for your digital edition, render the entire offending ad into an image. e.g. open their pdf in Photoshop and render it at 300dpi in cmyk. T...

Likes

translate

Translate

Translate
Adobe Community Professional , Dec 09, 2020 Dec 09, 2020
The "stitching" isn’t in the file, but is caused by the reader application’s screen anti-aliasing technique, you can hide the anti-aliasing artifacts in Acrobat by unchecking Smooth line art in the Page Display Preferences.   For your online magazine you could remove the stitching by rasterizing the ads into Photoshop with Anti-Aliasing turned off.  That might cause bigger problems with small text and file size, it would depend on the content. You can rasterize at a high resolution, then downsam...

Likes

translate

Translate

Translate
Most Valuable Participant ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

You cannot put an egg back in the shell after you make an omellet. The damage is done.

Tell the advertisers to provide PDF/X4 files.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

Nothing you can do, really. What is happening is that transparency flattening is creating small chunks of areas that are flattened and are abutting each other. As you have noticed, this is fine in print, but the lower resolution of the screen view may* (*totally will) pick up the edges of them. and, without the source there's no way to go back. A suggestion: for your digital edition, render the entire offending ad into an image. e.g. open their pdf in Photoshop and render it at 300dpi in cmyk. This will cause issues with smaller type since you will likley downsample the image further when you make your pdf, but at least the lines are gone. More work at your end, sadly, because trying to explain to your clients why their badly-created pdfs look bad because of the thing they did will be difficult.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

The "stitching" isn’t in the file but is an anti-aliasing artifact in the reader application’s screen preview—that’s why they don’t show up in high resolution printing. In Acrobat Reader you can hide the artifacts by changing Acrobat’s Anti-Aliasing preference—uncheck Smooth line art in the Page Display Preferences.

 

For your online magazine you could remove the anti-aliasing artifacts by rasterizing the ads into Photoshop with Anti-Aliasing turned off, but that might cause a bigger problem with small text or file size—it would depend on the content. You can open the file at a high resolution with AA turned off then downsample to a screen resolution, which anti-aliases the type and removes the stitching.

 

Here’s a comparison—Anti-Aliasing check on the left and unchecked on the right:

 

Screen Shot 16.png

 

 

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

The "stitching" isn’t in the file, but is caused by the reader application’s screen anti-aliasing technique, you can hide the anti-aliasing artifacts in Acrobat by unchecking Smooth line art in the Page Display Preferences.

 

For your online magazine you could remove the stitching by rasterizing the ads into Photoshop with Anti-Aliasing turned off.  That might cause bigger problems with small text and file size, it would depend on the content. You can rasterize at a high resolution, then downsample, which will anti-alias text.

 

Here’s an example:

 

Screen Shot 16.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Thank you everyone. After posting this, I realized that the ads submitted by some of the advertisers don't have the stitching but after I export using my printer's required settings the stitching appears. I had created digital layout by importing the printer files into indesign and exporting using the "smallest file size" PDF setting, so I guess I'll have to use the originals for the online version.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines