Highlighted

Right to left text doesn't work.

Community Beginner ,
Jul 08, 2020

Copy link to clipboard

Copied

I have a mainly English text that has a few words in Farsi. Whatever I do, the Farsi letters are not arranged from right to left and don't connect with each other. I uninstalled my 15.1.1 English (international) indesign, changed language settings to Arabic and installed the latest MENA version to fix this (although I've previously worked on English indesign and this was not an issue). I still have the same problem on the Arabic edition. I've tried world ready single line and paragraph composer, changing paragraph direction – none work. See screenshot for settings.Farsi/Arabic appears left to right (wrong)Farsi/Arabic appears left to right (wrong)

Adobe Community Professional
Correct answer by Mike Witherell | Adobe Community Professional

Another thought from the help menu: make a character style:

If you have a mix of languages in the same paragraph, you can specify the direction of text at a character level. Also, to insert dates or numbers, specify the direction of text at the character level.

From the Character panel menu, choose Character Direction and then select a direction.

TOPICS
Bug

Views

70

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Right to left text doesn't work.

Community Beginner ,
Jul 08, 2020

Copy link to clipboard

Copied

I have a mainly English text that has a few words in Farsi. Whatever I do, the Farsi letters are not arranged from right to left and don't connect with each other. I uninstalled my 15.1.1 English (international) indesign, changed language settings to Arabic and installed the latest MENA version to fix this (although I've previously worked on English indesign and this was not an issue). I still have the same problem on the Arabic edition. I've tried world ready single line and paragraph composer, changing paragraph direction – none work. See screenshot for settings.Farsi/Arabic appears left to right (wrong)Farsi/Arabic appears left to right (wrong)

Adobe Community Professional
Correct answer by Mike Witherell | Adobe Community Professional

Another thought from the help menu: make a character style:

If you have a mix of languages in the same paragraph, you can specify the direction of text at a character level. Also, to insert dates or numbers, specify the direction of text at the character level.

From the Character panel menu, choose Character Direction and then select a direction.

TOPICS
Bug

Views

71

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 08, 2020 0
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

Preferences > Advanced Type > Input Method Options > Use Inline Input for Non-Latin Text

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2020 0
Community Beginner ,
Jul 08, 2020

Copy link to clipboard

Copied

Thanks Mike. I can see that Use Inline Input for Non-Latin Text was already ticked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2020 0
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

According to very old notes of my own making, you turn that feature ... OFF? I cannot find it in the Adobe help files anymore, and I have never actually done it, so sorry if that is an incomplete thought...

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2020 0
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

Another thought from the help menu: make a character style:

If you have a mix of languages in the same paragraph, you can specify the direction of text at a character level. Also, to insert dates or numbers, specify the direction of text at the character level.

From the Character panel menu, choose Character Direction and then select a direction.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2020 1
Adobe Community Professional ,
Jul 08, 2020

Copy link to clipboard

Copied

I'm reading this help page:

https://helpx.adobe.com/indesign/using/arabic-hebrew.html

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 08, 2020 0
Adobe Community Professional ,
Jul 09, 2020

Copy link to clipboard

Copied

From the screenshot you provided, you have the right Middle Eastern version. I'm eliminating the "Adobe World Ready" and "Paragraph Alignment" factors because you mentioned that you've made sure they were properly set and I can relate to this because if any of the above were not properly set, you will see your Arabic/Farsi text this way…

Screen Shot 2020-07-09 at 6.17.07 PM.png 

I feel there is something with the font although you're using Adobe Arabic, it could be corrupted. Can you try with other Arabic fonts to see if things will improve?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2020 0
Community Beginner ,
Aug 07, 2020

Copy link to clipboard

Copied

Setting character direction to right-to-left solved this (Thanks Mike). In the English version my Farsi fonts were all automatically set to right-to-left (because there's no other option), this changed when I changed to the Arabic version so I had to set it manually (character panel > reveal more options > character direction). 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2020 0