Highlighted

Running heads and forced line breaks: extra space character?

New Here ,
Apr 23, 2020

Copy link to clipboard

Copied

Hello everyone. I'm formatting a book with running heads for the chapters (created as a text variable). Some of the chapter titles require a forced line break to fit how I want. Originally, I left an extra space before the forced line break so the generated table of contents would look right (when checking "Remove forced line breaks"). I only just realized that adds an extra space in my running heads that I can't seem to get rid of.

 

I searched for an answer, and either I don't know how to properly frame my question, or there's no good answer. A few search results (from 2018, I think—maybe earlier) directed me toward a dead link with a workaround (that others indicate doesn't work reliably—whatever it is).

 

I'm just curious if there's a way to ignore forced line breaks in running heads when pulled from a source that might have them. Thanks!

Topics

Bug, Type

Views

993

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Running heads and forced line breaks: extra space character?

New Here ,
Apr 23, 2020

Copy link to clipboard

Copied

Hello everyone. I'm formatting a book with running heads for the chapters (created as a text variable). Some of the chapter titles require a forced line break to fit how I want. Originally, I left an extra space before the forced line break so the generated table of contents would look right (when checking "Remove forced line breaks"). I only just realized that adds an extra space in my running heads that I can't seem to get rid of.

 

I searched for an answer, and either I don't know how to properly frame my question, or there's no good answer. A few search results (from 2018, I think—maybe earlier) directed me toward a dead link with a workaround (that others indicate doesn't work reliably—whatever it is).

 

I'm just curious if there's a way to ignore forced line breaks in running heads when pulled from a source that might have them. Thanks!

Topics

Bug, Type

Views

994

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 23, 2020 0
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

Maybe I didn't understand your issue.

I have InDesign 2020 (15.0.2) and the result is this:

Schermata 2020-04-24 alle 09.47.38.pngSchermata 2020-04-24 alle 09.47.47.png

 

and here is the settings on my master page:

Schermata 2020-04-24 alle 09.52.49.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

Your screens are exactly what I want on mine, but here's what I get instead:

Blake612_0-1587768865554.png

(forced line break for illustration purposes only)
And in my running heads, I get this:

Blake612_1-1587768934879.png

Here's what my text variable settings look like:

Blake612_2-1587769005701.png

I'm also running InDesign 2020 (ver 15.0.2 x64 on Windows 10). I'm not sure why that extra space gets added in. Thanks for responding! Any other ideas? Anything I might be missing?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
Advocate ,
Apr 24, 2020

Copy link to clipboard

Copied

Funny! … and not so good.

 

If you take a look to Vladan's second screenshot, he has now … a new space that appears at the end of the header line!! … So the header won't be precisely centered!

 

(^/)  The Jedi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 1
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

I'm not sure you can have more than one line in a running head in InDesign, there may be a third-party plug-in available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

Thanks, Derek. I might not have been clear: I don't want multi-line running heads: I want a multi-line chapter style to show up as a single line running head, but without the extra space I see added (see my reply above for visual examples). I appreciate you weighing in! Any suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
Adobe Community Professional ,
Apr 25, 2020

Copy link to clipboard

Copied

I remember that in some of the previous versions of indesign in similar cases an extra space was added in the headers on the odd pages and on the even pages not (!?). This option didn't worked well even before.

But now I have tested this on Mac OS Catalina and on Windows 10 pro with InDesign 2020 (15.0.2) and all is OK.

The only anomalous thing (bug) in my file is, as Michel very good noted, one anomaly space at the end of the header. However space at the end (or several spaces at the end) do not affect the alignment of the headers.
This space can be eliminated by ticking the "Delete End Punctuation" item (it is another anomaly since this anomalous space is considered as the end punctuation). Tick you too this item and check out if change something or not.

Do you notice this problem only in this file or in all files?
If it is only in this file try to export it in idml format. Reopen it and check if the bug persists or not.
If you notice this anomaly in all your files you could try to trash InDesign preferences of InDesign and check if afterwards it is okay or not.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2020 1
New Here ,
Apr 26, 2020

Copy link to clipboard

Copied

Thanks for the suggestions. IDML didn't change anything, so I'm going to try resetting my INDD preferences and see if that helps. Thanks again! (Worst case, it's not the end of the world to manually add spaces in my TOC: I just hope I don't forget anything!)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2020 0
Adobe Community Professional ,
Apr 27, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2020 0
Advocate ,
May 06, 2020

Copy link to clipboard

Copied

[InDesign CC 2020 [15.0.2] with OSX High Sierra]

 

If you don't want problems with the "soft-return", just don't use it [if ou can]!

 

Capture d’écran 2020-05-07 à 00.00.56.png

 

About cross-ref.:

https://community.adobe.com/t5/indesign/forced-line-breaks-in-heads-appear-in-cross-references/m-p/1...

 

(^/)  The Jedi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 1
Explorer ,
May 09, 2020

Copy link to clipboard

Copied

Capture.PNG

Hi, I did that. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2020 0
Advocate ,
May 09, 2020

Copy link to clipboard

Copied

Replace here a normal space by a soft-return won't never be for me … a truly good way to play!  😉

[What about this if you need cross-ref. or TOC! …]

 

(^/)  The Jedi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2020 0
Explorer ,
May 09, 2020

Copy link to clipboard

Copied

Capture1.PNG

I learnd from your screenshot, Michel. but i don't know am i doing it right?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2020 0