Small-caps randomly disappearing during export

Community Beginner ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Hi, 

I had a serious problem with Indesign export and I do not know how to solve it nor how to reproduce it, which makes it all the more worrisome.

The PDF file I exported and sent to my client has lost all the small-caps in Adobe Garamond Pro Italics font. They are present in the Indesign file, I do not have any font problem and when I redo the export, everything works just fine. How can this happen and how can I be sure that it won't happen again? 

(I am working in Indesign 2021 version 16.2.1, the problem appeared when I exported my indb file (it is a book of  7 indd files, making a total of about 800 pages).

Thank you very much for your help

TOPICS
Bug, Import and export, Print

Views

192

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

  • What part of the text was in small caps? Was it Roman numerals for the century at the end of your text?
  • did you type it or used some glyphs?
  • can you indicate the steps you took to generate the content that was lost?
  • what standards did you use for your pdf export?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Thank you very much for your response, Eric!

  • The text in small caps was indeed the Roman numerals for the century.
  • I imported it from word (no glyphs), and used the TT button in Indesign to make the small-caps.
  • I just made a HD export without any pdf standard.

When I retry to do the export with the same parameters, the small-caps are there. I don't understand what could have happened.

Thank you again for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

When you choose the small caps feature in an open type font, InDesign substitutes the glyph for the small cap version - rather than using the preferences for the small caps set in InDesign>Preferences.

 

On export to PDF it might be better to choose Create a Tagged PDF which might be an option to help PDF readers understand what glyph to display.

 

I wonder what PDF viewer it is missing in - are you both using Acrobat? Or another PDF reader, like Mac Preview or Foxit Reader etc. 

 

 

I've noticed a lot - especially with Word - that copying and pasting, importing or anything like that tends to have issues, I often have characters go completely missing, from hyphens, to spaces to a multitude of things. 

 

Check to make sure that no Microsoft styles came in - check your paragraph and character styles (especially character styles) to ensure that there are no rogue styles imported that could be causing issues. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

LATEST

Thank you for your response!

We both use Acrobat, yes.

Actually the issue is that neither of us could see the small-caps on one version (they just did not export), but they do export just fine now, I just want to be sure that it won't happen again.

I do not have any Word styles on these characters, I usually clear all the Word formatting. But we did do a lot of exporting due to multiple corrections asked by the client, and multiple people were working on the files.

Thank you very much and have a great day!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Here's something to try:

When exporting PDF, Export > Advanced > Subsetting Fonts Value: Set this to 0%

Note, this will include the entire character set and will create a larger file size PDF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines