Highlighted

Smart Text Reflow

New Here ,
May 02, 2018

Copy link to clipboard

Copied

Indesign CC 2018. I've set preferences to Smart Text Reflow/end of story/primary text frames. I've threaded my master page spread text boxes. I've "unlocked" the first page of my document's text box. I've pasted my text. Still no smart text reflow. I restarted Indesign and tried again.

What am I missing?

Adobe Community Professional
Correct answer by Steve Werner | Adobe Community Professional

I doesn't sound like you made the master page text box a Primary Text Frame. If it were, it would automatically generate a page after the first one.

Here's how they work:

https://indesignsecrets.com/indesign-basics-primary-text-frames.php

I believe that if you uncheck Limit to Primary Text Frames, you can get it to autoflow without Primary Frames, but only after you have created a new frame on a second page, linked to the frame on the first page as described in this article:

https://indesignsecrets.com/make-indesign-add-pages-automatically-as-you-type.php

"You can make Smart Text Reflow work on any text frame by turning off the limitation checkbox in the Preferences dialog box. However, in that case, you still won’t get it on every frame… it will only work for stories that are in frames that are already threaded across two or more pages! In other words, it won’t apply to any frame or story that is only on a single page. "

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Smart Text Reflow

New Here ,
May 02, 2018

Copy link to clipboard

Copied

Indesign CC 2018. I've set preferences to Smart Text Reflow/end of story/primary text frames. I've threaded my master page spread text boxes. I've "unlocked" the first page of my document's text box. I've pasted my text. Still no smart text reflow. I restarted Indesign and tried again.

What am I missing?

Adobe Community Professional
Correct answer by Steve Werner | Adobe Community Professional

I doesn't sound like you made the master page text box a Primary Text Frame. If it were, it would automatically generate a page after the first one.

Here's how they work:

https://indesignsecrets.com/indesign-basics-primary-text-frames.php

I believe that if you uncheck Limit to Primary Text Frames, you can get it to autoflow without Primary Frames, but only after you have created a new frame on a second page, linked to the frame on the first page as described in this article:

https://indesignsecrets.com/make-indesign-add-pages-automatically-as-you-type.php

"You can make Smart Text Reflow work on any text frame by turning off the limitation checkbox in the Preferences dialog box. However, in that case, you still won’t get it on every frame… it will only work for stories that are in frames that are already threaded across two or more pages! In other words, it won’t apply to any frame or story that is only on a single page. "

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 02, 2018 0
Adobe Community Professional ,
May 02, 2018

Copy link to clipboard

Copied

I doesn't sound like you made the master page text box a Primary Text Frame. If it were, it would automatically generate a page after the first one.

Here's how they work:

https://indesignsecrets.com/indesign-basics-primary-text-frames.php

I believe that if you uncheck Limit to Primary Text Frames, you can get it to autoflow without Primary Frames, but only after you have created a new frame on a second page, linked to the frame on the first page as described in this article:

https://indesignsecrets.com/make-indesign-add-pages-automatically-as-you-type.php

"You can make Smart Text Reflow work on any text frame by turning off the limitation checkbox in the Preferences dialog box. However, in that case, you still won’t get it on every frame… it will only work for stories that are in frames that are already threaded across two or more pages! In other words, it won’t apply to any frame or story that is only on a single page. "

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 0
Enthusiast ,
May 02, 2018

Copy link to clipboard

Copied

It would be better if you placed the text rather than pasting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 0
New Here ,
May 02, 2018

Copy link to clipboard

Copied

Wow, there's always something more to learn! Thank you. Making my master page text boxes "primary" by clicking on the little icon did the trick! Thanks so much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2018 0
Explorer ,
Sep 23, 2020

Copy link to clipboard

Copied

I'm having the same problem. Have spent many hours trying to figure out. I'd already found the above (excellent) articles and a video by David, and many other sources in case I was missing something...but it just won't work. Made a test Word file to import and it worked once, but then not with my "real" text file...and then not with the test file. (This after deleting everything, reapplying masters to get back to clean-slate and try again.) This really seemed like a great feature, I somehow never came across before, but I'm perplexed. TIA for any ideas.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2020 0
_BarbT LATEST
Explorer ,
Sep 23, 2020

Copy link to clipboard

Copied

So to update...I just kept trying to import the document and it finally worked, but, not 100%. I adjusted the text box on the master page to an odd size, so it would be easy to see. Once the text imported I reshaped the text box on the master page and it worked on the right-hand page, but inconsistently on the left. Weird.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2020 0