Locked

Spacebar to toggle Hand Tool is not working (CS5)

Explorer ,
Dec 16, 2010 Dec 16, 2010

Copy link to clipboard

Copied

In InDesign, using the spacebar to toggle the Hand Tool stops working.

When it stops working in InDesign, it also stops in Photoshop and Illustrator.

If I close the applications, and restart the machine - this combination starts working again, however after a while it stops working again.

Any assistance is greatly appreciated - you don't realize how much you use this 'til it goes away!

Matt

===============================

iMac 27" / 2.93 GHz Intel Core i7

8 GB Ram

OS X 10.6.5

Views

54.7K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advocate , Jul 16, 2015 Jul 16, 2015
It's because most browsers reserve the spacebar as a page down shortcut key.Regards,Pariah Burkehttp://iamPariah.com <http://iampariah.com/> • 503.422.7499 • @iamPariah<http://twitter.com/#!/@iamPariah> • https://www.facebook.com/PariahSBurkeConsulting & Training: ePublishing, Digital Publishing, Creative Workflows,Creative SoftwareInforming & Empowering Creative Professionals.™On Thu, Jul 16, 2015 at 10:14 AM, Steve Werner <forums_noreply@adobe.com>

Likes

translate

Translate

Translate
Advisor ,
Dec 16, 2010 Dec 16, 2010

Copy link to clipboard

Copied

What if you tap the Escape key first? Does that work?


Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 16, 2010 Dec 16, 2010

Copy link to clipboard

Copied

Tried the [ESC] key, same thing - still doesn't work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 16, 2010 Dec 16, 2010

Copy link to clipboard

Copied

I just noticed if I quit Google Chrome - it starts working again.

huh?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 16, 2010 Dec 16, 2010

Copy link to clipboard

Copied

Chrome must claim the space bar for some function or other.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 17, 2011 May 17, 2011

Copy link to clipboard

Copied

Me too. Spacebar works again after quitting Chrome.

Man, Chrome, between this and your flash issues, I think it's time we go our separate ways.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2016 Oct 26, 2016

Copy link to clipboard

Copied

THANK YOU SO MUCH!!! Just upgraded to macOS Sierra and I was having the same issue with the hand tool and magnifying glass. Turned off Chrome and everything is back to normal. It was driving me crazy!!

THANKS AGAIN!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2011 Jun 06, 2011

Copy link to clipboard

Copied

Hi,

Have just experienced the same problem myself - only I wasnt running Chrome. However, I was running Firefox - which had a MS Silverlight page loaded (may or may not be related) - and on quitting Firefox, the problem solved itself again. So seems it may not just be related to Chrome, but it does suggest some web technology interfering with the way InDesign interprets the space bar trigger.

Just my two penneth worth!

Miles

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 06, 2011 Jun 06, 2011

Copy link to clipboard

Copied

I would suggest you try changing tabs in Firefox. The last time I tried to reproduce this problem I couldn't, but if you have a good reproducible test case you should file a Firefox/buzilla bug...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 10, 2011 Jul 10, 2011

Copy link to clipboard

Copied

I've had the same situation -- Chrome causing the problem. Quitting Chrome solves the problem every time -- I've done it dozens of times now to solve the problem across PS, AI and InDesign.

Not sure if this is the case for anyone else -- but it seemed to happen only when I was running sites like Gmail and Twitter that update constantly in the background. Maybe that is a connection, maybe not.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 10, 2011 Jul 10, 2011

Copy link to clipboard

Copied

Not sure if this is the case for anyone else -- but it seemed to happen only when I was running sites like Gmail and Twitter that update constantly in the background. Maybe that is a connection, maybe not.

That technology is called AJAX, but I don't think it is the issue.

I think the source is web sites that define modifier keys in the browser -- somehow the act of doing so causes the browser to steal some keyboard handling events that it should not, and the Adobe apps no longer receive them, or no longer receive them in the same way.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jul 11, 2011 Jul 11, 2011

Copy link to clipboard

Copied

John Hawkinson wrote:

Not sure if this is the case for anyone else -- but it seemed to happen only when I was running sites like Gmail and Twitter that update constantly in the background. Maybe that is a connection, maybe not.

That technology is called AJAX, but I don't think it is the issue.

I think the source is web sites that define modifier keys in the browser -- somehow the act of doing so causes the browser to steal some keyboard handling events that it should not, and the Adobe apps no longer receive them, or no longer receive them in the same way.

Interesting that no OSs are mentioned. When I reported to the developer of TextExpander, a Mac keystroke macro tool, that the product stopped responding to its trigger shortcuts, the response was that some browsers caused it. Since then, I have been using Safari almost exclusively, with no recurrence. I'm not sure if newer releases of TextExpander have solved the problem, or if updated browsers no longer create it.

HTH

Regards,

Peter

_______________________

Peter Gold

KnowHow ProServices

    

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 11, 2011 Jul 11, 2011

Copy link to clipboard

Copied

I've only seen it on Macs, but I have not looked for it under Windows.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

just found myself suffering from the same problem: I tried deleting my preferences and that did not work.

I had Dreamweaver open at the same time - once I closed Dreamweaver everything seems fine (with InDesign) - hand tool/spacebar is working again. I'm using InDesign CS5, on an iMac, OS Version 10.6.8.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I've had this problem a couple of times in the last few months. I'm using CS5.5 on a Mac running OS 10.7.3. I have Safari, FF, and Chrome open simultaneously, all the time.

The first time, a few months ago, I found a solution online that, IIRC, was to go into keyboard shortcut in InDesign, and delete the setting for Hand Tool. I could be wrong about that tho. It did seem to solve the problem.

However, it just happened again today, and after reading the posts above, I tried something else. I had just opened Paypal.com in Firefox, and that's right when the Hand tool/Spacebar shortcut stopped working. I didn't realize it right away, but after quitting FF, the spacebar tool worked again. Then I re-opened FF, went back to Paypal (in a second tab), and the spacebar tool was non-responsive again. Closed that one tab in FF (Paypal.com), switched back to InDesign, and it works fine.

So, apparently Paypal.com on FF is the issue (of course, there could be many other sites that cause the same problem). I'm not sure what it is about the site/coding that renders the spacebar shortcut useless, but that's the problem, at least for me.

For what it's worth.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

It's a Mac OS security bit which blocks the modifier keys from working if there is an open port which has access. It's supposed to prevent malware from executing system events.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

That doesn't sound right. What do you mean by "an open port"?

If you mean an open TCP port, that's clearly not the case, since hundreds of apps do that and don't cause this behavior.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

I guess I mean something which has an open connection and does automatic downloads. Used to be Quicken was one which would cause this behavior.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

But everything from Safari to Firefox to ftp to the Adobe Updater meets that description. Do you have any documentation to suggest this is a deliberate system action to prevent malware, or is it just speculation?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2012 Mar 09, 2012

Copy link to clipboard

Copied

Sorry just what has worked in the past. Firefox (or at least some addons) has been reported as a problem as well.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 13, 2012 Jul 13, 2012

Copy link to clipboard

Copied

I already posted this to another thread, but I was having the same problem and found on the other thread that closing the browser seemed to fix the problem. This absolutely was the case on my iMac OS X Lion running Chrome and CS5.5. I then also discovered that I could reopen Chrome and not have the problem again AS LONG AS I didn't log in to LastPass. Every time I log into LastPass, I lose my spacebar grabber again and have to log out and restart Chrome.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

It was Dreamweaver (CS5) for me too, as reported above already. Once I closed it, InDesign CS5 and its hand tool returned to normal.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

Looks like this bug still exist today. Suddenly my InDesign stopped responding with space bar as well as command and option key combinations. Upon reading the posts above, realized that the latest version of Chrome was open. Just closed Chrome and problem solved.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 27, 2014 Apr 27, 2014

Copy link to clipboard

Copied

Windows 8

Go to  Metro UI> Settings > PC and Devices > Trackpad > Touchpad - 

  • Deactivate the Touchpad Delay.

Also:

I used a different wireless mouse which worked fine. The issue is possibly related to Mouse/Touch problems.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2014 Jun 23, 2014

Copy link to clipboard

Copied

I just experienced this same issue and the only browser I had open was Safari. I closed the browser and it fixed the issue.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines