Highlighted

Spaces Disappear When Importing Word Doc Into InDesign

Community Beginner ,
Jan 09, 2017

Copy link to clipboard

Copied

When importing a Word doc (MS Word 365 for Mac, El Capitan) into InDesign CC 2015, all of the spaces disappear - causing all of the text to run together.

The spaces in the Word doc we start with look fine, but when we import (not copy and paste, but import) it into InDesign, the spaces aren’t included.

Does anyone know why this happens and what we can do to stop it? Thanks!

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Spaces Disappear When Importing Word Doc Into InDesign

Community Beginner ,
Jan 09, 2017

Copy link to clipboard

Copied

When importing a Word doc (MS Word 365 for Mac, El Capitan) into InDesign CC 2015, all of the spaces disappear - causing all of the text to run together.

The spaces in the Word doc we start with look fine, but when we import (not copy and paste, but import) it into InDesign, the spaces aren’t included.

Does anyone know why this happens and what we can do to stop it? Thanks!

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

My guess would be that there is a default Paragraph and/or Text style that gets applied that has very very narrow tracking applied. What happend if you select al text, hold down Alt_Shift and click on the Basic Paragraph style in the Paragraph style panel? Does the 'reset' to the default font size etc. bring back the 'spaces'?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 21, 2017

Copy link to clipboard

Copied

Thanks - I think this is closest to the solution. We found that when a PDF is created, the exact kerning and tracking information must be discarded and the PDF renders it as well as it can.

When the PDF is converted to a Word doc, it re-interprets the kerning and tracking as font condensing (see “Fonts>Advanced”).

When a Word doc with text condensed this way is placed into InDesign, it apparently gets re-interpreted again, and if the text is condensed too much, InDesign ignores the “space” character and runs the words together, removing the space.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

To proof if there are no spaces do one of the following:


1. Copy some text to the clipboard.
Paste it to a text editor.

2. Select some text and open InDesign's Story Editor window.
( Keyboard shortcut is cmd+y on a Mac )

Do "Show Hidden Characters" to be sure.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 09, 2017

Copy link to clipboard

Copied

Thanks for the suggestions - but the spaces are actually not there. Here are two screen shots: 1. the InDesign doc with some of the spaces not appearing (story mode), and 2. the original Word doc with the spaces intact.

1-InDesign-Story-mode.png

2-Word.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

Very strange indeed. What are your InDesign import setting, keep or remove formatting on place? And: is the source .doc or .docx? Maybe you can share the Word file so we can have a look?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 09, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

I will try here and will get back to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

I tested with your file, with and without formatting as import option: no problem, all is well all spaces are there.

See first screenshot.

Screen_Shot 2017-01-09 om 23.00.55.png

Can you select the text that has the problem in InDesign,  make everything Basic Paragraph style with a Alt-shift click and then make a screenshot for Paragraph style settings (should now read Basic Paragraph with no plus sign) and the Text style setting (should read 'None'). Also make sure to see if all kerning is set to zero (the field under 'metric' in the Control panel).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

Hi Frans,

I can confirm some problems.

But nothing that I cannot also see in your screenshot.
See e.g. INDICATIONS AND USAGE section.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 09, 2017

Copy link to clipboard

Copied

Opened the Word document in Word 2011 for Mac and can see that the missing white space also is missing in Word.

Here the text I'm referring to:

TEST is also indicated for patients with:Exposure keratitisDecreased corneal sensitivityRe- current corneal erosionsTEST (hydroxypropyl cellulose ophthalmic insert)

It seems that after "with:" a list should be started, but is not formatted correctly. Line ends or paragraph signs are missing.
Also watch out for "Re- current" where a soft-hyphen turned somehow into a hard one.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Jan 10, 2017

Copy link to clipboard

Copied

I tested it on a win7 machine with cc2017 and I'm seeing the same problems. My guess, something went wrong in the Word file. Was it created from scratch, or was it generated (some kind of export to a Word-flle) by software?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 10, 2017

Copy link to clipboard

Copied

Seeing the same things: if spaces are not there they aren't in the original Word file as well. It is not an InDesign thing we can conclude. Please mark an answer as correct, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 12, 2017

Copy link to clipboard

Copied

Hi Kofi,

did you investigate the source of the docx file?
Is it really Word?

Or was it saved as docx e.g. from a PDF by Acrobat Pro (DC) ?
( Just to name one example. )

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 17, 2017

Copy link to clipboard

Copied

Hello All-

I work w/Kofi - -the person who posted this question. What is happening is that we are receiving client files that have pdfs placed in the InDesign document as text. We need to edit the text on these files and recreate as a real InDesign file with live editable text. If try opening the pdfs in Illy and then bring into Indesign, as live type, all of the formatting goes away. So what we have been experimenting with is going from Pdf to Word and then bringing in the formatted text into Indesign. Its true that the file that we sent as an experiment had some issue going from the PDF to the Word doc. However, we have experienced the same problem, in general, going from a Word doc that had been converted from a PDF, but came out clean--and then when we bring it into InDesign we have the no space issue in places. If you have any suggestions as a workaround to what we are doing please let us know. The pdf2doc website works fairly well - -but does sometimes do the same thing with spacing. My best guess is that it is a font issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jan 17, 2017

Copy link to clipboard

Copied

It's a workflow issue. What you're doing is akin to putting an egg back in the shell after making an omelet and then making a different omelet. I'd love to give you more positive news but PDF is an end product, not something to be used like this.

Best bet is to get the original document from which the PDF was created.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 17, 2017

Copy link to clipboard

Copied

Bob - -Ya know I love ya - -you have answered sooo many questions for me over the years - -but you have to realize that if your answer was an option I wouldn't be posting this!  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jan 17, 2017

Copy link to clipboard

Copied

You’re not the only one reading this stuff. Lots of lurkers and people need to understand the facts. Sorry if I wasted your time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 17, 2017

Copy link to clipboard

Copied

To all you lurkers who need to understand the facts... Bob's the Best!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 17, 2017

Copy link to clipboard

Copied

What is happening is that we are receiving client files that have pdfs placed in the InDesign document as text. We need to edit the text on these files and recreate as a real InDesign file with live editable text.

Alright, going from PDF to Word using Acrobat's export functionality is the problem here.

I'd suggest you have to analyze the PDF to find out why there are missing spaces.

Analyzing can be done very deeply exploring the PDF's structure using one of the menu options of Acrobat's Preflight panel.

Without having access to the PDF I cannot tell more.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 18, 2017

Copy link to clipboard

Copied

Right - - the issue lies in the conversion. The PDFs we are using are not missing spaces. It's after we convert to Word that the spaces get lost in some cases. The sample Word doc that was uploaded was already flawed. We didnt realize that at the time. I'm not sure I can supply you with the pdfs we are receiving from clients for proprietary reasons - -but maybe I can fake something. Thank you, Uwe.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 09, 2017

Copy link to clipboard

Copied

The Word file is a .docx, and here is a screen shot of the InDesign import settings:

3-import-settings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
seaj0725 LATEST
New Here ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi!

I don't know if you've solved this already, because I also had a hard time in looking for solutions. But I just want to share what I did that might work as well with the others.

-Open the Word file
-Find and replace all the spaces with space, then save the Word file.
-Place the Word file in Indesign.

It works. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...