Highlighted

Spelling suggest capitalization of each word

Community Beginner ,
Jun 29, 2020

Copy link to clipboard

Copied

Hi,

I have a problem with some indd files which I received from someone. When I open them, I see that all words except the first one in each sentence are underlined with green. When I right click these, InDesign suggest to capitalize them. When I capitalize, the green line disappears.

When I type some text in different indd file and copy that text box and paste it to such "problematic" indd, the text is automatically underlined with green - even if it was not in the other file. When I copy text box from the "problematic" indd and paste it in another document, the issue doesn't occur.

It looks to me that there must be some rule set in that particular indd that forces spelling check to make sure all words are capitalized.

Any idea where that is set and how to switch it off?

Thanks in advance for your help.

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Hi Przemyslaw:

 

I know a fair amount about InDesign but have no experience with Polish, as previously mentioned. I see you that you are using a dictionary that I am also not familiar with—Winsoft. I believe it is a plug-in for InDesign—purchased separately. Changing the dictionary to Hunspell or Proximity fixes the issue, but may cause issues with spellcheck and hypenation that I won't recognize. 

 

If it does, I'd suggest reaching Winsoft Tech support for help: https://store.winsoft-international.com/technical-contact/.

 

~Barb 

 

polish.gif

TOPICS
How to, Type

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Spelling suggest capitalization of each word

Community Beginner ,
Jun 29, 2020

Copy link to clipboard

Copied

Hi,

I have a problem with some indd files which I received from someone. When I open them, I see that all words except the first one in each sentence are underlined with green. When I right click these, InDesign suggest to capitalize them. When I capitalize, the green line disappears.

When I type some text in different indd file and copy that text box and paste it to such "problematic" indd, the text is automatically underlined with green - even if it was not in the other file. When I copy text box from the "problematic" indd and paste it in another document, the issue doesn't occur.

It looks to me that there must be some rule set in that particular indd that forces spelling check to make sure all words are capitalized.

Any idea where that is set and how to switch it off?

Thanks in advance for your help.

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Hi Przemyslaw:

 

I know a fair amount about InDesign but have no experience with Polish, as previously mentioned. I see you that you are using a dictionary that I am also not familiar with—Winsoft. I believe it is a plug-in for InDesign—purchased separately. Changing the dictionary to Hunspell or Proximity fixes the issue, but may cause issues with spellcheck and hypenation that I won't recognize. 

 

If it does, I'd suggest reaching Winsoft Tech support for help: https://store.winsoft-international.com/technical-contact/.

 

~Barb 

 

polish.gif

TOPICS
How to, Type

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 29, 2020 0
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

You can control what InDesign flags as incorrect in Preferences > Spelling, but it is InDesign-wide, not handled file-by-file. 

spelling.png

 

Are you using paragraph styles? Could you show us the paragraph style definition for the paragraph that's doing this?

 

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 2
Community Beginner ,
Jun 29, 2020

Copy link to clipboard

Copied

Thanks Barb for quick response.

I know I can switch that chck off, but it's just a way to ignore the issue, while I want to resolve it 🙂

It is odd because when I have 2 documents open, then one behaves correctly, second not. That's why the root cause will not be in general settings but rather in document settings. I just don't know where can I find that.

 

Answering your question: there is no style set for these text frames:screen_1.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Community Beginner ,
Jun 29, 2020

Copy link to clipboard

Copied

I made additional test. I opened this "problematic" indd, created two text boxes, put some text in English and German to them and changed these text boxes language accordingly. It looks that English and German works well. Only when I have text written in Polish language and the text box language is set to Polish, then InDesign suggests to capitalize all words.

And that happens only to documents which I received from one source. I saved the file as idml and reopened, but that didn't help.

Do you have any idea what can be wrong and how to fix this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

there is no style set for these text frames

Object styles impact frames, paragraph styles impact paragraphs, and I'm suspecting a paragraph style issue.

 

Let try this... can you share a page (or more) of the file so that I can take a look at the file settings? That is probably the quickest way. You can post a link to the file here (public) or message me directly (private). I don't need the linked images, just a page of the problem InDesign file.

~Barb

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 1
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

Only when I have text written in Polish language and the text box language is set to Polish, then InDesign suggests to capitalize all words.

Hmmm. I'm not sure what is going on there and I don't have any experience with Polish text in InDesign. I'm still happy to take a look, but you may want to wait for someone else with Polish experience to weigh in.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 1
Community Beginner ,
Jun 29, 2020

Copy link to clipboard

Copied

Thanks. I just sent you a link to sample page (private).

Hope you will be able to replicate the problem and find the solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Adobe Community Professional ,
Jun 29, 2020

Copy link to clipboard

Copied

Hi Przemyslaw:

 

I know a fair amount about InDesign but have no experience with Polish, as previously mentioned. I see you that you are using a dictionary that I am also not familiar with—Winsoft. I believe it is a plug-in for InDesign—purchased separately. Changing the dictionary to Hunspell or Proximity fixes the issue, but may cause issues with spellcheck and hypenation that I won't recognize. 

 

If it does, I'd suggest reaching Winsoft Tech support for help: https://store.winsoft-international.com/technical-contact/.

 

~Barb 

 

polish.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 2
Community Beginner ,
Jun 30, 2020

Copy link to clipboard

Copied

Thank you Barb.

That indeed was the issue. I checked and on all other documents I have the Dictionary is set to Hunspell while on this one it is WinSoft.

As I wrote - I received this file from someone to rework it a bit, so I don't know why the other dictionary was used.

On the other hand - I assumed the Preferences->Dictionary is a general setting rather than documen specific, but apparently it is not.

Thanks for solving the issue!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 1
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

Hi Przemyslaw:

 

So glad we got you back on track! That was a new one for me—I don't think I would have recognized the issue if I hadn't been able to see your file. 😊

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 1