Splitting columns is causing the text to be out of order!

Community Beginner ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I split my text into two columns but the text is now out of order -see how the left column content should be on the right-. What do I do? 

TOPICS
Type

Views

194

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Nov 19, 2020 Nov 19, 2020
Let's take a look at the InDesign version you are using: Open the CC Desktop app.Click your avatar in the top right corner > Preferences > Apps.What version is checked? I can see from your screen shots that you have an English-language version installed. Which one is it?   ~Barb         

Likes

translate

Translate

Translate
Adobe Community Professional , Nov 19, 2020 Nov 19, 2020
Hi honey620, there could be an explanation for this behavior: The story direction of the text frame is set to Right-to-Left. That would be typical for a text frame of a document with RTL text like you would need it with Hebrew or Arabic. You could tell if this is the cause if you select the frame and check the in- and out-ports of the frame:   Story direction left-to-right, the in-port is at the upper left, the out-port is at the lower-right:   Story direction right-to-left, the in-port is at t...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Information that would help us help you: Please tell us what operating system (exactly) you're running. Please tell us (exactly) what InDesign version you're using. 

 

Show us what the text looked like BEFORE you "split text into two column" (turn on Hidden Characters when you make a screen shot). Exactly what command did you use to split into columns?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

When you reply, please use the image icon to embed your images in the post, so other users don't have to download them to view them.

Screen Shot 2020-11-17 at 4.45.12 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Hi @honey620:

 

When you split one column into two columns, the text runs down the first column, and then down the second column. split.gif

 

If the columns are reversed, are you using a Middle Eastern version of InDesign, or did the text come from an ME version of InDesign?

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I'm not sure, how do I check for that?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I copied the text from a Google Docs file, not another ID file.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

I'm using a PC Windows 10, I have the most updated version of InDesign CC. after.JPGbefore.JPG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Hi @honey620 :

 

Actually, I can see that either the text is designated Middle Eastern or you have a Middle Eastern version installed by looking more closely at the screenshot that you posted of the paragraph panel. Directly under the left alignment button I see the left to right and right to left icons. Those don't normally appear in the English versions of the software.

 

Start by unsplitting, then change your paragraph composer from the World Ready Paragraph Composer to the Adobe Paragraph Composer. It's in the fly out menu from that same paragraph panel, top right corner. Resplit. Does that make a difference?

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Unfortunatly that did not work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

If you have currently a Middle Eastern version of InDesign ie. English يدعم العربية, you may fix the issue by simply opening "Story" panel which can be found under Window > Type and Tables > Story.

Select the text frame in question and switch story direction as shown here…

story-direction.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

@Zaid Al Hilali:

 

I was hoping you would see this! (And I had no idea those icons were in the Story panel in the ME version.)

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

You nearly figured it out yourself up here Barb 😉

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 27, 2020 Nov 27, 2020

Copy link to clipboard

Copied

Nearly! 😂 But still needed you!

 

~Barb

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Let's take a look at the InDesign version you are using:

  1. Open the CC Desktop app.
  2. Click your avatar in the top right corner > Preferences > Apps.
  3. What version is checked? I can see from your screen shots that you have an English-language version installed. Which one is it?

 

~Barb 

 

cc.png

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Hi honey620,

there could be an explanation for this behavior:

The story direction of the text frame is set to Right-to-Left. That would be typical for a text frame of a document with RTL text like you would need it with Hebrew or Arabic. You could tell if this is the cause if you select the frame and check the in- and out-ports of the frame:

 

Story direction left-to-right, the in-port is at the upper left, the out-port is at the lower-right:

LTR-InPort-UpperLeft.PNG

 

Story direction right-to-left, the in-port is at the upper right, the out-port is at the lower-left:

RTL-InPort-UpperRight.PNG

 

So in effect, if you do Span Columns to All you get the following results.

With story direction left-to-right:

SpanColumnsAll-LTR-StoryDirection.PNG

 

 

With story direction right-to-left:

SpanColumnsAll-RTL-StoryDirection.PNG

 

To change the story direction of the parent story of a selected text frame to LTR, use this script code written in ExtendScript (JavaScript) :

 

app.selection[0].texts[0].parentStory.storyPreferences.storyDirection = 
StoryDirectionOptions.LEFT_TO_RIGHT_DIRECTION;

 

How to save script code to a script file and to install that script file, see:

https://www.indiscripts.com/pages/help#hd0sb2

 

Regards,
Uwe Laubender

( ACP )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines