Highlighted

Strange icons appear in file - how to get rid of them?

Community Beginner ,
May 05, 2017

Copy link to clipboard

Copied

I have some InDesign files who act very strange. When I copy some of the textframes, I was noticed about this problem because you can't see it otherwise.

The text was left aligned and after pasting into another file it's right aligned?!

No use of styles, no specials into the textfame-options,....?

When making another textframe, it also appears! Where does it come from? And even more, how can I delete it?

I can't select it, can't do anything with it in the Story Editor, nor see it in the file itself.

Many thanks already to help me!

Screen Shot 2017-05-05 at 09.17.22.png

Correct answer by M_ries_Lab | Community Beginner

solved: it was made with an Arabic- version of InDesign.

I installed the language-settings of English-arabic and reopened the file without any issue.

I hoped this could be done in an other way. There are much more features in paragraph-settings and binding-settings it isn't comfortable for some or our customers to work this way.

Thanks for all of your replies!

Views

811

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Strange icons appear in file - how to get rid of them?

Community Beginner ,
May 05, 2017

Copy link to clipboard

Copied

I have some InDesign files who act very strange. When I copy some of the textframes, I was noticed about this problem because you can't see it otherwise.

The text was left aligned and after pasting into another file it's right aligned?!

No use of styles, no specials into the textfame-options,....?

When making another textframe, it also appears! Where does it come from? And even more, how can I delete it?

I can't select it, can't do anything with it in the Story Editor, nor see it in the file itself.

Many thanks already to help me!

Screen Shot 2017-05-05 at 09.17.22.png

Correct answer by M_ries_Lab | Community Beginner

solved: it was made with an Arabic- version of InDesign.

I installed the language-settings of English-arabic and reopened the file without any issue.

I hoped this could be done in an other way. There are much more features in paragraph-settings and binding-settings it isn't comfortable for some or our customers to work this way.

Thanks for all of your replies!

Views

812

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 05, 2017 0
Adobe Community Professional ,
May 05, 2017

Copy link to clipboard

Copied

How was the file created? Was it imported from Word? Also, what version of InDesign are you using (exactly)? What happens when you create a file from scratch: does it always occur?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Most Valuable Participant ,
May 05, 2017

Copy link to clipboard

Copied

Looks like you're pasting into a file with some kind of Right to Left language enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Community Beginner ,
May 05, 2017

Copy link to clipboard

Copied

Hi Bob, also an option! how can it be disabled?

I work in cc17 - it was an option (document settings) in cs6, but I can't find it anymore?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Most Valuable Participant ,
May 05, 2017

Copy link to clipboard

Copied

First off, is your version of InDesign capable of RTL? If so, it should be in the paragraph/paragraph style options, but to be clear, I'm not 100% sure that's what this having never used those features.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Community Beginner ,
May 05, 2017

Copy link to clipboard

Copied

What does this sign/icon means? RTL alignment?

the strange file is LTR when pasting into a fresh page of any other .indd it changes the text to RTL alignment. Then it starts to act strange... even any new textframe in this file has this issue...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Most Valuable Participant ,
May 05, 2017

Copy link to clipboard

Copied

As I said, I've never used RTL languages or Mid East version of InDesign. I'm pretty much guessing at this point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Community Beginner ,
May 05, 2017

Copy link to clipboard

Copied

It's somewhere in the file. Any new textframe has the same issue...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2017 0
Adobe Community Professional ,
May 06, 2017

Copy link to clipboard

Copied

Hm…

Looks similar to the strange character in this thread:

6. Re: InD CC 2017: Tables - Header & Footer disappears when duplicating the table.

https://forums.adobe.com/message/9496853#9496853

StoryEditorView-OversetHeaderOfTable.png

Also have seen this with table cells in my German version of InDesign CC 2017.
But never in a usual text frame.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2017 1
Adobe Community Professional ,
May 06, 2017

Copy link to clipboard

Copied

What does this sign/icon means? RTL alignment?

the strange file is LTR when pasting into a fresh page of any other .indd it changes the text to RTL alignment. Then it starts to act strange... even any new textframe in this file has this issue...

I'm not sure, but I think the problem with the "special character" showing in table cells when viewed by the Story Editor is gone with CC 2017.1 version 12.1.0.56.

Did some tests with older CC 2017.0 documents where this was a problem and I cannot see the special character in the latest version of InDesign. I have both versions installed side by side.

Document opened in CC 2017.0 showing the "special characters":

StrangeCharacter-StoryWindow-TextCell-CC-2017-v12.0.0.81.indd.png

Same document opened in CC 2017.1 not showing the "special characters":

StrangeCharacter-StoryWindow-TextCell-CC-2017.1-v12.1.0.56.indd.png

If the OP provides the document on a download service like Dropbox and post the link I'd like to see into this.

At least the bug showing the special characters in table cells with the Story Editor seems to be fixed.

// EDIT POST:
Tested with German InDesign versions on German OSX 10.10.5.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2017 1
Adobe Community Professional ,
May 06, 2017

Copy link to clipboard

Copied

Maybe in other locale versions or in the international version this is not fixed yet?

In this thread as mentioned above:

InD CC 2017: Tables - Header & Footer disappears when duplicating the table.

the phenomenon of showing a special character in Story Editor is still visible and the version must be 12.1.0.56 because it is discussing a bug showing up with duplicating tables that is version-12.1.0.56-only.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2017 0
Community Beginner ,
May 07, 2017

Copy link to clipboard

Copied

It had nothing to do with tables. It appears in every textframe.

it has something to do with the Adobe composer vs word composer. And RTL like Bob said.

I however can't find how you can fix this without installing Arabic/hebrew or CJK languages.

If I receive files like this, I want to change the RTL into LTR without any issue (I don't need the language change).

If I change the paragraph to Adobe composer, no issue is shown. But only for new textframes, how can  I change the aligment of existing frames? And preferably without language-installs.

I have found some scripts for Illustrator, but this must be already into InDesign I really hope so!

someone? Thanks already!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2017 0
Adobe Community Professional ,
May 07, 2017

Copy link to clipboard

Copied

Some things you could test perhaps:

1. Would the problem go away, if you drag the text to a new text frame?
Then this bug is coupled directly with the text frame from the MENA version.
You can enable dragging selected text in the Preferences panel.

2. Export the document to IDML and open again in InDesign.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2017 0