Highlighted

Synchronizing Master Pages Overrides Smart Text Reflow Setting

Explorer ,
Sep 09, 2020

Copy link to clipboard

Copied

Version: 15.1.2 x64 (windows)

Hello - 

 

We have a number of book files and within each book, there are multiple documents of a page or 2 each. These documents have Smart Text Reflow turned on, as we want the text or images to flow onto a second page if necessary.

 

In all, there are somewhere in the realm of 5500 .indd files in our project. Recently, we have been asked to remove a line from the footer (which exists on master pages A and B). I thought that I would create a file with the correct footer on master pages A and B, insert that into each book, and sync the files within the book to that inserted file. This was the process I used for when we updated object and paragraph styles, which worked like a charm. It doesn't seem to be as "charming" for master page synching. 

 

When I bring in my page to synch, set it as the style source, select the files to synch, go to the synch options, disable everything except Master Pages, and finally synch the files, everything seems to look ok; the correct line of text has been removed from the footer of the page. However, it behaves differently. What had previously had Smart Text Reflow enabled, still seems to have it enabled, but a newly inserted image or additional text does not automatically flow onto the next page in the document. 

I do not have the different elements in the master page in different layers; everything resides within Layer 1 on the Layers panel. In hindsight, maybe this was a bad idea, and I'd adjust for the next time I set something up, but it's what we have to live with in my group right now.

 

I would really rather not have to open each of the ~5500 documents and manually remove the line from the master A and B footers.  I am at a loss as to how I can make this work. Any insight would be greatly appreciated. 

 

Sandra C

I'm replying to myself - I think that the way I was going about it has been incorrect. Using a synched master page is not the best solution, so instead, I'll open my books and do a Find/Replace in all files. I had no luck finding a script, as Scott suggested - admittedly, I didn't look for long, figuring that I'd try the find/replace function first. 

Hopefully, if someone else is trying to synch a master page and they don't have luck, they'll try a different solution - maybe even the find/replace function will work for them.

Topics

Import and export, InCopy workflow, Sync and storage, Type

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Synchronizing Master Pages Overrides Smart Text Reflow Setting

Explorer ,
Sep 09, 2020

Copy link to clipboard

Copied

Version: 15.1.2 x64 (windows)

Hello - 

 

We have a number of book files and within each book, there are multiple documents of a page or 2 each. These documents have Smart Text Reflow turned on, as we want the text or images to flow onto a second page if necessary.

 

In all, there are somewhere in the realm of 5500 .indd files in our project. Recently, we have been asked to remove a line from the footer (which exists on master pages A and B). I thought that I would create a file with the correct footer on master pages A and B, insert that into each book, and sync the files within the book to that inserted file. This was the process I used for when we updated object and paragraph styles, which worked like a charm. It doesn't seem to be as "charming" for master page synching. 

 

When I bring in my page to synch, set it as the style source, select the files to synch, go to the synch options, disable everything except Master Pages, and finally synch the files, everything seems to look ok; the correct line of text has been removed from the footer of the page. However, it behaves differently. What had previously had Smart Text Reflow enabled, still seems to have it enabled, but a newly inserted image or additional text does not automatically flow onto the next page in the document. 

I do not have the different elements in the master page in different layers; everything resides within Layer 1 on the Layers panel. In hindsight, maybe this was a bad idea, and I'd adjust for the next time I set something up, but it's what we have to live with in my group right now.

 

I would really rather not have to open each of the ~5500 documents and manually remove the line from the master A and B footers.  I am at a loss as to how I can make this work. Any insight would be greatly appreciated. 

 

Sandra C

I'm replying to myself - I think that the way I was going about it has been incorrect. Using a synched master page is not the best solution, so instead, I'll open my books and do a Find/Replace in all files. I had no luck finding a script, as Scott suggested - admittedly, I didn't look for long, figuring that I'd try the find/replace function first. 

Hopefully, if someone else is trying to synch a master page and they don't have luck, they'll try a different solution - maybe even the find/replace function will work for them.

Topics

Import and export, InCopy workflow, Sync and storage, Type

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 09, 2020

Copy link to clipboard

Copied

I believe there's a script out there that does Find/Change through multiple book files. BTW, why are there book files with only a few pages each? Please explain?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 09, 2020

Copy link to clipboard

Copied

Hi Scott - 

The reasoning behind it is that we are reusing content across multiple books, with different order of files for each book. I am essentially rebuilding training materials for different audiences. In simple terms, think of a powerpoint presentation - each slide is a document, and the book is the full presentation. 

 

We normally would build our training pubs in FrameMaker, but due to the requirements of a number of interactive elements, we are building those elements into the source files, rather than after the PDF is created. Yes, it has to exist offline, in PDF format (not ePub), and have interactivity - the interactivity is not supported within FrameMaker. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 09, 2020

Copy link to clipboard

Copied

My first suspicion to what happened is the pages that had text flowed on them are no longer part of the primary text frame, but an overridden text box on top of a new, empty text frame. Can you move the existing text frame to the side and Cntl-Shft (Cmd-Shft) click on the page to see if there is another text frame below it?

 

One simple fix--if it works for your project--would to be not limit the smart text flow to just the primary text frame.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 09, 2020

Copy link to clipboard

Copied

That was my suspicion as well, and I tried to find an empty text frame. When I couldn't find one, I tried making a new file for synching, which had all the header and footer text boxes but the primary one removed. I still had the same issue with the smart text flow no longer being smart. 

 

Is there a way to turn off the smart text flow primary text frame check box for all files within the book? I don't mind having to do this for all books, but it will definitely be tedious to do this for all documents. I know where the setting is in preferences, but I thought that only worked for new files, not existing ones. (Sorry, I'm not overly versed in InDesign, so I'm not sure what can be done globally, and what only works on a per-file basis.) 

 

Thank you for your help! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 09, 2020

Copy link to clipboard

Copied

I'm replying to myself - I think that the way I was going about it has been incorrect. Using a synched master page is not the best solution, so instead, I'll open my books and do a Find/Replace in all files. I had no luck finding a script, as Scott suggested - admittedly, I didn't look for long, figuring that I'd try the find/replace function first. 

Hopefully, if someone else is trying to synch a master page and they don't have luck, they'll try a different solution - maybe even the find/replace function will work for them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...