Table Border Won't Go Away

Contributor ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

I have tried every way I can see to try but no matter what I do, the inner borders of my table continue to print. Everything I look at for the table, the rows, the columns, and even each individual cell, is telling me that no border should appear. When I print it, however, or export it as a .pdf, the inner border is still there.

What I most want is a bottom border for the header row and a top border for the footer row but I would gladly take no borders at all over having borders everywhere. Does anyone have any idea what I'm doing wrong?

I'm using CS4 and I'm a novice.

Views

67.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Sep 10, 2010 Sep 10, 2010
Strokes applied to cells of tables can easily be obscured by guides. Hide guides and frame edges and then you will be able to verify whether strokes have been applied.As for applying strokes to one side of a cell, select the row of the table. Then, in the cell options (Note: what I have illustrated is from the control panel, but this can be found in various places.) select the appropriate part of cell you wish to change.

Likes

Translate

Translate
Adobe Community Professional ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

Strokes applied to cells of tables can easily be obscured by guides. Hide guides and frame edges and then you will be able to verify whether strokes have been applied.

As for applying strokes to one side of a cell, select the row of the table. Then, in the cell options (Note: what I have illustrated is from the control panel, but this can be found in various places.) select the appropriate part of cell you wish to change.

table.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

I've been doing that. It doesn't remove the border, no matter how many times I click on it to remove it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

There is a Table Border, as well as applying strokes to cells within a table. Perhaps, you have turned off cell strokes, but the table border is on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

I should have posted a screen shot to start with, to save you the extra typing. I can't see anyplace, anywhere, that shows there should be a border anyplace, anywhere. It still prints one, though.

Table2.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

OK, you don't have a table border, but you can still have cell strokes turned on. With the table selected, go to Table > Cell Options > Strokes and Fills and make sure all the cell strokes sides are selected then Color: None. After this you should have no stroke applied.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

That cleared the border! I could have sworn I had already done that several times but I must have been doing something slightly different. I still can't get the two lines I want without getting the ones I don't want but this is definitely better! Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

Cell strokes are a little tricky, it depends on what you have selected of the actual table and what you hightlighted blue in the diagram of cell options. In your case, turn off all strokes. Then select the header row, then in cell options, highlight just the bottom portion, apply stroke: color, weight, etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

3 ideas

a) sure no stroke and no color applied by the two side of the stroke ?

b) No table or cell style applied ? perhaps look about standard style how they look

c) is there another cell inside your cell that wouldn't have selected ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

lemaquettiste.com wrote:

3 ideas

a) sure no stroke and no color applied by the two side of the stroke ?

b) No table or cell style applied ? perhaps look about standard style how they look

c) is there another cell inside your cell that wouldn't have selected ?

a) no

b) no

c) no

It's the first table I've ever even tried to make, on a fresh install, using a computer that hasn't ever had InDesign on it, in a newly-created document that I'll be using as a template for future documents. I did just try creating a table style to see if it helped me see options I wasn't seeing but that didn't help anything.

What I have just discovered interesting is that, upon coming home (I'm posting from my home account now) and loading it into my trial of CS5, I was able to easily change the border exactly the way I want it with no trouble.

Thank you both for your assistance. I don't know what the problem actually is, but I know it must be rooted in the old version of InDesign. I'll just work on them to upgrade to CS5.

Message was edited by: Kyrna

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2010 Sep 10, 2010

Copy link to clipboard

Copied

Cell borders can be pretty tricky to diagnose. First, the cell style can have a border, but even if it doesn't borders can be applied manually cell by cell or to groups of cells. Insidiously, it seems to me that I've seen strokes that look like they are between cells, but are actaully applied as the top or bottom stroke on one cell and don't show up as exisiting when you select the cell on the other side.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2016 Nov 06, 2016

Copy link to clipboard

Copied

thank you! haha

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

Thank you so much!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 11, 2014 Aug 11, 2014

Copy link to clipboard

Copied

I know that this post was almost 4 years ago, but I was having the same problem and it was one of the first links in Google.  Anyway I thought I'd share my experience.

The key to the problem is that Adobe Strokes/Borders don't function like Word or Excel.  In Word or Excel when you deselect the frame/stroke it erases it or select a frame/stroke it turns it on.  However, in Adobe the selection is just that a selection; then you have to do something with it.

So, to erase all of your borders you don't deselect everything, you actually select everything and then change the weight to zero.  Then you select the borders you want to add and change the weight and style to whatever you are trying to do. For instance:

table.jpg

Everything else is erased here so highlighting the bottom stroke (as is shown) and changing the weight to zero would turn it off, deselecting the bottom stroke (as you would in Word or Excel) does nothing.  Similarly, if you would highlight all of the strokes on the box and select a zero weight it would remove all of them.  Select them all and add a weight and they all come on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2014 Aug 12, 2014

Copy link to clipboard

Copied

@masqu3rade – sometimes it's unfortunate to set the line width of a border to zero.

Instead go to to the Cells Options menu under the Table menu and chose the line style "None".

Option "None" is not available in the Control Panel.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 19, 2014 Sep 19, 2014

Copy link to clipboard

Copied

THANK YOU!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 10, 2014 Dec 10, 2014

Copy link to clipboard

Copied

Thanks for the explanation, masqu3rade. Just the help I needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

LATEST

Brilliant! Understanding that it works differently than Excel/Word made all the difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2017 Mar 03, 2017

Copy link to clipboard

Copied

I also had this problem, so I'd like to share my experience!

Well, in my case, I took over other designer's indesign file.

While I was writing contexts on a table, some weird thick lines which look like strikethrough appeared.

I did everything to erase it, but nothing worked for me.

If you're in my case, try to remove paragraph styles or character styles!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

One thing that confused me was that when you select a stroke it turns BLUE.  I thought BLACK was showing it as selected when I was trying to change a strokes property.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines