Highlighted

Table import from Word sets following space to -0p4

Community Beginner ,
Nov 11, 2020

Copy link to clipboard

Copied

I've got a document that has hundreds of tables. When i import (through place) all of the tables default to a 0p4 space before and -0p4 space after. I've set the default table prior to the import but the import ignores those settings. How do i get the after space set without touching each table

TOPICS
How to, Import and export

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Table import from Word sets following space to -0p4

Community Beginner ,
Nov 11, 2020

Copy link to clipboard

Copied

I've got a document that has hundreds of tables. When i import (through place) all of the tables default to a 0p4 space before and -0p4 space after. I've set the default table prior to the import but the import ignores those settings. How do i get the after space set without touching each table

TOPICS
How to, Import and export

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 11, 2020 0
Explorer ,
Nov 11, 2020

Copy link to clipboard

Copied

Most likely the tables are using the Default Table style.

  1. Open the Table Styles panel and edit it.
  2. In the Table Setup section, adjust the Space Before and Space After to what you'd like it to be.

 

This change will affect all of the tables in your document, unless you created a different table style and used it. I've never understood why the 4p/-4p settings were built into the default; they don't work for any of my designs and I permanently change the default to my settings (that is, change the Basic Table's defaults without a document being open; all future documents will have that new setting).

 

Tables_default-table-style_01.png

 

Sometimes, tables come in with the old +4/-4 pts spacing, in spite of my changes to the default Basic Table style. I find that the table has come in with overrides. In that case, select the entire table and click the icon to remove manual overrides.

Tables_manual-overrides_01.png

Let us know if any of this helps resolve the problem.

 

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
Community Beginner ,
Nov 11, 2020

Copy link to clipboard

Copied

Nope doesn't change a thing.

I edited basic table to be 0p0 before 2p0 after. No other table styles defined. Still imports with 0p4 and -0p4.

Went in an changed basic table default to 0p0 and 2p0 with no document open. Closed indesign and restarted. Default is at 0p0 and 2p0. Still imports at 0p4 -0p4. 

Very frustrated. Shouldn't be this hard.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
Explorer ,
Nov 11, 2020

Copy link to clipboard

Copied

Did you select the table and remove any overrides? (see the text above that's in between the graphics)

 

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
Community Beginner ,
Nov 11, 2020

Copy link to clipboard

Copied

The tables appear to be coming in as not [basic table] but [No Table Style]. If i then apply basic table that has to happen on each individual table and not document wide. And while changing from [no table style] to [basic table] then causes an override which you can take out but it takes two sections for each table. Not what i need.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
Explorer ,
Nov 11, 2020

Copy link to clipboard

Copied

Yes, I can see that. It's been a couple of years since I had to bring in a slew of tables and automatically format them, and something has definitely changed since then.

I've tried:

  • Creating a new table style and applying it as the default, which should then be applied by default to any incoming table. Doesn't work. I get [No Table Style} as well. This is a bug. File it with Adobe.
  • Using Place / Import Options to either remove all formatting, or map it. But this feature doesn't give us control over table formatting: it either allows the crud from MS Word (or other source) into the InDesign layout, or strips it out entirely. This is a shortcoming: ask Adobe to add this to the import options, giving us the ability to apply a particular table style to all incoming tables.
  • And it's not possible to Find/Replace for tables and apply a Table Style to them. We can apply paragraph, character, and object styles, but not Table styles. This is a shortcoming: file that with Adobe, too.

 

Please go to www.InDesign.Uservoice.Com and file these issue as a bug with a request to improve the import of tables.

 

Design + Accessibility | Author | Designer | Programmer | Trainer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0
Adobe Community Professional ,
Nov 11, 2020

Copy link to clipboard

Copied

I assume you mean a Word document? Wondering if there's something you could "grab" and use Find/Change. For example, if each table is inline, perhaps you could create a style that creates negative spacing between paragraphs. Something along these lines: https://creativepro.com/use-findchange-to-find-tables/. Just a direction to think about. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2020 0