Highlighted

Text and cross-references garbled in placed Word file

Participant ,
Aug 02, 2020

Copy link to clipboard

Copied

Having issues when trying to get placed Word files in InDesign to play nicely is nothing new, but this is a whole new level of messed up for me, and I’m hoping it will ring a bell for someone.

 

I have a book of about 600 pages that I need to typeset. It’s about a dozen Word files, and all files are full of internal cross-references (only within each individual file). I’ve just tried placing the longest of the chapters (about 160 pages in Word), and to my horror, I see that nearly all cross-references are completely garbled – they point to random places in the middle of the text rather than the numbered headings they were set to point to; and more importantly, they show no text in InDesign at all, appearing as just a single whitespace character.

 

In addition to this, even the main body text seems to have become garbled in places, seemingly at random. By way of example, the following text is in the original Word document:

 

“For relatives that are not connected in a straight line, such as uncles and aunts, cousins, nephews and nieces, the potentially relevant distinctions are between the paternal and the maternal line, and between blood relatives and relatives by marriage. Under the general term ‘uncle’, we may in principle distinguish between the blood relatives ‘father’s brother’ and ‘mother’s brother’ […]”

 

When placed in InDesign, that sentence ‘reads’ (if you can call it that):

 

“For relatives that are not connected in a straight line, such as uncles and aunts, cousins, nephews and nieces, the potentially relevant di etween the paternal and e, and between blood relatives and relatives by mar neral term ‘uncle’, we may in pr4.6.3en the blood relatives ‘father’s brother’ and ‘mother’s brother’ […]”

 

So there’s a cross-reference to 4.6.3 in the middle of a word (there’s no reference to that heading anywhere near this place in the Word document), and the entire sentence has been cut up and put back together which random chunks just completely missing. I’ve tried placing the file into a new document three times now, and the result appears to be more or less the same each time.

 

This sort of random garbling is a new one to me, and Google is being remarkably unhelpful. I’m guessing it’s probably related to the large number of cross-references, but I don’t actually know.

 

Does this ring a bell to anyone? Anyone know what might cause this and if there’s a way to fix it?

There is no index in the Word file – that wouldn’t make any sense. There are index markers (i.e., field codes of type XE), but I don’t think it’s even possible to place a Word file and exclude index markers, and at any rate, the index markers actually seem to be fairly intact. But cross-references are unrelated to indices, both in InDesign and in Word.

 

It’s true that this particular Word document has had some issues, including the most insane amount of style spawnage I’ve ever seen – there were over a hundred styles and almost every one of them had spawned ten copies of itself, resulting in far over a thousand styles in the document in total. Trying to get rid of all the style detritus at once just made Word crash repeatedly, so I had to do it in small chunks, saving regularly, which took ages.

 

But that has been taken care of, and the mess is gone, so I doubt that is the cause. I have of course already saved-as and also copied the text without the final paragraph mark into a new document to help clear up clutter, before placing the file in InDesign. This is standard procedure for me before placing any Word document in InDesign. The index markers in the Word document look clean, as far as I can tell.

 

Bizarrely, I just tried re-placing the Word document into the existing file where I had previously placed it – and somehow that seems to have fixed it! This time, I haven’t seen any garbled text (so far, at least). The first three times, I placed the file into a new document, whereas this time I placed it into an existing one.

 

Since placing it the first time, I had done some cleanup on paragraph styles (editing them into proper InDesign shape and getting rid of the little ‘imported-from-Word’ icon), master pages and things, to make a document I can use as a template; that may be what did the trick. When placing the Word file this time around, I could manually match paragraph and character styles to existing ones in the InDesign document. The only other thing changed is that I made the cross-references not appear as hyperlinks (it’s for a printed book, so hyperlinks aren’t needed); that may also be what fixed it.

Topics

Bug, Import and export

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Text and cross-references garbled in placed Word file

Participant ,
Aug 02, 2020

Copy link to clipboard

Copied

Having issues when trying to get placed Word files in InDesign to play nicely is nothing new, but this is a whole new level of messed up for me, and I’m hoping it will ring a bell for someone.

 

I have a book of about 600 pages that I need to typeset. It’s about a dozen Word files, and all files are full of internal cross-references (only within each individual file). I’ve just tried placing the longest of the chapters (about 160 pages in Word), and to my horror, I see that nearly all cross-references are completely garbled – they point to random places in the middle of the text rather than the numbered headings they were set to point to; and more importantly, they show no text in InDesign at all, appearing as just a single whitespace character.

 

In addition to this, even the main body text seems to have become garbled in places, seemingly at random. By way of example, the following text is in the original Word document:

 

“For relatives that are not connected in a straight line, such as uncles and aunts, cousins, nephews and nieces, the potentially relevant distinctions are between the paternal and the maternal line, and between blood relatives and relatives by marriage. Under the general term ‘uncle’, we may in principle distinguish between the blood relatives ‘father’s brother’ and ‘mother’s brother’ […]”

 

When placed in InDesign, that sentence ‘reads’ (if you can call it that):

 

“For relatives that are not connected in a straight line, such as uncles and aunts, cousins, nephews and nieces, the potentially relevant di etween the paternal and e, and between blood relatives and relatives by mar neral term ‘uncle’, we may in pr4.6.3en the blood relatives ‘father’s brother’ and ‘mother’s brother’ […]”

 

So there’s a cross-reference to 4.6.3 in the middle of a word (there’s no reference to that heading anywhere near this place in the Word document), and the entire sentence has been cut up and put back together which random chunks just completely missing. I’ve tried placing the file into a new document three times now, and the result appears to be more or less the same each time.

 

This sort of random garbling is a new one to me, and Google is being remarkably unhelpful. I’m guessing it’s probably related to the large number of cross-references, but I don’t actually know.

 

Does this ring a bell to anyone? Anyone know what might cause this and if there’s a way to fix it?

There is no index in the Word file – that wouldn’t make any sense. There are index markers (i.e., field codes of type XE), but I don’t think it’s even possible to place a Word file and exclude index markers, and at any rate, the index markers actually seem to be fairly intact. But cross-references are unrelated to indices, both in InDesign and in Word.

 

It’s true that this particular Word document has had some issues, including the most insane amount of style spawnage I’ve ever seen – there were over a hundred styles and almost every one of them had spawned ten copies of itself, resulting in far over a thousand styles in the document in total. Trying to get rid of all the style detritus at once just made Word crash repeatedly, so I had to do it in small chunks, saving regularly, which took ages.

 

But that has been taken care of, and the mess is gone, so I doubt that is the cause. I have of course already saved-as and also copied the text without the final paragraph mark into a new document to help clear up clutter, before placing the file in InDesign. This is standard procedure for me before placing any Word document in InDesign. The index markers in the Word document look clean, as far as I can tell.

 

Bizarrely, I just tried re-placing the Word document into the existing file where I had previously placed it – and somehow that seems to have fixed it! This time, I haven’t seen any garbled text (so far, at least). The first three times, I placed the file into a new document, whereas this time I placed it into an existing one.

 

Since placing it the first time, I had done some cleanup on paragraph styles (editing them into proper InDesign shape and getting rid of the little ‘imported-from-Word’ icon), master pages and things, to make a document I can use as a template; that may be what did the trick. When placing the Word file this time around, I could manually match paragraph and character styles to existing ones in the InDesign document. The only other thing changed is that I made the cross-references not appear as hyperlinks (it’s for a printed book, so hyperlinks aren’t needed); that may also be what fixed it.

Topics

Bug, Import and export

Views

40

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 03, 2020

Copy link to clipboard

Copied

When you File > Place the Word docx, be sure to click on Show Import Options.

This will bring you to a second dialog box where you can decide what to do with the Index from Word.

Your choices are to leave it out, or import an existing index as text.

https://helpx.adobe.com/indesign/using/creating-index.html

Sometimes the Word docx has issues. For troubleshooting, I often open the docx in Word, do a save-as and see if the problem occurs again. Some insert their cursor at the very end of a Word docx and backspace once, and then do a Save As and test again.

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Aug 03, 2020

Copy link to clipboard

Copied

There is no index in the Word file – that wouldn’t make any sense. There are index markers (i.e., field codes of type XE), but I don’t think it’s even possible to place a Word file and exclude index markers, and at any rate, the index markers actually seem to be fairly intact. But cross-references are unrelated to indices, both in InDesign and in Word.

 

It’s true that this particular Word document has had some issues, including the most insane amount of style spawnage I’ve ever seen – there were over a hundred styles and almost every one of them had spawned ten copies of itself, resulting in far over a thousand styles in the document in total. Trying to get rid of all the style detritus at once just made Word crash repeatedly, so I had to do it in small chunks, saving regularly, which took ages.

 

But that has been taken care of, and the mess is gone, so I doubt that is the cause. I have of course already saved-as and also copied the text without the final paragraph mark into a new document to help clear up clutter, before placing the file in InDesign. This is standard procedure for me before placing any Word document in InDesign. The index markers in the Word document look clean, as far as I can tell.

 

Bizarrely, I just tried re-placing the Word document into the existing file where I had previously placed it – and somehow that seems to have fixed it! This time, I haven’t seen any garbled text (so far, at least). The first three times, I placed the file into a new document, whereas this time I placed it into an existing one.

 

Since placing it the first time, I had done some cleanup on paragraph styles (editing them into proper InDesign shape and getting rid of the little ‘imported-from-Word’ icon), master pages and things, to make a document I can use as a template; that may be what did the trick. When placing the Word file this time around, I could manually match paragraph and character styles to existing ones in the InDesign document. The only other thing changed is that I made the cross-references not appear as hyperlinks (it’s for a printed book, so hyperlinks aren’t needed); that may also be what fixed it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...