Highlighted

Text disappears in text box after hitting enter

Community Beginner ,
Feb 23, 2010

Copy link to clipboard

Copied

Ok, I'm having major issues with type in inDesign and Photoshop CS4 for Windows.

When I draw a type box, I can type all I want just fine, but as soon as I hit enter, the type goes away.

In inDesign, I get the red plus sign at the bottom of the type box, and in photoshop, my type box goes away, and the history menu updates itself with "edit type layer".

Either way, I cannot create a line break and second line of text, which, in effect, makes this software completely and utterly useless to me.

I have referenced this previous thread which discusses numlock and multiple mapping of the enter key for various type functions.

http://forums.adobe.com/thread/575626?tstart=0

I am using an Alienware M15x laptop. My numlock is turned off, and frankly, the only way I can get the numlock to turn on is by enabling the on screen keyboard and hitting the numlock button there.

I have tried to go to the keyboard shortcut menu to remap the enter key, but I have no idea what I'm looking for there.

This seems to be a HUGE flaw with the Windows versions of this extremely expensive software, and I'm pretty upset about it.

I want to be able to do design work on the go with my PC laptop, but these flaws make it impossible...forcing me to have to wait until I can get to my desktop macs.

Booo!

Please help.

Views

35.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Text disappears in text box after hitting enter

Community Beginner ,
Feb 23, 2010

Copy link to clipboard

Copied

Ok, I'm having major issues with type in inDesign and Photoshop CS4 for Windows.

When I draw a type box, I can type all I want just fine, but as soon as I hit enter, the type goes away.

In inDesign, I get the red plus sign at the bottom of the type box, and in photoshop, my type box goes away, and the history menu updates itself with "edit type layer".

Either way, I cannot create a line break and second line of text, which, in effect, makes this software completely and utterly useless to me.

I have referenced this previous thread which discusses numlock and multiple mapping of the enter key for various type functions.

http://forums.adobe.com/thread/575626?tstart=0

I am using an Alienware M15x laptop. My numlock is turned off, and frankly, the only way I can get the numlock to turn on is by enabling the on screen keyboard and hitting the numlock button there.

I have tried to go to the keyboard shortcut menu to remap the enter key, but I have no idea what I'm looking for there.

This seems to be a HUGE flaw with the Windows versions of this extremely expensive software, and I'm pretty upset about it.

I want to be able to do design work on the go with my PC laptop, but these flaws make it impossible...forcing me to have to wait until I can get to my desktop macs.

Booo!

Please help.

Views

35.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 23, 2010 1
LEGEND ,
Feb 23, 2010

Copy link to clipboard

Copied

The problem is in the Keyboard driver, not ID. Complain to the laptop manufacturer.

You need to edit two shortcuts, both under the Type Menu product area: Insert Break Character: Paragraph Return (and the Num Enter key) and Insert Break Character: Column Break (change it to anything else). You may also need to chang the forced line break and frame break shortcuts (Shift + the enter keys).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2010 2
Community Beginner ,
Feb 23, 2010

Copy link to clipboard

Copied

this did not work.

i assigned new keys and key combos to the things you mentioned and i got the same result.

strangely, no matter if i had num lock on or off, the enter key in INDD's shortcuts menu was labelled as "num enter"

this is driving me crazy. blame alienware, blame adobe, i dont care...i just want this software to work properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2010 0
LEGEND ,
Feb 23, 2010

Copy link to clipboard

Copied

I see there was a typo (typical) in my last post. It should have said ADD the numenter key to those shortcuts. You might have to do it by pressing the regular enter key on your keyboard (in fact I'd really try that, since that's the key not being correctly recognized). You also have to save as a new set, and be sure you are using that set and not the defaults.

Take a deep breath and give it another shot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2010 0
Community Beginner ,
Feb 23, 2010

Copy link to clipboard

Copied

Ok I worked out a fix for this. Like you said, it was a total manufacturer issue, not an adobe issue.

Apparently, my laptop's BIOS version was incorrectly reading the enter key as "numpad enter".

I dont have a numpad, so this was the root of the confusion.

I tracked down a BIOS update and ran it, now I'm good to go.

Thanks for your help. I know how to remap my key shortcuts if I ever need to in the future now.

  cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2010 1
Community Beginner ,
Mar 12, 2010

Copy link to clipboard

Copied

I have an HP computer and keyboard and I am having the same problem with text disappearing when I hit enter. It appears to only happen with imported text. I have typed into text boxes without the return problem.  I use my number pad all the time so do not know how changing the keyboard sort cuts will influence any changes. Plus, I am not familiar with how to change shortcuts.

I have learned that going to the type menu > insert break character > paragraph return works but it is very cumbersome.

How do I need to change my return key to get this very expensive software to work properly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
Most Valuable Participant ,
Mar 12, 2010

Copy link to clipboard

Copied

I have an HP computer and keyboard and I am having the same problem with text disappearing when I hit enter. It appears to only happen with imported text. I have typed into text boxes without the return problem.  I use my number pad all the time so do not know how changing the keyboard sort cuts will influence any changes. Plus, I am not familiar with how to change shortcuts.

I have learned that going to the type menu > insert break character > paragraph return works but it is very cumbersome.

How do I need to change my return key to get this very expensive software to work properly?

You should start a new thread; it sounds like you're experiencing something rather different from the original poster.

When you say "imported" text - do you mean text you've copied and pasted into InDesign, or text that you've put in with File -> Place? What kind of files are you placing?

Assuming you're using InDesign CS4, you can find some of this text that is disappearing when you hit enter, and then look to see if it has No Break applied. It could appear in a number of places:

1) is there a Character Style applied to the text? Find out by opening the Character Styles menu, Window -> Type & Tables -> Character Styles. Is it set to "None," or is there a character style applied? If there is a charstyle applied, you can right click on the name of the charstyle, choose "Edit" and then go to Basic Character Formats. There's a checkbox there for "no break."

2) If there is no character style applied, then highlight a few words of text (you must highlight, just putting your cursor into the text is not enough) and then click on the button in the upper left hand corner of the InDesign window:

btton.png

and look to see if there is a check next to No Break.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
LEGEND ,
Mar 12, 2010

Copy link to clipboard

Copied

The "very expensive software" is working properly. It's your cheap hardware that is not.

The steps for editng the keybaord shortcuts are outlined above. If you don't understand them, I recommend you try to find a more experienced user locally who can show you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
LEGEND ,
Mar 12, 2010

Copy link to clipboard

Copied

I was a little harsh, and I apologize. If indeed it is the keyboard problem, though and you don't understand, you need to find someone who can guide you through editing Keyboard shortcuts. It isn't hard, really.

But Joel may be correct that you are experiencing something differnt entirely. It would help for you to start a new thread and describe in great detail exactly what happens, and what you are doing leading up to the point wher the text disappears, and add a couple of screen shots from just before and just after you hit enter so we can eliminate things like Keep options.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
Most Valuable Participant ,
Mar 12, 2010

Copy link to clipboard

Copied

a little harsh,

It's in the air these days.

Besides, I'd feel silly if it turned out that there was a separate shortcut context for placed content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
LEGEND ,
Mar 12, 2010

Copy link to clipboard

Copied

Joel Cherney wrote:


Besides, I'd feel silly if it turned out that there was a separate shortcut context for placed content.

You and me both. My suspicion is it's coincidence or keep options set in imported text styles.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
Most Valuable Participant ,
Mar 12, 2010

Copy link to clipboard

Copied

... keep options set in imported text styles.

Adobe User Forums Feature Request: facepalm emoticon.

Keep Options are a much more plausible cause for the not-OP's issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
Community Beginner ,
Mar 12, 2010

Copy link to clipboard

Copied

Joel, I am not sure what you mean by starting a new thread. The new material I placed in a new text box on a new page is less than a page wide and does not fill the text box.

I file > placed the text and it came from Word. I did not copy and paste it.

I do use CS4.

There are no character styles or paragraph styles applied to the text. This is something I will add as the pieces are placed.

The button to which you refer is in the upper right hand corner of my computer and the text to which you referred -- no break is unchecked.

This is not the first time I have had trouble with text disappearing. I usually manage to make an end run and correct the problem in Word and then place the text again. However, whatever method I use is time-consuming, tedious and frustrating.

No matter where I use the enter key in that text frame, text below the enter disappears and the out port then shows a plus (even though the text box is NOT full). If I click on the plus and add the text to a different text box, I get the text that disappeared. But that is not the result I want. If I try to take the text from the out port and put it back into the text box, where it belongs then I get text linked to text--a mess.

There must be a cure for this problem.

B

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
LEGEND ,
Mar 12, 2010

Copy link to clipboard

Copied

By start a new thread,  we meant post a new topic.

Can you package a smaple page that shows this problem and put it on a file shareing site like yousendit.com, then post a link here, so we can see the problem for real?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 0
Community Beginner ,
Mar 12, 2010

Copy link to clipboard

Copied

I do not know how to start a new "thread". All I know is that I worked on this disappearing problem for hours today and some yesterday and went on Adobe help to see if there were any answers. I do not know how to set key short cuts (yet). I rarely use this site and do not know my way around.

I described what happens. If you have more detailed questions. I can answer them. The only way I could eliminate the disappearing problem was to insert the paragraph break from the type menu instead of hitting the return key. So, there is something wrong that needs to be corrected. This does not happen in any of my other word processing programs when I hit enter. And note, the type >insert break > paragraph return does indicate that the "shortcut" is "enter"!!!!

B

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2010 1
Engaged ,
Mar 13, 2010

Copy link to clipboard

Copied

need answer wrote:

I do not know how to start a new "thread".

At the top of this page, next to your name, there is a link "New", click it and it will say "discussion". That starts a new thread.

Now, if you turn on Type > Show hidden characters and hit the enter key, do you see a little upside down arrow, like this:

frame break.jpg

That's the frame break character for which the return key on the numeric keypad is the shortcut. If you do see it, we've got the answer. If you don't, then we need to look for something else.

k

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2010 0
LEGEND ,
Mar 13, 2010

Copy link to clipboard

Copied

Ken has explained how to start a new thread. Please do that, and make two screen captures, one before you hit enter and one after. Both must have hidden characters visible (Type > Show Hidden Characters). Embed them in your post using the camera icon in the editing area where you type your message.

CameraIcon.png

We need to see the text and hidden characters across the full width of the text frame, all the way from where you are inserting the break to the top of the frame.

ALL text has styling applied. Text typed in InDesign starts with the [Basic Paragraph] style by default, but another stlyle can be chosen and will be come the default if not no text cursor is active. Character styles are not applied by default.  In Word the default style is "Normal" and it's likely that your import settings are to include the Word styles and formatting. It's impossible to know without examining the text what styles might or might not have been applied, or what local formatting was applied in addition to those styles in Word. That's why I also asked if you would post a sample file for examination.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2010 0
Community Beginner ,
Mar 13, 2010

Copy link to clipboard

Copied

See text below.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2010 0
LEGEND ,
Mar 13, 2010

Copy link to clipboard

Copied

There is nothing to see....

Did you read my post on how to embed a screen shot?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 13, 2010 0
New Here ,
Dec 19, 2014

Copy link to clipboard

Copied

Just to contribute here, I did a BIOS update (DELL Optiplex) and the problem has gone.
Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2014 0
Explorer ,
Mar 28, 2015

Copy link to clipboard

Copied

I just had that problem and found that it works if I use the enter key that is mixed in with the letters and not the one that is on the number pad. Much easier fix. I used the info that I read here--what I could understand anyway (also a very newbie) and when I opened the dialog on the type tab, I read the stuff inside the parenthesis and figured it out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2015 1
New Here ,
Apr 06, 2010

Copy link to clipboard

Copied

As dumb of a mistake this is, it has happened to me before. Sometimes your "leading" in the "Character" window is set way high, so that when you hit enter it puts multiple lines in between the lines of text. Maybe this isn't the case but I thought I would contribute for what it is worth.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2010 0
New Here ,
Sep 29, 2011

Copy link to clipboard

Copied

yes it works ...

the last solution

thank you raphx003

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2011 0
Daro1500 LATEST
New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

For what it's worth, I had the same issue. Working whith a HP laptop (dockingstation) and Win10Pro.  Wired HP keyboard with numpad. So when inserting text in a box and pressing the 'numpad'-enter button, the text disappeared.  However when pushing the 'characterpad'-enterbutton it goes fine. Good luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0