Highlighted

trouble with Minion 3 font characters

New Here ,
Apr 27, 2020

Copy link to clipboard

Copied

I'm working on a book with some pretty unusual transliteration characters, trying to represent ancient Near Eastern characters in English letters. My colleague and I were delighted last week to find that Minion 3 has all of the characters we could want, except a couple of them don't present correctly in InDesign. If I go to the Minion 3 page on fonts.adobe.com and paste in the sample that I'm attaching (v & a & u with macron and breve), all three look fine. But if I paste them into InDesign, only the v looks right; the other two put the macron over the letter and the breve out to the side. Unfortunately, there are several dozen of the u and the a combination in the book we are working on. I see this behavior in both regular and italic

 

Any ideas out there?

v-a-u with macron & breve.png

Thanks very much.

Phil

Topics

Type

Views

965

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

trouble with Minion 3 font characters

New Here ,
Apr 27, 2020

Copy link to clipboard

Copied

I'm working on a book with some pretty unusual transliteration characters, trying to represent ancient Near Eastern characters in English letters. My colleague and I were delighted last week to find that Minion 3 has all of the characters we could want, except a couple of them don't present correctly in InDesign. If I go to the Minion 3 page on fonts.adobe.com and paste in the sample that I'm attaching (v & a & u with macron and breve), all three look fine. But if I paste them into InDesign, only the v looks right; the other two put the macron over the letter and the breve out to the side. Unfortunately, there are several dozen of the u and the a combination in the book we are working on. I see this behavior in both regular and italic

 

Any ideas out there?

v-a-u with macron & breve.png

Thanks very much.

Phil

Topics

Type

Views

966

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 27, 2020

Copy link to clipboard

Copied

Hi Phil:

 

 But if I paste them into InDesign, only the v looks right

Try adding them through Window > Type > Glyphs.

 

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 28, 2020

Copy link to clipboard

Copied

What version of InDesign are you using? Your text indeed fails in my old, old CS4 (even with the World-Ready Paragraph Composer enabled), but it works flawless in CC 2020:

 

_Jongware__0-1588072880217.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 28, 2020

Copy link to clipboard

Copied

Hi Barb and Jongware,

 

Thanks much for your comments. They both make a lot of sense. However . . .

 

I've been looking in the glyph panel, Barb, and while I can find a/u with macron, and a/u with breve, I don't see either with both macron and breve. And adding a continuing macron to a/u with breve, or adding a continuing breve to a/u with macron, both give me the result I showed above. Further, I don't see a v with either in the glyph panel.

 

And Jongware, I am running ID CC 15.0.2, with the world-ready paragraph composer turned on. What did you type to get the results you got? Or, how did you enter those characters?

 

Phil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 28, 2020

Copy link to clipboard

Copied

I typed them in CS4 to check if they would fail. I already knew Minion Pro does not support this accent stacking but tested with Minion 3 to be sure. It didn't work, so I copied the glyphs (picked from the Glyphs panel) and pasted them into CC2020. No other action needed – I even checked if anything would change with enabling the World-Ready Composer, but that did not change anything for the worse.

(Make sure you pick the correct combining accents: the ones with Unicode values starting from U+300. There is another set that is spacing, by design.)

 

[...] Just tested again with Times New Roman, Arial, Minion 3, and Minion Pro. It only fails for the latter – and then only because that font doesn't contain the combining accents.

 

Placing accents upon any base character requires the font to have an OpenType feature called "mark"; furthermore, to stack any accent upon any other accent, it requires another feature called "mkmk". InDesign CS4 claims to support these two, even with the regular Paragraph Composer (as tested with Adam Twardoch's font Nadyezhda SL One), but it visibly does not work – not even with the World-Ready Composer.

It is not due to a fault in the font data but bad OpenType handling inside InDesign (quite ironic, since InDesign was to be the flagship application in 1999, to show off the brand new, Adobe-led, OpenType font format). It also fails for your five-year old version but it seems they finally got it right with the latest version.

 

So I dare say it works out of the box in CC2020.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 28, 2020

Copy link to clipboard

Copied

Sorry to say, I'm still missing something. First of all I meant to say I'm using CC2020, which is, I believe, 15.0.2. I'm not using a five year old version. Second, am I hearing that there is an "a" with both a macron and breve in the glyphs panel (which I don't see in my glyphs panel), or that there is an "a" with a macron (which I do see) to which you're adding a combining breve? And both the combining breves (0306) and combining macrons (0304) I've been working with show Unicode numbers in the glyphs panel that begin with Unicode: 03.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 28, 2020

Copy link to clipboard

Copied

Let me try putting it a different way. I can either type in the a with a macron (Unicode 0101), and then add the combining breve, or I can type in the plain a and then add the combining macron and the combining breve. But with all of those I get the result shown above. I think I've tried combining these in all the possible ways, but they all yield the same result. And I see your result, and that's exactly what I want, but I can't figure out how to get there from here.

 

If I change them to uppercase they work perfectly; back to lowercase, not so much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 29, 2020

Copy link to clipboard

Copied

I am at a loss. No, I do not have to do anything special, unexpected, or tricky. I just pick the characters v, macron, and breve from the Glyphs panel. (Well not that v – I typed it – but that really ought not make a difference.)

I disabled Minion 3 from Adobe Fonts and reinstalled it – it keeps on working. Also, as I said above, it already works as advertised with other OpenType fonts. Do check on your side if those other fonts work or not! If they do, it has to do with your Minion 3 (and a bout of font cache cleaning may be in order). If they don't, it has to do with your InDesign.

 

Something peculiar turned up on my old workhorse CS4, though. As before, after reinstalling Minion 3, I picked the glyphs from the Recently Used part of the panel, and as before it didn't work. However, I noticed the glyphs panel had saved the style as well: Italic, while my test text was in Regular. And hey! After selecting the entire text and changing it to Regular, it suddenly worked (still only with the World Composer enabled). Sorry, scratch that. The character 'a' is still a problem. I think it's because InDesign automatically uses the precomposed "ā" when it encounters a+macron, and then the next step, adding a breve at the top of the macron, fails. Anyway, this was when experimenting with CS4 so it isn't useful for the latest version.

 

(Apologies for the confusion about the version number. It has been the bane of my life ever since Adobe decided "InDesign 1.0" and "InDesign 2.0" should logically be followed by "InDesign CS", "CS2", etc. – and just when I got the hang of that and repeatedly having to verify with users that they can not be using "InDesign 3" because either it had to be "CS" or "CS3" ... they changed the numbering scheme again.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Thanks, Jongware, for sticking with this. I have tried the same thing with a couple of other fonts, and it all works fine. Just not with Minion 3, which, of course, is the font we want to use for the project. I'll try unstalling Minion 3 and reinstalling, and look into the font cache thing. If nothing else works I can do it the hard way, by adding a regular breve and then raising it and then kerning the heck out of it. That works, but obviously is not the preferred way of working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 29, 2020

Copy link to clipboard

Copied

>  raising it and then kerning the heck out of it

 

Yup. My modus operandi as well when all else fails. As a matter of fact, such accent wrangling was what inspired me to create IndyFont... (not a shameless plug -- you really should not be needing it!).

 

By now I'd really like to hear from anyone else if they can replicate either your result or mine? Do chime in, please. Both Phil & I could still be overlooking something basic.

 

Anyone?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...