Locked

UI Menu Bug in Indesign CC 2017

Participant ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Latest Indesign CC

Windows 10, i7, Quadro M1200

Ultra HD screen

Guys,

I'm going crazy about the top menu in Indesign (and Muse).

Every time I click a menu item, it selects the one to the right of it.

I cannot access any of the menus... basically making Indesign quite useless to me.

This strange offset with the mouse clicks happening since the latest update.

Btw: Same issue in Muse and Indesign!

Not in Illustrator, After Effects or Photoshop

Seems to me this is a programming bug or issue with supporting my screen / resolution.

Any word on this?

P.S. Made a similar post in the Muse forums, see UI bug in the top menu in 2017?

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , May 02, 2017 May 02, 2017
I have found the cause of the bug in Muse and Indesign..In my setup I have 2 screens. One has a higher resolution than the other (4K vs FullHD).In Windows 10: One screen is set to 200% DPI and the other to 175% DPI. This is also recommended by Windows (it says: recommended).Apparently, Muse and InDesign cannot deal with this DPI inconsistency across screens and topmenus fail to work.If I set the DPI to the same (which is really undesired, making everything either too big or too small on one scre...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Reset preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I've reset the preferences and checked the troubleshoot guide.

But I'm going to be honest here and say that it is very hard for me to believe that clearing preferences can resolve an issue of invalid mouse event handling (mouseOver/Out/Click) in InDesign's application logic. I'd rather believe this is a bug in InDesign where it does not deal with Windows DPI settings correctly on 4K screens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I've reset the preferences and checked the troubleshoot guide.

Have you cleared your caches? They are often the culprit with interface problems.

C:\Users\<USER>\AppData\Local\Adobe\InDesign\<Version #>\<Language>\Caches\

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Have you tried resetting preferences yet?

Also, I have a long list of other things you can try: InDesign CC 2017 troubleshooting how-to guide

TrainingOnsite.com - InDesign CC 2017 Resources

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

To make it extra clear to hopefully find a solution, I've put Illustrator next to Indesign.

But latest versions, on the same screen, same computer.

Notice me navigating the dropdown menus.

It's simply impossible to open the Type menu in InDesign for example.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

Not good. You can report this to Adobe here:

Wishform - Adobe InDesign

In the meantime, things I would try:

  • Is the display driver up to date? (mouse driver too)
  • Can you try a different display to see if the Ultra HD Screen is the issue? (I googled it, but didn't get any hits.)
  • What about lowering the resolution, just to see if that makes a difference?
  • Worse case scenario, use the menu shortcuts. Normally, Alt+the first letter of the menu. I.E., Alt+t to open the Type menu (though the Table menu is Alt+a). Then arrow down to pick a command and press Enter, or just press the underlined letter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

I have found the cause of the bug in Muse and Indesign..

In my setup I have 2 screens. One has a higher resolution than the other (4K vs FullHD).

In Windows 10: One screen is set to 200% DPI and the other to 175% DPI. This is also recommended by Windows (it says: recommended).

Apparently, Muse and InDesign cannot deal with this DPI inconsistency across screens and topmenus fail to work.

If I set the DPI to the same (which is really undesired, making everything either too big or too small on one screen), the topmenus have no issue.

Video

Notice how I change the DPI setting and the problems disappear

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2017 May 20, 2017

Copy link to clipboard

Copied

I'll be darned, this fixed my issue, too. An odd workaround, but I guess it will have to do. I bought a new laptop with a 4K screen, and that's when this issue reared its annoying head.  THANK YOU, this was driving me crazy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2017 Sep 07, 2017

Copy link to clipboard

Copied

Thanks for that, completely solved my problem after tearing my hair out and getting OTT frustrated using keyboard shortcuts for the last few days...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2018 Feb 07, 2018

Copy link to clipboard

Copied

I have the bug to, now its 2018 - only use one screen down to 100%

Its not fixed yet, the bug? What to do?

Pia

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 07, 2018 Feb 07, 2018

Copy link to clipboard

Copied

LATEST

Then you don't have the same problem. Please start a new topic with full system details as well as screenshots showing whatever problem it is that you have.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines