Highlighted

unable to apply 'Fill' option in 'Table Styles'

Engaged ,
May 26, 2020

Copy link to clipboard

Copied

Hello

 

I have created a table style. Now in this table i want some of the rows to have a fill and some to have no fill. So i thought of using the Fill option under 'Table Styles.'

 

But i find that when i am using this option, the table does not yield any results. Screenprint below:

 

table fill option.PNG

 

Please let me know where i am going wrong here.

Thank you.

TOPICS
How to

Views

492

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

unable to apply 'Fill' option in 'Table Styles'

Engaged ,
May 26, 2020

Copy link to clipboard

Copied

Hello

 

I have created a table style. Now in this table i want some of the rows to have a fill and some to have no fill. So i thought of using the Fill option under 'Table Styles.'

 

But i find that when i am using this option, the table does not yield any results. Screenprint below:

 

table fill option.PNG

 

Please let me know where i am going wrong here.

Thank you.

TOPICS
How to

Views

493

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 26, 2020 0
Adobe Community Professional ,
May 27, 2020

Copy link to clipboard

Copied

Hi Ashim,

from your screenshot I can see no difference in fill color for First and Next Rows.

So every row will get that C=100 M=0 Y=0 K=0 fill color.

 

From my German InDesign where I defined:

Alternate

First: 1 Rows to Yellow

Next: 1 Rows to None:

 

EveryOtherRow-TableRowFills.PNG

 

Note:

Skip First: 1 Rows

Skip Last: 4 Rows

as well.

 

Hope your table has enough body rows so that all the settings can go into effect.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0
Adobe Community Professional ,
May 27, 2020

Copy link to clipboard

Copied

Also note that if you're using Cell Styles the cell fills will override the table fills.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0
Engaged ,
May 27, 2020

Copy link to clipboard

Copied

Hi Uwe and Scott

Thank you for your inputs.

Well, the effect that i want is that i want all the rows in my table to be shaded a light gray, which is why i was having the same color for both the first and next rows.

Since  i was unable to produce this effect, i did have the cell highlighting option selected. But after reviewing Scott's input, i deactivated the cell highlighting option. But even then, i am unable to get the results.

Even if i try a different shade for every other row, it still does not work.

 

I am not sure what is it that i am missing here. Your guidance is truly appreciated.

 

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0
Adobe Community Professional ,
May 28, 2020

Copy link to clipboard

Copied

Hi Ashim,

then I guess that some style overrides are in place.

After you removed the overrides all should work as expected with alternate rows.

 

If you are on InDesign 2020 version 15.0.3 you could use a script in the new Community section of your Scripts panel to get rid of the overrides in your table: ClearStyleOverrides.jsx by Gregor Fellenz.

 

When not on 15.0.3 the script ClearStyleOverrides.jsx is available at the link below with a detailed description how to use it:

https://github.com/grefel/clearOverrides

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2020 0
Engaged ,
Jun 17, 2020

Copy link to clipboard

Copied

Hi Uwe

I updated to the latest version, but it still does not work, i am afraid. Also my page numbers are now all messed up - all i see is "ss"

 

Capture2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 0
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

Hi Ashim,

if you see "ss" in text variable instances, Current Page markers, footnote number instances you updated to InDesign 15.1.0.25 and you are using one of the two paragraph composers:

Adobe World-Ready Single-line Composer
Adobe World-Ready Composer

 

This is a known bug.

 

Currently the only known workaround is to use one of the following paragraph composers:

 

Adobe Single-line Composer
Adobe Paragraph Composer


Adobe Japanese Single-line Composer
Adobe Japanese Paragraph Compose

 

If you do text composition with Hebrew or Arabic then this is no option at all.

In that case revert back to InDesign 15.0.3 until the issue is fixed.

 

Vote for fixing the bug here or vote that you get a notification when a fix is out:

ID 2020 15.1 - All text variables (including page numbers) replaced by "ss" text

https://indesign.uservoice.com/forums/601180/suggestions/40675342

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Engaged ,
Jun 18, 2020

Copy link to clipboard

Copied

Thank Uwe. i rolled back to 15.0.3.

Also, can you please weigh in on why i am not able to use the table fill option even after executing the override script.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Adobe Community Professional ,
Jun 18, 2020

Copy link to clipboard

Copied

Regarding your other problem, the one with your table:

 

Please show the table before you are running the script by Gregor Fellenz.

Also show the settings you do in the script's UI.

Plus: Show the table after you ran the script.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Engaged ,
Jun 19, 2020

Copy link to clipboard

Copied

Sure Uwe.

Please find below the details.

The table before running the script. There are no cell fill styles:

1. table before.PNG

The table fill style that i am trying, but which is not taking effect:

2. table style.PNG

The table after running the script:

3. table after running script.PNG

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2020 0
Engaged ,
Jun 29, 2020

Copy link to clipboard

Copied

Hi Uwe

I was wondering if you could weigh in on why i am unabel to apply the fill option in table styles. I have attached the screenprints as you had requested.

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

Hi Ashim,

if someone wants to solve this riddle you have to make the table available for inspecting.

Not the whole document, just one page with the table.

Best use Dropbox or a similar service and post the download link for the document here.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 0
Engaged ,
Jul 01, 2020

Copy link to clipboard

Copied

Sure Uwe.

 

Please find below the link to the file.

https://easyupload.io/r463qh

 

filename - test.indd

 

Thank you for your time and help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2020 0
Engaged ,
Jul 09, 2020

Copy link to clipboard

Copied

Hi Uwe

I was wondering if you had a chance to look at the file that i uploaded.

Thanks and regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2020 0
Adobe Community Professional ,
Jul 15, 2020

Copy link to clipboard

Copied

Change the Fill on your 'lifecycle - body cell' Cell Style from None to Ignore (at the bottom of the list)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0