Highlighted

Unchecking Hyphenation still causes all subsequent text to be lost

Community Beginner ,
Dec 04, 2018

Copy link to clipboard

Copied

I see this has NOT been resolved since 2014:

I lose words when i uncheck hyphenate

I want to have 2 paragraphs of text that simulates ancient Greek manuscripts.  NO hyphens and NO breaking at a syllable.  When they ran out of space in the papyrus roll they just continued the word, wherever the break was, on the next line.

I tried to turn off hyphenation for the one paragraph.  All text gone for the rest of the doc.  I tried setting up a new style with no hyphenation.  All text gone...

4 years, and InDesign has not fixed this problem.

I pay for a subscription and can't get support for a bug?  This is bs.

I will now start looking at Lulu and other vendors who don't require you to work with a POS program once I finish this book.

Short of typing each line individually, counting letters, and then hitting return (with single space) so I get the look I want, I see no other  solution.  Does any InDesign employee want to try to keep me in the camp?  And keep me from putting out to all academics I know NOT to self-publish with ad-Oh-be.

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi gregorys84937500 ,

try what samar1234 is suggesting.

You may substitute every blank with a FIXED_WIDTH_NONBREAKING_SPACE character to make it work:

NoLanguage-text.PNG

Regards,
Uwe

Views

612

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unchecking Hyphenation still causes all subsequent text to be lost

Community Beginner ,
Dec 04, 2018

Copy link to clipboard

Copied

I see this has NOT been resolved since 2014:

I lose words when i uncheck hyphenate

I want to have 2 paragraphs of text that simulates ancient Greek manuscripts.  NO hyphens and NO breaking at a syllable.  When they ran out of space in the papyrus roll they just continued the word, wherever the break was, on the next line.

I tried to turn off hyphenation for the one paragraph.  All text gone for the rest of the doc.  I tried setting up a new style with no hyphenation.  All text gone...

4 years, and InDesign has not fixed this problem.

I pay for a subscription and can't get support for a bug?  This is bs.

I will now start looking at Lulu and other vendors who don't require you to work with a POS program once I finish this book.

Short of typing each line individually, counting letters, and then hitting return (with single space) so I get the look I want, I see no other  solution.  Does any InDesign employee want to try to keep me in the camp?  And keep me from putting out to all academics I know NOT to self-publish with ad-Oh-be.

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi gregorys84937500 ,

try what samar1234 is suggesting.

You may substitute every blank with a FIXED_WIDTH_NONBREAKING_SPACE character to make it work:

NoLanguage-text.PNG

Regards,
Uwe

Views

613

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 04, 2018 0
New Here ,
Dec 04, 2018

Copy link to clipboard

Copied

Can you modify the font to turn the hyphen into a space?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 04, 2018 0
Contributor ,
Dec 05, 2018

Copy link to clipboard

Copied

Try this under Paragraph Style Options:

– Basic Character Formats: make sure No Break is NOT selected

– Advanced Character Formats -> Language: [No Language]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2018 2
New Here ,
Oct 13, 2020

Copy link to clipboard

Copied

Thanks, this solved my issue!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
Enthusiast ,
Dec 05, 2018

Copy link to clipboard

Copied

> All text gone for the rest of the doc.  I tried setting up a new style with no hyphenation.  All text gone...

I guess it's not gone, it's just overflowing, right?

That paragraph, perhaps it contains words that doesn't fit on one line? Or does it use non-breaking spaces instead of normal spaces? Either way, the text needs more space when hyphenation is not allowed, and overflowing is the way that InDesign (and I believe all other DTP software) handles this situation. Words can not be broken up unless hyphenation is on.

If I had this (very uncommon) problem, and I need to do it many times, or on a large mass of text, I'd write a script that puts line breaks at the right places.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2018 0
Adobe Community Professional ,
Dec 05, 2018

Copy link to clipboard

Copied

Hi gregorys84937500 ,

try what samar1234 is suggesting.

You may substitute every blank with a FIXED_WIDTH_NONBREAKING_SPACE character to make it work:

NoLanguage-text.PNG

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2018 1
Enthusiast ,
Dec 05, 2018

Copy link to clipboard

Copied

Acutally trying the answer from samar1234 and following your excellent screensshots Uwe... make me realize I'd like to erase my previous answer!

: )

Seems to work fine!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2018 0