Highlighted

Unexpected "figure spaces"

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

In some headers I am finding "figure spaces" added to the end of lines even though I've never asked for them.  I can see them using the "view invisible characters" function.

 

The really weird part is that

1) I can't select or delete them

2) They don't seem to actually add space.

3) They seem to be breaking my TOC entries by adding extra tabs or extra newlines.

 

So for instance I might have something that looks like:

"Transfers#"

where the # character is the icon for the figure space invisible character. See the image below.

drew-mills_1-1592422456274.png

Any ideas where these are coming from and how I can get rid of them?

Hi - the character that you can see is just an end-of-text indicator - it's not a space or any printable character. It just indicates that there is no more text after that point.

Topics

Type

Views

102

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unexpected "figure spaces"

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

In some headers I am finding "figure spaces" added to the end of lines even though I've never asked for them.  I can see them using the "view invisible characters" function.

 

The really weird part is that

1) I can't select or delete them

2) They don't seem to actually add space.

3) They seem to be breaking my TOC entries by adding extra tabs or extra newlines.

 

So for instance I might have something that looks like:

"Transfers#"

where the # character is the icon for the figure space invisible character. See the image below.

drew-mills_1-1592422456274.png

Any ideas where these are coming from and how I can get rid of them?

Hi - the character that you can see is just an end-of-text indicator - it's not a space or any printable character. It just indicates that there is no more text after that point.

Topics

Type

Views

103

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
Jun 17, 2020

Copy link to clipboard

Copied

Hi - the character that you can see is just an end-of-text indicator - it's not a space or any printable character. It just indicates that there is no more text after that point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jun 17, 2020

Copy link to clipboard

Copied

Hi @drew-mills,

To hide these "invisible" characters in InDesign, you need to check the hidden characters setting.

Click on Type in the main menu bar and then turn off Show Hidden Characters.

 

Or you turn on Overprint Preview in menu: View.

 

-------------------

But for me these markers are very important. In my documents I always turn on Type --> Show Hidden Characters. There is a toggle Shortcut for that [Alt]+[Cmd/Strg]+[I]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 19, 2020

Copy link to clipboard

Copied

Thank you! The # character (end of story) looks almost identical to the # , (the figure space character). Thanks for straightening that up for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...