Unnecessary Overset Text

Community Beginner ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

I am working with InDesign and since the latest update to version 16.1 I have had all of my text boxes, in every file behave strangely. When I type in new text, it automatically jumps out of the box and becomes overset. In some cases I can change this in Story Editor, or by copying and pasting the hidden character for a return, but not in all cases.
As you can see from the screenshot, the text frame has ample room, and yet there is still overset text.

  • Adobe Indesign Creative Cloud version 16.1 (I've tried rolling back the update, it didn't help)
  • Windows 10 PC, Version 10.0.19041
  • Basic Paragraph style
  • Text frame set to "Ignore Text Wrap"
  • Screenshot 2021-02-26 134147.jpg
TOPICS
Bug, Performance, Type

Views

128

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 01, 2021 Mar 01, 2021
It looks like you are adding column breaks here and there. In InDesign, the Enter key on the main part of the keyboard will create a hard return (¶) but the Enter key on the numeric keypad will create a column break (a down pointing ^).   It's best to work with Type > Show Hidden Characters enabled so you can see them and remove them. Was that the issue?~Barb  

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

Does that last bit of text have a no-break attribute applied to it?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

I have tried applying the "no-break" attribute, it helps sometimes, but the next time I hit return for a new paragraph the new text is overset.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

You want to not have the no-break attribute applied. It keeps all contiguous text with no-break applied on the same line. This will cause overset it the resulting string of characters is too long.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Thanks, it's currently not set to no-break. I've tried it both ways. When I set it to no-break the whole paragraph disappears, but when I turn the no-break feature off the paragraph returns to visible, including the overset text.

But then the next paragraph becomes overset...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

Is there a Wrap applied to a nearby object? (Possibly an object hidden by your Story Efitor?) If yes, go to Object > Text Frame Options and check Ignore Text Wrap to the lower left in the window and click OK.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

Thanks for the suggestion, there are no other objects on top of or near abutting the frame. As I noted in my post, the frame is already set to "Ignore Text Wrap".

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

could you share your file with us (dropbox or similar) or just the page that presents the problem you have described?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

I feel like I hit a keystroke somewhere along the way that caused a setting to change. I just can't find the way to set it back.
https://1drv.ms/u/s!Akoy4utBrdgXv0rHUjy9md228Qhs?e=EaCkBA

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

It looks like you are adding column breaks here and there. In InDesign, the Enter key on the main part of the keyboard will create a hard return (¶) but the Enter key on the numeric keypad will create a column break (a down pointing ^).

 

It's best to work with Type > Show Hidden Characters enabled so you can see them and remove them. Was that the issue?

~Barb

 

keyboard mac.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Thank you! This appears to be the problem. I don't use column breaks so I've changed the setting for the Enter key on my numeric keypad in my keyboard shortcuts.

 

I can't imagine how I have never encountered this problem before. I've used the same keyboard set up for years.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

I'm still puzzling over this—the layout you linked to is different from the file you are showing. And in your file, there is a hard return after Food & Catering Options, but in the file you linked to, it's a line break (as described above).

 

~Barb 

breaks.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

I had continued to work on the document after posting the initial screenshot. I had found a workaround prior to your solution. I would copy and paste the appropriate hidden character where I needed it in order to correct the overset text. Thanks for your help, it seems to be working properly now.

 

I still have no idea why I haven't encountered this before. My keyboard setup and habits have not changed.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines