Highlighted

Unresolved symbols in the samples for InD SDK 15

Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Hi

 

I have many unresolved symbols in the SDK Samples for InD SDK 15. Possibly I need to set the path for all the projects. Is there a documentation on how to do this in the SDK docs?

 

Thanks,

TOPICS
SDK

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unresolved symbols in the samples for InD SDK 15

Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Hi

 

I have many unresolved symbols in the SDK Samples for InD SDK 15. Possibly I need to set the path for all the projects. Is there a documentation on how to do this in the SDK docs?

 

Thanks,

TOPICS
SDK

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 03, 2020 0
Adobe Community Professional ,
Jul 03, 2020

Copy link to clipboard

Copied

Is this on Visual Studio? If yes then this is a know issue, don't rely on the intellisense much. If things are correct the code will compile, this won't have any issue on the compilation

 

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0
Adobe Community Professional ,
Jul 03, 2020

Copy link to clipboard

Copied

Quoting the sdk documentation on this issue below

IntelliSense

IntelliSense has never worked very well for InDesign code, and you may find that IntelliSense red squiggles appear under nearly every InDesign type or API, despite your project compiling successfully.

To disable the squiggles:

  1. Go to Tools > Options.
  2. In the options dialog, in the left pane, expand "Text Editor" and then expand "C/C++".
  3. Click on "Advanced" under "C/C++".
  4. In the right pane, scroll down until you see the "IntelliSense" section.
  5. Select "Disable Squiggles" and change its value to True.
  6. Click OK.

 

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0
asaxena LATEST
Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Thanks.

 

I however feel really limiting when intellisense does not work specially when I am beginning with the framework and want to really 'go to definition' of various types and classes to wrap my head on the various elements and programming concepts available. Sad!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0