Unwanted added transparency for imported photoshop or png files

Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Since halfway this year an issue with indesign. Something that looks like automated added transparency.

- a psd (with already a BG mask)

- a png file (with an embedded masked background

- a jpg with a white (masked) background

What happens is that the imorted image gets some kind of transparency mask on top of the transparency that is already there. In the example below you see both the photoshop file opened in photoshop and the way it appears in indesign. Also note that there are no effects or transparency settings from indesign.

It is most likely a bug, since this happens with only some psd files, not all of them. Thanks for the help!

 

TOPICS
Bug, Import and export

Views

296

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , May 12, 2021 May 12, 2021
Thank you Bob! GPU turned off doesn't change. But while relinking the file i think i found the solution:- show import options- under image uncheck 'apply photoshop clipping path'that means that this option got checked on automatically since the last update probably, never heard about it or used it before today.

Likes

Translate

Translate
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Can you share the layered PSD?

 

Does it happen if you convert the bottom white layer into a background layer by selecting it in the Layers panel and choosing Layer>New>Background from Layer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Hi Rob thank you for the reply! Unfortunately i can not upload the psd file, it is hundreds of Mb. I also don't see the use for it, since the bug also happened on some jpg and png files.

I tried setting the white BG layer in photoshop as you proposed. It is visible in photoshop as a plain white BG. (before the visibility of that BG layer was turned off in photoshop. Now i get this result after updating the image link in indesign:

 

Screenshot 2021-05-12 at 10.04.58.png

If you look closely you can see that the correct mask is now displaying in white, displaced behind the faulty picture

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Try turning off GPU performance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

Thank you Bob! GPU turned off doesn't change. But while relinking the file i think i found the solution:

- show import options

- under image uncheck 'apply photoshop clipping path'

that means that this option got checked on automatically since the last update probably, never heard about it or used it before today.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines