Unwanted microthin white lines along the edges of the colour fills in imported illustrator files

Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

indesign white lines.png

I'm getting these unwanted microthin white lines along the edges of the colour fills in my imported illustrator file in Indesign CC 2020. When I export is as a jpeg, these white lines don't show up, resulting in a perfect output. What should I do to fix this trouble?

 

I think it's a display tweak in InDesign that would surely help me out.

TOPICS
Bug, How to, Import and export, Performance

Views

2.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 08, 2020 May 08, 2020
Also, if I put a rectangle filled with blue behind the art, the anti-aliasing display artifacts go away:  

Likes

translate

Translate

Translate
Adobe Community Professional ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

These lines are probably not there. They're not showing up in exported file. Have you tried exporting as a PDF just to see if the lines show up? I doubt they will.

 

Are you viewing your screen using high performance (View > Display Performance > High Quality Display)? Have you tried unchecking GPU Performance in Preferences?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Lines are showing in pdf. This is surprising. I opened pdf in chrome, adobe acrobat and nitro pdf reader. Everywhere white lines show up! On the other hand the jpeg exports are absolutely fine! Seems like a bug in Indesign? Many people have been facing this trouble for years. I tried the old trick of flattening my work in Illustrator but I still get white lines. 

 

The display performance is of course high quality. GPU performance setting isn't available in InDesign. 

 

Checking upon nvidia button in the windows 10 taskbar tray in bottom right, InDesign isn't using GPU acceleration. 

indes 2.png

 

INDESIGN GPU CHECK.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

There could be duplicated shapes that are stacked on top of each other in the art file. Open graphic in Illustrator, and with the direct selection tool select a shape and move or delete, and see if there is an underlying shape.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

There are no duplicate shapes stacked over one another. I checked. If that was the case, then the exports would also come with white lines. Exports are coming fine. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

What were the PDF settings in the Illustrator file? Make sure it's saved with PDF-X/4.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

I didn't do any settings in the illustrator file. I imported the direct .ai file. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Can you share the .AI file?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Sure. 

 

You can download the file from here. 

 

https://www73.zippyshare.com/v/K7CZvGXS/file.html

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2020 May 07, 2020

Copy link to clipboard

Copied

The link wants me to install a plugin.

 

Can you share via your CC acount? If you put it in your Creative Cloud Files folder and right click, you should get a Share Link option, or you can go to your Creative Cloud web page and get the link there.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

I think it's an ad popup that's bothering you. 

 

Try here. It's a dropbox link. 

 

https://www.dropbox.com/s/lvm9q2b24ll2krm/grohl%20test.ai?dl=0

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Isn't this just a display artefact? I know that in Acrobat (Preferences under Page Display, deselect the option "Smooth Line Art") there's a setting to fix this, but I am unsure about InDesign.

 

Can you save to a PDF, then open in Acrobat and activate that setting?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

 

 

 

I cannot find the option of "Smooth Line Art". I toggled with enhance thin lines which didn't make any difference to the output. 

I am using the latest version of Acrobat .

 

The pdf display setting is not the issue, otherwise the file would have showed up fine in chrome, nitro pdf, etc. It is still showing with white lines which means that the pdf itself has corruption of lines which disappears in jpeg outputs from InDesign. 

 

 

 

acrobat options.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

The drawing is made with shapes that share borders as opposed to shapes stacking on top of each other, so the thin lines are a display artifact (assuming the shape edges are perfectly aligned). It doesn’t have anything to do with transparency flattening artifacts, but it is a similar issue, where the vector art preview has to get resampled to fit the screen, and the anti-aliasing or aliasing would affect the preview.

 

If the output is to a high resolution device like a platemaker there would be no anti-aliasing and the lines wouldn’t show—the problem only happens with "low res" devices like an anti-aliased screen display.

 

I can see the artifacts in Illustrator without placing in ID and exporting a PDF. Here I have captured the 200% view and applied a slight sharpening, so it is easier to see here:

Screen Shot 17.png

 

You can see that the artwork shapes knockout rather than stack:

 

Screen Shot 18.png

 

If I skip InDesign and export directly from Illustrator to PDF, the display edge anti-aliasing is still visible, and the Page Display settings has some affect:

 

Screen Shot 20.png

 

Turning off anti-aliasing improves the edge line a bit:

 

Screen Shot 21.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 09, 2020 May 09, 2020

Copy link to clipboard

Copied

This is driving me crazy now. I'm on a windows 10 machine and on 6400% zoom in Adobe Acrobat in the pdf directly exported from Illustrator, I don't get any lines. 6400% is the max. zoom limit. 

 

Moreover, in Illustrator, 200% zoom, 400% zoom, both are clean. Super clean. No artefacts visible. There's definitely some issue with how Adobe makes their products for Mac and Windows. 

 

GROHL 200.pngGROHL_400.png

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
May 09, 2020 May 09, 2020

Copy link to clipboard

Copied

I opened the file in Affinity Designer, because it allows me to zoom in extremely close.

 

The result:

 

extremezoom.png

Definitely a seam between elements, which is causing this issue.

 

Turning off anti-aliasing clears it up somewhat, but still white pixels appear here and there, and become more pronounced when zooming in again.

 

rayek_elfin_0-1589060609561.png

 

None of the shapes have a stroke set. The solution here is to turn on a hairline stroke  for all shapes, and apply the same colour to the stroke as the fill.

 

Result: no more artefacts,

 

Anyway, the problem is that imprecision between placed elements. There is a seam, even if it might be very, very small. Turning on a hairline stroke with the same colour as the fill solves it.

 

First select all objects, and assign a hairline stroke. Then use the select by fill command for to select all objects with the same colour, and assign the same stroke colour as the fill. Do this for each colour.

 

 

 

 

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2020 May 09, 2020

Copy link to clipboard

Copied

Definitely a seam between elements, which is causing this issue.

 

You can "RIP" a vector file using Photoshop, and a conversion to 2400ppi (typical platemaker resolution), CMYK, with Anti Alias off, shows there are no lines in a high resolution raster file.

 

2400ppi Photoshop import displayed at 1:1 image pixels to monitor pixels

 

Screen Shot 3.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
May 09, 2020 May 09, 2020

Copy link to clipboard

Copied

Then why did I find those seams when I zoomed in Affinity Designer?

 

Not doubting you, genuinely curious. I opened the file in PhotoLine and Xara, and those seams were there. In PhotoLine I turned off anti-aliasing, and still white pixels showing up here and there.

 

I have noticed this problem before with other files in the past, and fixed it by turning on the stroke (hairline) and assigning the same colour as the fill. Which also fixes the issue here.

 

So I would be interested in learning how Photoshop is internally handling this.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

Then why did I find those seams when I zoomed in Affinity Designer?

 

Because Affinity is anti-aliasing its preview.

 

It would be important to know the AI file’s final output—low res, high res, screen, print? If it is for screen display you would have to create overlaps in the art because at low resoultions some kind of anti-aliasing is going to be used by the display application to smooth the shape edges. If it is for high end printing the vector art has to be RIP’d to pixels at a high resolution where there is no need for any anti-aliasing. That’s why there are no artifacts in my 2400ppi Photoshop example. The edges are jagged, but then that doesn’t matter at 2400ppi with the final output to a halftone or stochastic screen.

 

https://en.wikipedia.org/wiki/Raster_image_processor

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

I understand that, but what I am saying is that these seams (meaning: actual white lines running between components) are physically present. Affinity allows me to zoom in at a far higher zoom level than Adobe apps, and in PhotoLine at 25000% zoom I can clearly see the same seams (with or without anti-aliasing). The parts do not overlap or exactly fit, and that is caused (seemingly) by a lack of a stroke setting.

 

I opened the file in PhotoLine and turned off the anti-aliasing, "ripped" it at the same high resolution, and still white dots appear here and there.

 

When I assign a hairline with the same colour as the fill to all elements the issue goes away in all software, screen displays, and resolutions. (Changing the background colour isn't really a solution, because the colour of the background still affects the rendering and rasterization.)

 

And I am aware that Photoshop fixed this issue a long time ago (if my memory serves me right). Which means Photoshop's internal rastering algorithm seems to take these tiny seams into account and overflows a bit.

 

So what would the difference be between how Photoshop rasterizes this file, and (for example) PhotoLine with anti-aliasing turned off.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

I have no idea how other apps would handle the conversion to rasters. The real test would be to a high resolution print via a RIP. I have software RIP driving my large format inkjet printer and the lines do not show in the high res print output even when enlarged.

 

This is 2880dpi stochastic output at 200%:

 

scan0002.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

You see that the culprit is anti-aliasing if you RIP the file into Photoshop at a low res with anti-aliasing turned off. Here‘s 72ppi:

 

Screen Shot 5.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

When I export is as a jpeg, these white lines don't show up, resulting in a perfect output.

 

The Anti-Aliasing choice with a JPEG export does have an affect:

 

Type Optimized Hinting:

 

Screen Shot 22.png

 

Off

Screen Shot 23.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

Also, if I put a rectangle filled with blue behind the art, the anti-aliasing display artifacts go away:

 

Screen Shot 24.pngScreen Shot 25.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 09, 2020 May 09, 2020

Copy link to clipboard

Copied

You placed a rectangle in InDesign or Illustrator?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines