White box in Indesign

Community Beginner ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hi, 

I have a problem with the Id libraries.
When I import a vector object, created on Ai, the vector has a box with a white background.

TOPICS
Bug, Import and export

Views

166

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Dec 11, 2020 Dec 11, 2020
Hi @puntocom_giardininaxos:   Was the white box inadvertantly added to the file in Illustrator, and then added to the library? Look at the artwork thumbnail in the CC Library. Do you see checkerboard directly behind the object, or white?   In my example below, the group of trees has a white background, but the four individual trees do not.   ~Barb 

Likes

translate

Translate

Translate
Adobe Community Professional , Dec 14, 2020 Dec 14, 2020
Hi puntocom_giardininaxos, I'm quite sure that the following happened:   The last time you placed an AI file or a PDF file you disabled option Transparent Background in the Import Options. Because the assets marked as AI in your CC Libraries are nothing than AI files you can place, the disabled Transparent Background is still active and default.   To solve the issue: Place an AI file and use the Import Options. Enable option Transparent Background   Then go on placing the AI assets from your CC ...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hi @puntocom_giardininaxos:

 

Was the white box inadvertantly added to the file in Illustrator, and then added to the library? Look at the artwork thumbnail in the CC Library. Do you see checkerboard directly behind the object, or white?

 

In my example below, the group of trees has a white background, but the four individual trees do not.

trees.png

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hi @Barb Binder 

there isn't the white box

 

no I don't see the white. Schermata 2020-12-11 alle 17.23.52.pngSchermata 2020-12-11 alle 17.24.37.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hi @puntocom_giardininaxos:

 

I am not having that experience. What version of InDesign are you using? Have you tried placing one in a new file, just to see if it works as expected?

 

~Barb 

library.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

The problem occurred with version 20. I have tried several times. I have created several objects, I also tried with vector objects previously they did not have this problem.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Version 20? Do you mean InDesign 2020? That is version 15. Be sure you are all patched up. The current 2020 version is 15.1.3.

 

I just tried this in 2020 and it worked as expected. Did you try in a brand new file?

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Hi puntocom_giardininaxos,

I'm quite sure that the following happened:

 

The last time you placed an AI file or a PDF file you disabled option Transparent Background in the Import Options.

Because the assets marked as AI in your CC Libraries are nothing than AI files you can place, the disabled Transparent Background is still active and default.

 

To solve the issue:

Place an AI file and use the Import Options.

Enable option Transparent Background

 

Then go on placing the AI assets from your CC Library.

 

Import options from my German InDesign 2021:

 

ImportOptions-TransparentBackground-ENABLED.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Hi @Laubender

Thank a lot, I just followed your advice and this is the solution.

I hadn't thought about the link between Ai import and CC Libraries.

Regards

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Hi

you could vote for this feature request ( I already did ) :

 

Options dialog for Place from CC Library

Anonymous shared this idea, Jan 16, 2019

 

Implement a possibility to choose how to import .ai items from Library. Now there is no dialog or options for this at all.
If your item has transparency Indesign uses import setting from last imported .ai object and provides no way to choose this for the current one. So if you want to change it you have to import no-matter-which .ai from local computer -> set desired transparency background option -> import your item from library.
This workaround is absolutely not obvious, thanks for Adobe forums it posted there (from year 2016).

 

https://indesign.uservoice.com/forums/601021-adobe-indesign-feature-requests/suggestions/36537766-op...

 

Regards,
Uwe Laubender

( ACP )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

There is also this one that also points out an issue with import and PhotoShop:

 

Import controls for Libraries
James Lockman shared this idea, Jun 8, 2018

 

Provide an option to control how a Library item imports into InDesign. Since Libraries created from AI are treated as PDF, they place with the Bounding Box (Visible Layers) option if the user hadn't changed the PDF Import options. There is no way to control the import into Photoshop, as Photoshop doesn't remember the last PDF import option, unlike InDesign.

 

https://indesign.uservoice.com/forums/601021-adobe-indesign-feature-requests/suggestions/36537766-op...

 

Regards,
Uwe Laubender

( ACP )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines