Why does InDesign ignore my custom baseline grid?

Dec 13, 2016

Copy link to clipboard

Copied

I've got a block of text in a text box and have set and enabled a custom baseline grid for that textbox, but InDesign simply ignores the custom baseline grid in favor of whatever leading value I have specified for the text in the Character panel. How do I get the custom baseline grid to be applied? Thank you.

Make sure the Paragraph style for that text has the baseline grid switch turned on.

Baseline grid requires three steps:

1. Define baseline grid in preferences or within the textframe options

2. Choose whether or not to view the baseline grid under the View menu

3. Turn on Indents and Spacing > Align to Grid: All Lines -- in the Paragraph style that controls the text (you ARE using styles, aren't you?)

Views

608

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Why does InDesign ignore my custom baseline grid?

Dec 13, 2016

Copy link to clipboard

Copied

I've got a block of text in a text box and have set and enabled a custom baseline grid for that textbox, but InDesign simply ignores the custom baseline grid in favor of whatever leading value I have specified for the text in the Character panel. How do I get the custom baseline grid to be applied? Thank you.

Make sure the Paragraph style for that text has the baseline grid switch turned on.

Baseline grid requires three steps:

1. Define baseline grid in preferences or within the textframe options

2. Choose whether or not to view the baseline grid under the View menu

3. Turn on Indents and Spacing > Align to Grid: All Lines -- in the Paragraph style that controls the text (you ARE using styles, aren't you?)

Views

609

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 13, 2016 0
Dec 13, 2016

Copy link to clipboard

Copied

Make sure the Paragraph style for that text has the baseline grid switch turned on.

Baseline grid requires three steps:

1. Define baseline grid in preferences or within the textframe options

2. Choose whether or not to view the baseline grid under the View menu

3. Turn on Indents and Spacing > Align to Grid: All Lines -- in the Paragraph style that controls the text (you ARE using styles, aren't you?)

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2016 1
Dec 13, 2016

Copy link to clipboard

Copied

My guess is Bob that item 3 on your list is not applied by OP  😉

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2016 1
Dec 13, 2016

Copy link to clipboard

Copied

... aaaaaand we have a winner! Thank you Michael (and Frans), I did not turn on number 3.

I'm feeling rather foolish now, haha. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2016 0
Nov 23, 2020

Copy link to clipboard

Copied

I'd like to think this is a joke -- that the only way to force type to align to a baseline grid is to first create styles, and define the baseline grid option within that style, then force all the text into various styles. I suspect it is not a joke, as I've banged my head against the wall numerous times to try to make this happen AS IT SHOULD. Holy cow.

 

I'm using CC 2015, due to my need to conform to a client's software spec, but maybe you've implemented this correctly in later versions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Nov 26, 2020

Copy link to clipboard

Copied

Hi Mike Diehl,

if you want to force text to the baseline grid you can do this also from:

[1] the Paragraph panel

[2] the Control panel

[3] when in InDesign CC 2019 or above: the Properties panel 

 

Watch out for this set of controls:

ForceTextToBaselineGrid.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2020 0