Highlighted

Why is my text frame vertical alignment changing from bottom to top in indesign 2018?

New Here ,
Oct 26, 2017

Copy link to clipboard

Copied

I just installed Indesign CC 2018 and when I open an indesign file that was created in a previous version Indesign is automatically changing the vertical alignment of my text in boxes that are aligned bottom to align top. Is this because of the basic text frame? Do I have to create a new text frame if I want text to align bottom in this new version of Indesign?

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Why is my text frame vertical alignment changing from bottom to top in indesign 2018?

New Here ,
Oct 26, 2017

Copy link to clipboard

Copied

I just installed Indesign CC 2018 and when I open an indesign file that was created in a previous version Indesign is automatically changing the vertical alignment of my text in boxes that are aligned bottom to align top. Is this because of the basic text frame? Do I have to create a new text frame if I want text to align bottom in this new version of Indesign?

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 26, 2017

Copy link to clipboard

Copied

Hi,

Does my answer here CC 2018 Vertical Justification Issue  help you too?

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 26, 2017

Copy link to clipboard

Copied

Like you I do not want all of my text boxes in a single document to be aligned top or bottom. I tried clicking off the basic text frame but this did not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 26, 2017

Copy link to clipboard

Copied

When you installed CC 2018 did you make sure that “Import previous settings and preferences” (see screen shot) was unchecked?

INSTALL ID.png

If you had this option checked during the install then it's possible that the problems that you are describing are related to that (CC 2018 does not seem to like using old preference files—quite a few issues that have at first appeared to be bugs have been related to the use of old preferences) and you will now have to manually make sure that all previous preference files for InDesign are deleted (or if on a PC renamed) making sure that InDesign is closed when you do so. You can then open CC 2018, save a test file and then quit it so that a new CC 2018 only preference folder will be created. (This is all based on a test I did that showed that when an older preference file exists CC 2018 did not create a complete preference folder). At this point I would restart the computer and once rebooted launch InDesign and hopefully your problem will be solved.

To delete old preferences:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works then great but if it doesn’t you may have to manually delete them.

To do so:

On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings (you may be able to skip the previous steps with Windows 10). Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language> for any versions that you have. Make sure that InDesign is closed when you do this. When you relaunch the program it will create  new preference files and the program will be at its default settings. You should do this for any versions that are there. After deleting launch CC 2018, if the launch is successful, create and save a test file and then quit the program to “confirm” the preferences. It also may be a good idea to reboot your computer after this is done.

Once you relaunch the program you can begin customizing it to your liking.

After you’ve reset up the program (make sure that no document window is open), it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 26, 2017

Copy link to clipboard

Copied

I don't recall if I had that checked or not. I was thinking of going into my files and creating an object style for text aligned bottom but I have a lot of files and it would be very time consuming. I will try removing my preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 26, 2017

Copy link to clipboard

Copied

Hope it works out for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 27, 2017

Copy link to clipboard

Copied

So I have a fix for this problem that may lead to other problems if you are using Object styles in your documents. The problem occurred in an InDesign book file. The new version of InDesign must have text alignment top as a fixed default. If you have an InDesign document with both top and bottom alignment in your text boxes it will make them all top aligned if you have Object Styles set to synchronize in your book. If you uncheck object styles the problem seems to be fixed. Although this means if you rely on other object styles to synchronize they won't.

Otherwise every time you synchronize your book it will move the text to top aligned in your text boxes. Over to you Adobe. This was never a problem that occurred before. Is there a fix for this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
amaarora LATEST
Adobe Employee ,
Oct 27, 2017

Copy link to clipboard

Copied

Hi,

Thanks for narrowing the problem.

If possible can you please report the bug here:Adobe InDesign: Bugs: New (326 ideas) – Adobe InDesign Feedback

along with the sample documents and a video if possible. This will help us reproduce the bug and take appropriate action.

Thanks once again.

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...