Highlighted

Wrong font/style constantly replaces desired font/style

Participant ,
May 02, 2020

Copy link to clipboard

Copied

I am trying to import a Word document into ID. My document, a magazine, has long established styles. The "first paragraph of article" style includes a special initial cap. Even if I go to the paragraph menu BEFORE I start the import the "first paragraph of article" character is applied to the entire import. Even if I go to the character menu BEFORE I start the import and select the correct font the "first paragraph of article" is applied to the entire import. Even if I create a new text box BEFORE I try either of those solutions the "first paragraph of article" is applied to the entire import. Is there a weird preference I never set that is doing this? How can I make it stop? 

Also, if I manually correct the font, the initial cap of each paragraph is still the wrong size — the size of the initial cap in the "first paragraph of article" style. If I then try to apply the correct style, it reverts to the wrong font. 

And I lose all italic and bold in the original ms.

Most Valuable Participant
Correct answer by Willi Adelberger | Most Valuable Participant

When you import the text is the character style selected?

 

No charcter style must be selected, if so all text is with this style applied.

TOPICS
Type

Views

928

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Wrong font/style constantly replaces desired font/style

Participant ,
May 02, 2020

Copy link to clipboard

Copied

I am trying to import a Word document into ID. My document, a magazine, has long established styles. The "first paragraph of article" style includes a special initial cap. Even if I go to the paragraph menu BEFORE I start the import the "first paragraph of article" character is applied to the entire import. Even if I go to the character menu BEFORE I start the import and select the correct font the "first paragraph of article" is applied to the entire import. Even if I create a new text box BEFORE I try either of those solutions the "first paragraph of article" is applied to the entire import. Is there a weird preference I never set that is doing this? How can I make it stop? 

Also, if I manually correct the font, the initial cap of each paragraph is still the wrong size — the size of the initial cap in the "first paragraph of article" style. If I then try to apply the correct style, it reverts to the wrong font. 

And I lose all italic and bold in the original ms.

Most Valuable Participant
Correct answer by Willi Adelberger | Most Valuable Participant

When you import the text is the character style selected?

 

No charcter style must be selected, if so all text is with this style applied.

TOPICS
Type

Views

929

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 02, 2020 0
Adobe Community Professional ,
May 02, 2020

Copy link to clipboard

Copied

HOW are you importing text from Word. Copy and paste? or File > Place? If File > Place, are you choosing Show Options. If you're choosing Show Options, which options are you choosing?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2020 0
Participant ,
May 02, 2020

Copy link to clipboard

Copied

I've tried Command + D and File > Place. Originally I was choosing the first option,  to remove styles etc. Now it's started working better, after I quit the program and opened another document. However, the character style for the first character of the paragraph is now applied to the entire paragraph. I guess I'll try deleting and recreating it. But any advice on why this happened would be appreciated.

I also had a problem with extra space after paragraphs. I opened the paragraph tab, but could not delete the space, even after I'd done so in the original Word document. That seems to have stopped but I am not sanguine (a favorite word).

 

I'd also removed and reloaded the offending style. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2020 0
Most Valuable Participant ,
May 03, 2020

Copy link to clipboard

Copied

When you import the text is the character style selected?

 

No charcter style must be selected, if so all text is with this style applied.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2020 1
Participant ,
May 03, 2020

Copy link to clipboard

Copied

Yes, I realized this morning that was the problem. But I never selected the style; ID seemed to do so on its own. I'm about to go back to all my master pages to be sure the style is not mysteriously selected in their text boxes. Thanks for your reply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2020 0
Participant ,
Jun 03, 2020

Copy link to clipboard

Copied

I think that was the problem: somehow the character style became selected (though I had not selected it). However, I still have a problem with the character style. It is designated to, and should apply to, the initial letter of the the initial word only. Instead, the second letter is also in the decorative font selected for the initial cap.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 03, 2020 0
New Here ,
Jun 12, 2020

Copy link to clipboard

Copied

I am not sure about this second problem you have run into. In regards to the original issue, I discovered InDesign has a non-obvious (and quite sneaky) way of defining which styles (paragraph, character, object and tables) are set as the defaults. When nothing is selected in the entire document (Edit > Deselect All), if you then click on a paragraph or character (etc) stylesheet, that becomes the default stylesheet. Of course, this then causes issues when importing text. This drove me nuts until I found out why. The answer is: Deselect All, then choose Character Style = [None] (or Paragraph Style = [Basic Paragraph], Object Style = [None] etc), to set those as the defaults. This is especially important in a template document! Well, it fixed the issue I was having, anyway.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Participant ,
Jun 12, 2020

Copy link to clipboard

Copied

Many thanks. I'll make a point of deselecting all the styles in the template document. I thought I had, but it mysteriously chose the "First Paragraph of Article" style as the default.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0