Highlighted

XCode version for Ind15 plugin development

Community Beginner ,
Sep 10, 2020

Copy link to clipboard

Copied

Hi,

 

The InDesign 15 SDK help suggests using XCode 9.2 for Mac plugin development work.

asaxena_0-1599721794576.png

I want to know if this is a strict requirement of using XCode 9.3 is fine too?

 

PS: New to both Mac and InD/InD plugin work 🙂

 

Thanks,

Anubhav.

Xcode 9.3 should also work

Topics

How to, SDK

Views

67

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

XCode version for Ind15 plugin development

Community Beginner ,
Sep 10, 2020

Copy link to clipboard

Copied

Hi,

 

The InDesign 15 SDK help suggests using XCode 9.2 for Mac plugin development work.

asaxena_0-1599721794576.png

I want to know if this is a strict requirement of using XCode 9.3 is fine too?

 

PS: New to both Mac and InD/InD plugin work 🙂

 

Thanks,

Anubhav.

Xcode 9.3 should also work

Topics

How to, SDK

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Sep 10, 2020

Copy link to clipboard

Copied

Xcode 9.3 should also work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 10, 2020

Copy link to clipboard

Copied

Hi,

 

I need to do InD 15 plugin related development work and as per above I installed XCode 9.3. My Mac is Catalina but it looks like XCode 9.3 isn't compatible with Catalina.

 

asaxena_0-1599725783074.png

 

So, what is the XCode version / Mac Compatibility matrix that can be used for InD 15 plugin development work? For example, what's the XCode version that I need to install for my scenario?

 

Thanks,

Anubhav.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 10, 2020

Copy link to clipboard

Copied

If you need to develop 2020 plugins, you'll need Mojave and Xcode 9.2. And for the upcoming 2021 plugin development, you'll need Xcode 11.3 which should run in Mojave too, and it it also possible to have two version of Xcode on the same machine. So you can either downgrade from Catalina to Mojave or create a new partition and install Mojave

 

Btw, InDesign 2021 plugin sdk is now available in developer pre-release at https://www.adobeprerelease.com/beta/D1A76A97-F7DC-4552-DE3C-FF5F211C7492

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
asaxena LATEST
Community Beginner ,
Sep 10, 2020

Copy link to clipboard

Copied

Thank you very much. That is really helpful

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...