Highlighted

XML href to local smb server

Community Beginner ,
Apr 15, 2020

Copy link to clipboard

Copied

Hej there!
I have image files I want to link to via XML and load into InDesign automatically, for the pages they belong in. So right now it looks like this:
<container href="file:///Users/meeeeee/asdf.jpg"></container>

Pages without the image would simply be exported from the database as an empty <container></container>.

 

This works, but the file is lying on a local smb server...

OS X tells me, the path is "smb://servername/...", but that doesn't work.

Neither do things like "file:///smb://", "smb:///" or different other combinations I tested, feeling increasingly stupid.... 🙂

 

I was only able to find either local path or http examples online, it seems to be somewhat specific.

 

 

Also, would you know of some "alt = asdf" option like in html, so I can have text instead, in case the jpg would be missing?

 

Thank you and best wishes!
Mathis

InDesign does not understand the SMB protocol. Mount the SMB server in Finder and use a file path.

To construct the file path, navigate to an example image in Finder.

ctrl+click or right-click for Finder's contextual menu.

In that contextual menu hold the option key down to see a menu entry "Copy "test.png" as Pathname".

Use that pathname with a prefix of "file://" so it will be like "file:///Volumes/MyServer/test.png"

 

Topics

How to, Server developers

Views

434

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

XML href to local smb server

Community Beginner ,
Apr 15, 2020

Copy link to clipboard

Copied

Hej there!
I have image files I want to link to via XML and load into InDesign automatically, for the pages they belong in. So right now it looks like this:
<container href="file:///Users/meeeeee/asdf.jpg"></container>

Pages without the image would simply be exported from the database as an empty <container></container>.

 

This works, but the file is lying on a local smb server...

OS X tells me, the path is "smb://servername/...", but that doesn't work.

Neither do things like "file:///smb://", "smb:///" or different other combinations I tested, feeling increasingly stupid.... 🙂

 

I was only able to find either local path or http examples online, it seems to be somewhat specific.

 

 

Also, would you know of some "alt = asdf" option like in html, so I can have text instead, in case the jpg would be missing?

 

Thank you and best wishes!
Mathis

InDesign does not understand the SMB protocol. Mount the SMB server in Finder and use a file path.

To construct the file path, navigate to an example image in Finder.

ctrl+click or right-click for Finder's contextual menu.

In that contextual menu hold the option key down to see a menu entry "Copy "test.png" as Pathname".

Use that pathname with a prefix of "file://" so it will be like "file:///Volumes/MyServer/test.png"

 

Topics

How to, Server developers

Views

435

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Advisor ,
Apr 16, 2020

Copy link to clipboard

Copied

InDesign does not understand the SMB protocol. Mount the SMB server in Finder and use a file path.

To construct the file path, navigate to an example image in Finder.

ctrl+click or right-click for Finder's contextual menu.

In that contextual menu hold the option key down to see a menu entry "Copy "test.png" as Pathname".

Use that pathname with a prefix of "file://" so it will be like "file:///Volumes/MyServer/test.png"

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 16, 2020

Copy link to clipboard

Copied

Thank you very much, Dirk Becker – it works!

Strangely, when copying the path from the CMD+i window, there's like a secondary server name before that...

file:///Volumes/MyServer/...

vs.

smb://myOtherServerName/MyServer/...

So that's where I got lost... I'm not that much into servers, maybe it makes sense.

 

Do you happen to have an idea about the "alt=" option mentioned above?

"alt" doesn't work and just putting the text in the container will delete the image...

 

Thanks so much again! & Best wishes

Mathis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 17, 2020

Copy link to clipboard

Copied

Well, it doesn't seem to be an option anyway, as InDesign just opens a search/reconnect window when I import an XML with a non-working image link. I'm not sure a working alt function could change that...

 

Therefore, thank you very much again!

Mathis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...