Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom 3.4.1 does not correctly identify photo aspect ratios after catalog import

1 Vote
Community Beginner ,
Jul 21, 2011 Jul 21, 2011

Copy link to clipboard

Copied

I have Adobe Lightroom 3.4.1 and I just imported two separate catalogs into one new one. I had a smart collection that would sort out shots that were landscape aspect ratio and it is now empty, as Lightroom thinks that EVERY shot is now portrait aspect ratio. If I change ANY crop settings in the Develop Module, then Lightroom instantly and correctly identifies photos that are in landscape vs. portrait aspect ratio. Is there a way to fix this WITHOUT me having to touch each photo's crop settings to fix it??? THANKS...

Lee Hawkins
Cleveland, OH
Bug Fixed
TOPICS
Desktop

Views

9

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 24, 2017 Mar 24, 2017
Solved in Lightroom 4 and later.

Votes

Translate

Translate
8 Comments
Adobe Employee ,
Jul 21, 2011 Jul 21, 2011

Copy link to clipboard

Copied

Hi Lee,

Maybe. Here's what I would try:

1. Select all photos.
2. Switch to the Develop module.
3. With all photos selected, click the "Sync" button at the bottom of the right hand panels.
4. In the "Synchronize Settings" dialog box, uncheck everything except for "Aspect Ratio" (the last option).
5. Click the "Synchronize" button.
6. This will set all of your photos to exactly the same aspect ratio. Obviously this isn't what you want. So now, go to Edit>Undo Synchronize Settings.

That will return all of your photos to whatever aspect ratio they were at before the sync, but you will have "touched" the cropping of every photo, and that might fix the problem for you.

In the meantime, I'd like to try reproducing this problem myself. Can you tell me what operating system you're using?

Thanks,
Ben

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 21, 2011 Jul 21, 2011

Copy link to clipboard

Copied

I think Lightroom has some wonkiness in handling of orientation.

There's been a few threads about different flavors of it...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 22, 2011 Jul 22, 2011

Copy link to clipboard

Copied

Thanks for your quick reply, Ben. I'll try that as a workaround...that should save me a lot of time. I am using Windows Vista SP2 (32-bit) on an Intel Core 2 Duo E7400 @ 2.8GHz with 4GB RAM.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 27, 2011 Jul 27, 2011

Copy link to clipboard

Copied

Hi Lee,

I've been able to reproduce this problem myself. The issue is written up in our bug database, and we hope to fix it. Unfortunately, my genius idea for a workaround didn't work, as soon as you undo the sync, the smart collection reverts to not having the photos it should. So far I haven't been able to come up with a workaround that actually works.

A normal import (as opposed to import from catalog) does not cause this problem. You could always open the old catalogs, Save Metadata to Files, then import the photos into the new catalog via a normal import. This should bring all metadata and develop settings with them, and avoid the problem of the missing orientation info.

Thanks,
Ben

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 27, 2011 Jul 27, 2011

Copy link to clipboard

Copied

Ben, one problem with the workaround of using a normal import (after having saved Metadata to the files) is that edit histories won't be available.

I personally like to have access to edit histories in case I want to understand how I achieved some effect/look sometime later.

I made a feature request regarding retaining edit histories a while ago.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2011 Aug 12, 2011

Copy link to clipboard

Copied

i exported a catalog (export as catalog) and imported it on another pc, i have the same problem, all my images are landscape regardless of the real orientation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2011 Aug 12, 2011

Copy link to clipboard

Copied

i looked at the original catalog (on the original pc) and there the orientation of the pictures is correct. it may not be relevant, but the lightroom on the old pc was setup in english and the new pc is using a dutch version

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

LATEST
Solved in Lightroom 4 and later.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines