Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom 5.2: Not rendering correctly photos with spot removal applied in LR4

2 Votes
LEGEND ,
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

I've just upgraded my LR4 to LR5.2 and after open my LR4 catalog in LR5.2 I discovered that some photos (not all) with many spot removal applied are not rendering right:

LR4:


LR5.2:


Am I doing something wrong or is it really a sw bug?
Bug Fixed
TOPICS
Desktop

Views

14

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
42 Comments
LEGEND ,
Sep 18, 2013 Sep 18, 2013

Copy link to clipboard

Copied

I think it may be because of feather slide is set to zero on photos that clone spot removal was applied when converting LR4 catalog to LR5.2... if I am correct it is a sw bug...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 18, 2013 Sep 18, 2013

Copy link to clipboard

Copied

What is the feather slider set to currently?
Do the spots look better when you set feather to 0?

Mac or Windows?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 18, 2013 Sep 18, 2013

Copy link to clipboard

Copied

After catalog convesion, feather is set to 0 on all clone type spots.
If I change feather to ~50 it looks like I see in LR4.

I'm using Windows.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 18, 2013 Sep 18, 2013

Copy link to clipboard

Copied

I'm having the same issue! See this post:

http://forums.adobe.com/message/56945...

It doesn't seem to affect all Spot Removal clone/heal tool spots....only some.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2013 Sep 19, 2013

Copy link to clipboard

Copied

I found a way to list all images with cloned spots.

You can list images with cloned spots using a SQLite manangement sw (there are some free options out there, I used a sw called SQLiteAdmin) and executing the following query.

SELECT DISTINCT d.pathFromRoot, f.originalFilename
FROM AgLibraryFile f
INNER JOIN AgLibraryFolder d ON f.folder=d.id_local
INNER JOIN Adobe_images i ON f.id_local=i.rootFile
INNER JOIN Adobe_libraryImageDevelopHistoryStep h ON i.id_local=h.image
WHERE h.name LIKE '%spot%' and h.text LIKE '%spotType = "clone"%';

With this list you can measure if it is better wait for new release come out or do the correction of feather attribute for each image.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 20, 2013 Sep 20, 2013

Copy link to clipboard

Copied

Thanks Rodrigo. After looking at this further it appears ALL images edited in LR4 and previous versions with Spot Removal are set with Feathering at ZERO (0) inside LR5 FINAL. This is very disappointing to say the least.

I have over 20,000 images in my LR catalog. Finding those images with clone/heal Spot Removal and "manually" resetting the Feathering to 50 on all of these images is not an option.

One other person on a Mac OS X claims LR5.2 FINAL fixes this issue, but that's not the case on my Windows 7 system.

http://feedback.photoshop.com/photosh...

Rodrigo, what OS are you running on?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 20, 2013 Sep 20, 2013

Copy link to clipboard

Copied

Rodrigo there's an explanation as to what is happening in LR5.2 FINAL concerning Spot Removal clone spots during the LR4 (or earlier) catalog conversion:

http://forums.adobe.com/message/56994...

Adobe decided that it was best to default all prior image clone spots to '0' Feathering.

I ended up downloading and using AnyFilter to find images with Spot Removal applied and it works very well:

http://www.johnrellis.com/lightroom/a...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 20, 2013 Sep 20, 2013

Copy link to clipboard

Copied

Hi Rodrigo,

Thanks for brining this to our attention. It is a bug, and I have reported the issue to the engineers. When the bug is fixed, your old images should automatically go back to looking the way they did in Lightroom 4, you should not have to manually change any settings.

Thanks,
Ben

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

Hi Benjamin,

At this post:

http://forums.adobe.com/message/56994...

it is mentioned that Adobe staff Eric Chan indicates this is the way the Spot Removal clone tool functions in LR5.2, which is different than in previous versions. Based on this information it does not appear to be a bug, but a decision by Adobe's LR team concerning how to convert clone spots edited in prior versions when importing catalogs into LR5.2 Final.

Even if this is not the case (i.e. it is a bug) how are LR5.2 users supposed to use images that were edited in LR4 or earlier without first checking each and every image and "manually" correcting those that require Feathering? IMHO this is a huge problem for professional photographers who have 100,000s of images that they need to access and use today–Not when Adobe comes up with a solution. The only "workaround" for them is to go back and use LR4.4.1 for prior work AND LR5.2 Final for images they have already processed inside LR5.x.

I chose to use a non-Adobe plugin to filter and find images with Spot Removal tool application so I can "manually" correct each and every image. Fortunately I only found 179 images in my LR catalog with Spot Removal. A commercial photographer may have 1,000s of images with Spot Removal!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

My wife has just discovered that after upgrading from 5 to 5.2, all images with spot removal work have changed.
The feather slider is set to 75%, so to fix it, she has to find all these instances and change the feathering to 0.
Is this the SAME problem that others are having?
We need a fix asap Adobe!!!
Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

Peter, I am in the process of "manually" correcting my LR4 processed images inside LR5.2 Final. I am working on a Windows 7 platform and did not use LR5.0 initial release. In my case all images with Spot Removal editing applied in LR4 or earlier version have Feathering set to '0,' which is NOT always optimal. Your wife may find that many of her images require no adjustment if they've all been set to 75 Feathering. I can't speak for what the images look like that were edited in LR5 with its Spot Removal tools.

I used a LR plugin called AnyFilter to locate the images that have Spot Removal applied. I was surprised to see that out of 20,000+ images I only had 179 with Spot Removal, so I've chosen to "manually" update the Feathering setting. It turns out that I can actually get much better results with the new LR5.2 Spot Removal tools. On images that have less than optimal looking clone or heal spots I'm taking the opportunity to "redo" them using the ":improved" LR5.2 Spot Removal tools.

You can download AnyFilter here:

http://www.johnrellis.com/lightroom/a...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

Thanks. I found that and will use it unless Adobe comes out with a fix, since I have to do it as the wife does not have the patience to follow all the instructions - just wants it fixed - who can blame her.... 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

Worth noting: this SQL depends on "spot" in develop history, and therefore may miss some, e.g. if history cleared, or done by sync...

Better to use AnyFilter or DevMeta, in my opinion.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

This is a major mess, I would have to edit thousands of photos to fix this and I just upgraded to 5.2 today from 5.1/0 and i can tell you it isn't from LR4 to LR 5.2 that's an issues I just used spot editing this week with LR5 and all that work needs to be re done. I just spoke to support who states they can't help me to try back Monday as a specialist will need to review this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

1) What are you seeing for Feather setting on images edited in LR4 and previous versions?

2) What are you seeing for Feather setting for LR5.0 edited images?

3) Are there any other issues besides the Feather setting?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

No idea what was in LR4

LR5.0 didn't have the feathering slider, just size and opacity. All the images that are messed up have the Feathering slider set to 75%, after sliding down to 0% everything looks normal.

So far I have had LR 5.2 open for ten minutes before noticing this major problem and my current catalog has almost 10 thousand pictures and I can't even comprehend going through them to click on each little spot edit and sliding the feathering slider to 0.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2013 Sep 21, 2013

Copy link to clipboard

Copied

Figured out a little more, it is with the LR5 Spot removal using the brush to remove spots or sections that defaults to feathering of 75% after the upgrade to LR5.2 if it's just a simple round spot removal the feathering is defaulting to 0% in LR 5.2.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 22, 2013 Sep 22, 2013

Copy link to clipboard

Copied

I had not thought about it! Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 22, 2013 Sep 22, 2013

Copy link to clipboard

Copied

Windows 7

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 22, 2013 Sep 22, 2013

Copy link to clipboard

Copied

Thanks!
For me it's ok change the way it works in new versions, or better, in new edited cloned spots using LR5, but it is unacceptable change the spots from older versions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 22, 2013 Sep 22, 2013

Copy link to clipboard

Copied

Thanks Jason! That explains the difference (75% vs 0%).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 23, 2013 Sep 23, 2013

Copy link to clipboard

Copied

When using the Any Filter plugin, all of my wife's photos are being searched for the filter (images with spot removal). Since there are 10's of thousands, is there a way to only search a collection or a folder??
Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 23, 2013 Sep 23, 2013

Copy link to clipboard

Copied

In my opinion, it is best to ask the plugin author such questions, rather than here in the Adobe feedback forum. That said, the answer to your question is: check the 'Visible photos only' box.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 23, 2013 Sep 23, 2013

Copy link to clipboard

Copied

Peter, I have a little over 20,000 images in my catalog. When filtering on 'All Photographs' it only took 70 seconds to complete the filter search, which in my case pulled up 179 images. You can then Select All of the filtered images and create a collection labeled 'Spot Removal Images.' It will no longer be necessary to use the filter for this purpose.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 23, 2013 Sep 23, 2013

Copy link to clipboard

Copied

Great, as long as it's quick - we cancelled it after a while when we realized it was going through 60,000+ images. We will try again tonight.

Since this problem is caused by an Adobe product, and they have not responded to a solution, I feel warranted to talk about the work-around in this thread, whether it's using a third party program or otherwise. - that's my justification. 🙂 Thanks all.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines