Lightroom CC 2015.8 Edit in Photoshop CC 2017 Not Working Together

5 Votes
Explorer ,
Dec 11, 2016 Dec 11, 2016

Copy link to clipboard

Copied

In Lightroom CC 2015.8 when using the Edit in Photoshop CC 2017 feature, the image gets sent to Photoshop and is worked on as norma. Then when saved, closed, and returning to Lightroom, the image is not in the Library as is usually the case. Instead, one must now right click on the folder to synchronize it in order for the edited Photoshop PSD to appear. Is anyone else finding this to be the case?

It's kind of frustrating that whenever there seems to be an update for Lightroom, something essential like this gets broken along the way. 
Bug Investigating

Views

7

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
30 Comments
Community Beginner ,
Nov 23, 2017 Nov 23, 2017

Copy link to clipboard

Copied

Great solution. Thanks Russell

Votes

Translate

Translate

Report

Report
New Here ,
Dec 31, 2017 Dec 31, 2017

Copy link to clipboard

Copied

Having just found this thread because I'm getting problems in Ligthroom CC 7.1 (latest on Mac as at 2017-12-31) with similar weird workflows... I've created an idea post...

https://feedback.photoshop.com/photoshop_family/topics/-edit-in-or-photo-merge-of-a-photo-should-res...

Votes

Translate

Translate

Report

Report
LEGEND ,
May 11, 2018 May 11, 2018

Copy link to clipboard

Copied

I am having the same exact issue as the original complaint. I edit in photoshop and when I save, it goes to the original folder and not back into lightroom. It was working fine two days ago and yesterday, it just stopped working

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 11, 2018 May 11, 2018

Copy link to clipboard

Copied

Im having the same problem on Lightroom Classic CC (latest update 2018, MacOS) and just did something that "fixed" it.
I read on another post that the user linked the problem to files on an external drive, which is just as I work.
I copied the folder containing my ".lrcat" file from the external drive to the desktop, and then proceeded to double click the .lrcat file which opened it on LR. When I clicked over a the photo I was trying to edit previously LR told me it couldnt locate the file, and asked my if wanted to do it.

I then made another new folder on my desktop, named it "photo" and dragged the corresponding .rar file from the external drive in to it.

I went back LR, "located" the file on this new folder on my desktop and proceeded to the "Photo>Edit in" menu and found "Edit in Photoshop" enabled, which previously I found both greyed out and enabled in different occasions but didn't work regardless, but this time when I clicked it, it all worked as usual, opening the file on PS and saving the edited PS on my same LR collection.

Im doing this right now and this is as far as Ive gone, but im guessing Im going to try moving my "lrcat" folders and its corresponding ".rar" files folders from my external drive to the HD on my mac, and then back to the external drive, with a different name or something.

Let me know if this works or is of any help!
*Update* I did that only with the .lrcat folder and its all back to normal, no need to move all the .rar files.
I did all the bunch of stuff described above, but maybe just moving the .lrcat folder back and forth, after deleting the original on the external HD could fix it. It sounds like a file corruption issue.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

LATEST
Lightroom Version Number: 
Photoshop Version Number:
Operating System/Version?
Location of original folder?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report