Lightroom Classic: Backup 'extended attributes' prevent backup software working

10 Votes
Community Beginner ,
Jan 10, 2016 Jan 10, 2016

Copy link to clipboard

Copied

I have a problem trying to get lightroom catalog backup files backed up using my backup software LiveDrive. The people at LiveDrive tell me that the files cannot be backed up because they have 'extended attributes'.If I unzip and re-zip the backup then it gets backed up OK, so clearly there's some difference between the zip files created by Lightroom and those created directly by Windows.Can anyone cast any light on this? I'm tempted to just write a powershell script to remove extended attributes, but not sure which would be safe to remove (would Lightroom be able to restore properly afterwards), and not entirely sure which would need to be removed to allow the backup to happen anyway.
Bug Acknowledged

Views

6

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 19, 2017 Apr 19, 2017
This bug is fixed in the latest Lr CC 2015.10 (6.10) update. Please check.

Votes

Translate

Translate
20 Comments
Community Beginner ,
Jan 11, 2016 Jan 11, 2016

Copy link to clipboard

Copied



The T attribute on Windows files is described by Microsoft as:

"The file is temporary. A temporary file contains data that is needed while an application is executing but is not needed after the application is finished. File systems try to keep all the data in memory for quicker access rather than flushing the data back to mass storage. A temporary file should be deleted by the application as soon as it is no longer needed."

It seems sensible therefore that backup software ignores these files, but I want my Lightroom backups backed up to my cloud storage.

I have worked around this for now by running a powershell script to remove this attribute as part of my backup process, but this should not be necessary.

This was not happening on earlier versions of Lightroom - the earlier files do not have this attribute set. It has taken several weeks in discussions with my backup software vendor to work out why my Lightroom backups were no longer being copied to my cloud storage.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 13, 2016 Jan 13, 2016

Copy link to clipboard

Copied

Yes, me too. I spent months tracking this down with my backup vendor.

I make regular backups of my Lightroom catalogue. I also like to have my catalogue backups included in my system backup. However, when Lightroom creates a backup of the catalogue, the zip file has the "temp" attribute set. Quite understandably, some backup software (including mine) will ignore files with the temp attribute set, so the catalogue backup is not backed up.
Thanks for reading,

Brian

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2017 Jan 24, 2017

Copy link to clipboard

Copied

Has this really been outstanding for a year when all sorts of cosmetic stuff has been coded into Lightroom?
EVERYONE who tries to backup their Lightroom backup zip files will find that they have not been in fact saved anywhere because of the erroneous Temp attribute set by Adobe on these critical files.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2017 Jan 24, 2017

Copy link to clipboard

Copied

Oh, the issue has been around longer than that. It would be such a simple thing to fix too!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 25, 2017 Jan 25, 2017

Copy link to clipboard

Copied

This is insane. Needs to be fixed!

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 12, 2017 Feb 12, 2017

Copy link to clipboard

Copied

This is really bad, and hard to understand that it cannot be fixed in over a year!!!

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Feb 12, 2017 Feb 12, 2017

Copy link to clipboard

Copied

This is one of the reasons I switched to RoboCopy instead of Xcopy in my backup script. RoboCopy lets me turn off the "T" attribute.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 13, 2017 Feb 13, 2017

Copy link to clipboard

Copied

Joseph, many thanks for the RoboCopy tip! It solves the issue for me. Have anyone tried to restore a zipped backup with the T attribute turned off? Maybe Adobe require to have it on for restore? (Which would be just as stupid as setting the temp attribute in the first place).

Votes

Translate

Translate

Report

Report
New Here ,
Mar 18, 2017 Mar 18, 2017

Copy link to clipboard

Copied



At least on Windows 10, the catalog backups created by Lightroom are left permanently marked as "temporary" in the filesystem:


PS D:\Amazon Drive\Lightroom Catalogs> Get-ChildItem . -recurse | where {$_.attributes -match "temporary"} | ft fullname,lastwritetime,attributes -autosize
FullName                                                                                             LastWriteTime                 Attributes
--------                                                                                             -------------                 ----------
D:\Amazon Drive\Lightroom Catalogs\2017-03-03 2258\Lightroom Catalog.lrcat.zip                     3/3/2017 10:59:05 PM  Archive, Temporary
D:\Amazon Drive\Lightroom Catalogs\2017-03-04 1358\Lightroom Catalog.lrcat.zip                     3/4/2017 1:58:23 PM   Archive, Temporary
D:\Amazon Drive\Lightroom Catalogs\2017-03-04 1618\Lightroom Catalog.lrcat.zip                     3/4/2017 4:19:09 PM   Archive, Temporary
D:\Amazon Drive\Lightroom Catalogs\2017-03-17 1942\Lightroom-Catalog.zip                             3/17/2017 7:42:43 PM  Archive, Temporary
D:\Amazon Drive\Lightroom Catalogs\2017-03-18 1042\Lightroom Catalog.lrcat.zip                     3/18/2017 10:43:10 AM Archive, Temporary
While I'm not aware of any issue this causes for Lightroom itself, it does cause Amazon Drive to deem the file temporary (because it is) and skip the sync that would otherwise occur:
[2017-03-18 10:52:49.387 -05:00  Info] [FileFilter] ignoring temporary file 

"D:\Amazon Drive\Lightroom Catalogs\2017-03-18 1042\Lightroom Catalog.lrcat.zip"
The behavior exhibited by Amazon Drive is definitely reasonable, and is not exclusive to it. I'm sure plenty of backup services will ignore temporary files since a file marked this way should be temporary.

When Lightroom finishes its backup, it really should remove the "temporary" filesystem attribute since the file really isn't temporary anymore.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 18, 2017 Mar 18, 2017

Copy link to clipboard

Copied

See also, my response to Assaf Frank which explains how this can be resolved per file, directory, or directory tree using Windows Powershell.

It's not an idea solution, but it will work. Depending on your backup software, it may take a bit for it to notice the file is no longer temporary or you may need to force it to rescan your files.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 20, 2017 Mar 20, 2017

Copy link to clipboard

Copied

Thanks. Will investigate.

Votes

Translate

Translate

Report

Report
Explorer ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

Thank you for your help I really appreciate it, it works like magic.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

A fix was made for the next Lr update.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

No problem, Assaf!

Thanks, Simon; thats great news!  🙂

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

This bug is fixed in the latest Lr CC 2015.10 (6.10) update. Please check.

Votes

Translate

Translate

Report

Report
New Here ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

Thanks for the update, Simon! I'll check it out and share what I find. 🙂

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

It is fixed now. Thank you.

My backup software livedrive picks up the zip files for backup now.

Votes

Translate

Translate

Report

Report
New Here ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

And the problem is back. 😞
I'm having the latest version "7.3.1", and now I can't backup my files (with Synology Drive).

Votes

Translate

Translate

Report

Report
New Here ,
May 28, 2018 May 28, 2018

Copy link to clipboard

Copied



When doing a backup of my catalog (when exiting LR), the file keeps the attribute "Temporary" set after the backup is done.
That means that I can't do a backup of the file (done with Synology Drive).
I'm having the latest version "7.3.1".
It's a old known problem, there has been fixed previous.
//Anders

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 28, 2018 May 28, 2018

Copy link to clipboard

Copied

LATEST



Thanks for letting us know, Anders.
We are aware of this issue and a fix in underway.

Thanks,
Sunil

Votes

Translate

Translate

Report

Report