Lightroom Classic CC: Keyboard shortcuts for rotate left and right changed incorrectly in German, Spanish, French, Italian, and Swedish

14 Votes
LEGEND ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

[Update: The shortcuts for rotate left and right were incorrectly changed in German, Spanish, French, Italian, and Swedish.  See here for details:
https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-cc-keyboard-shortcuts-for-r...
- John Ellis]

Hi Adboe,

I like working with LR and it's the software product I use the most. It's a good piece of software and I never had any troubles working with it and I always was a happy user. (German keyboard layout on a Mac)

But in the new LR version the keyboard shortcuts to rotate images have been changed, unfortunately to the worse. From (Command+) and (Command+.) to (Command+<) &
(Command+#). You did fix something that was not broken.

Here's what these new shortcuts do:
1) They only work for me when an image I have fully zoomed into an image.
2) The shortcut to rotate an image clockwise (Command+#) is the same as the one to zoom into an image (Seriously?! Did no one double check that before the release?).
3) In the previous LR version you could rotate images with the shortcuts in both directions without having to use two hands on the keyboard because the keys for both directions were right next to each other (, & .). Now the keys used for this are on the opposite ends of the keyboard (at least mine, which has a German layout).

I really hope you come up with an update to bring back the old shortcuts to rotate images.
Bug Fixed

Views

11

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
39 Comments
Community Beginner ,
Dec 13, 2017 Dec 13, 2017

Copy link to clipboard

Copied

Thx for this info.

I changed  $$$/Application/Menu/Edit/Preferences/KeyWin=Cmd+, to something else and now rotating images works fine for me even in develop module.
 

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

For italian keyboard I sugget to modify the file: C:\Program Files\Adobe\Adobe Lightroom Classic CC\Resources\it\TranslatedStrings_Lr_it_IT.txt

and find out the line:
"$$$/AgLibrary/Menu/Photo/RotateLeft/Key=Cmd+["
"$$$/AgLibrary/Menu/Photo/RotateRight/Key=Cmd+]"

and sobstitute with:
"$$$/AgLibrary/Menu/Photo/RotateLeft/Key=Shift+J"
"$$$/AgLibrary/Menu/Photo/RotateRight/Key=Shift+M"

This solve the problem and match the indication of the Shift+H Windows.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 28, 2018 Mar 28, 2018

Copy link to clipboard

Copied

Hi All,

The issue for keyboard shortcuts not working correctly for German keyboard has been fixed in the latest update of Lightroom Classic CC 7.2.
I would request you all to please make sure that you have Lightroom 7.2 installed  and let us know if the latest update fixed the issue or does the issue persist.
Regards
Tanuj Sandal

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 28, 2018 Mar 28, 2018

Copy link to clipboard

Copied

Tanuj,

I tested the rotate shortcuts for the five languages involved, DE, ES, FR, IT, SV. They all appear to have workable shortcuts (though someone using ES or FR should comment on the choice of Cmd + ]):

RackMultipart201803292973013z5-b608ec0b-8197-42a5-816f-b6ea4140e176-704960852.png

However, the shortcuts shown in Help > Library Module Shortcuts are still wrong for ES and FR.  Whoever edited ES and FR forgot to update the separate entries for that Help screen.

Also, in German, the Strg key is still incorrectly labeled as Ctrl in the shortcuts shown in the menus:

RackMultipart2018032957350230u-a641238f-1093-4d87-b2f9-976272e45a5d-699245352.png

This is because of the following incorrect change in TranslatedStrings*.txt:
$$$/Win/MenuDisplay/KeyboardShortcutElement/Ctrl=Strg
=>
$$$/Win/MenuDisplay/KeyboardShortcutElement/Ctrl=Ctrl

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 18, 2018 Jun 18, 2018

Copy link to clipboard

Copied

Hi,

Lightroom Classic 7.4 was released today and should address this issue.  Please update your Lightroom to the latest version and let us know if you continue to see the issue. Thank you for your patience.

https://helpx.adobe.com/lightroom/help/whats-new.html

Thanks,
Smit Keniya

Smit | Lightroom Classic Team

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 19, 2018 Jun 19, 2018

Copy link to clipboard

Copied

Lightroom Classic CC Version 7.4 was released earlier today and should have a fix for this issue. Give it a try and let us know if you continue to see this problem. Thank you for your patience!
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Participant ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

I use an English keyboard. Since the last update many of the shortcuts are doing the wrong thing. 

For example, cntrl/shift U is supposed to Auto White Balance but now it exports a DNG. Other shortcuts are also performing the wrong task. While working on another LR bug Adobe support already reset my preferences and that did not fix the shortcuts problem.
Corporate photographer based in Calgary, Canada and Oviedo, Spain. Making portraits, architectural, industrial and advertising photography for national and global brands.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

In which language are you running Lightroom?

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

Also, please copy the first ten lines from the menu command Help > System Info, so we can see the precise versions you're running.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

Running it in English. First 10 lines:

Lightroom Classic version: 8.1 [ 1200465 ]

License: Creative Cloud

Language setting: en

Operating system: Windows 10 - Business Edition

Version: 10.0.17763

Application architecture: x64

System architecture: x64

Logical processor count: 8

Processor speed: 3.6 GHz

Built-in memory: 28613.0 MB
Corporate photographer based in Calgary, Canada and Oviedo, Spain. Making portraits, architectural, industrial and advertising photography for national and global brands.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

Strange. This is a long shot, but does this file exist on your system?

C: \Program Files\Adobe\Adobe Lightroom\Resources\en\TranslatedStrings_Lr_en_US.txt

It shouldn’t exist, but if it does, it could be the cause of your problems.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

No, that file does not exist.
Corporate photographer based in Calgary, Canada and Oviedo, Spain. Making portraits, architectural, industrial and advertising photography for national and global brands.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

Then I suggest doing a reinstall, as suggested in your other thread.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 20, 2019 Jan 20, 2019

Copy link to clipboard

Copied

LATEST
Re-install fixed at least two of the bugs. 
Corporate photographer based in Calgary, Canada and Oviedo, Spain. Making portraits, architectural, industrial and advertising photography for national and global brands.

Votes

Translate

Translate

Report

Report