Lightroom Classic: Noise reduction effect not displayed in Develop mode

23 Votes
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

Noise reduction effect not displayed in Develop mode when image is smaller than 1:1. Enlarged is ok, but when I set FIT or FILL, image displayed without noise reduction settings applied (I think so).
Bug Won't fix

Views

28

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 108 Replies 108
108 Comments
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

In addition. When press before/after button and copy 'after' settings to 'before' - 'before' image displayed with noise reduction, 'after' image without.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

That's not new. LR doesn't display noise reduction or sharpening results except at 1:1 or above. They're still there, and will export correctly. But they aren't rendered at less than 1:1. After they are exported they are "baked in" and visible at any size.

Votes

Translate

Translate

Report

Report
Guide ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

It's always been that way. There's even a little ! mark in the Detail tab which explains the issue...

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

I think this is a new issue with LRCCC I have this same issue. All my old files(pre LRCCC) show noise reduction at "fit". Any new file i import doesn't show noise reduction in develop module.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 18, 2017 Oct 18, 2017

Copy link to clipboard

Copied

I found a sign '!' with an explanation, but it worked well in LRCC before upgrade to Classic without zoom to 1:1. Is there a way to configure Classic do same?

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

UPDATE: If i have noise reduction at 100%, with the size set to "fit" and White Balance at "auto" the noise reduction effect shows up in "fit" size.

Basically it seems to be linked with the white balance.
If WB is "auto" NR shows in "fit".
If WB is anything other than "auto" NR doesnt show in "fit"

Looks like a glitch to me...or maybe noise reduction is linked with camera WB. Anyone else seeing this?

Also, all my already edited files show NR at "fit"

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Same problem here, no NR is displayed at all in my standard "fit" view but is applied when i zoom in.  Unlike the above my white balance has no effect on this.
This is a different behaviour from LR6 and CC which did update NR on the "fit" view quite happily.
Confirmed this by running LR6 with the same catalogue and image.

Its a fairly serious bug as i really cant tell whats happening to my image when making changes if the whole thing appears with noise.

Votes

Translate

Translate

Report

Report
Guide ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Sorry, but no matter what you see or imagine, noise reduction is only accurate and visible at 1:1 view. What you're seeing when you fit is simply an approximation of some sort. If you need to see exactly what you're NR looks like, then either zoom 1:1 or use the preview window in the Details tab.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Here are some pics. Hopefully the differences are visible on the screenshots
 
Image 1: NR-0 and WB-auto
RackMultipart20171019200711umf-ff775bf7-3b6b-47ee-8a2c-45a5508d3c56-1897007648.JPG

Image 2: NR-100 and WB-auto
RackMultipart201710191162321tu-20cd4681-4914-4587-b4fd-766b49e24417-337596113.JPG

Image 3: NR-0 and WB-As Shot
RackMultipart20171019458215eiu-c1dbe0ce-0ad6-434a-a473-3ccb9dc726c2-588910982.JPG

Image 4: NR-100 and WB-As Shot
RackMultipart201710192487f2n3u-c84165e8-c74a-40d4-a29f-3f7654595b34-736157939.JPG

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Its an approximation that is accurate, gives a good general feel of the image and something lightroom has done for years.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Ive found a non ideal workaround.  I've disabled the "Use GPU" in the menu and restarted lightroom.  Without using GPU acceleration normal behaviour is restored, it renders NR and Sharpening in fit and fill views.  Re-enabling GPU functions and it stops again.
FWIW im on Windows 10 autumn update, GeForce 1060 with latest drivers.

Maybe someone else experiencing this issue can test with and without GPU acceleration and a LR restart.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

OK im seeing the GPU thing as well. So it must be a driver compatibility issue with the new LRCCC. Im using a GTX titan

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Id go more for LR bug than driver issue.  Ive just tried it on older drivers as well.
Performance doesn't seem and different at all with GPU acceleration turned off so for now i guess i'll have to leave it off to avoid losing this very very useful feature.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

I was just on tech support with adobe and the guy said my GPU was outdated (LOL) he said to wait for a GPU firmware update. LRCCC requires directx 12 or Opengl 3.3. My GPU supports both

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

I updated the GPU drivers from 385 something to 387.92 but no luck

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

It's good to see that I'm not the only one having this bug. I have a GTX 850m and the bug disappears when I turn the GPU acceleration off. I hope Adobe adresses this issue ASAP, because I really feel a drop in performance when I'm not using hardware acceleration... And it's pretty clear that this is not a graphics card driver issue, since there was no bug when using the older versions of Lighroom.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

The issue seems to happen with files I edit after updating to LRCCC. Meaning my older files, which I have already edited dont have this issue. Its only on files I havent edited before. Looks like a driver issue to me...or driver-lightroom compatibility issue.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Disabling GPU acceleration solve the problem for me (GT650m). Not sure about performance changes. My files already edited in LR6 have this issue, but think I'm did't exported they before. 
Trying to update macOS for latest version and test.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

I think it's probably a driver-lightroom issue... But the thing is: everything was working just fine before the update. I hope Adobe and nVidia to work together to fix this ASAP.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

FWIW ive since tried 3 different drivers ranging from this months latest release to ones for March.  The issue is present on all on them in LR classic.  The issue is NOT present on old Lightroom CC/6 using any of those drivers.
So im going for a bug in LR Classic itself as opposed to a driver issue as all of them worked perfectly on older versions of lightroom.
"Old" video card is rubbish as well, people are getting this with 1050/60/70/Titan range modern high end cards - there are no newer ones!

What OS are people experiencing this on?  Im using windows 10 (autumn creators update) and it does it.  It is doing it for apple users or win7 users as well?

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied



With new lightroom Classic CC there seems to be a problem with GPU acceleration whilst on Images are showing significant grain, almost like no noise reduction has been applied

The two images below the only difference between them is GPU acceleration on vs off. Obviously, it's a bad photo but it demonstrates the problem quite clearly 

Sorry had to upload to dropbox couldn't post a Jpg apparently 

https://www.dropbox.com/s/n4cipdmcroal1d9/Screenshot2017-10-2218.01.09.png?dl=0 https://www.dropbox.com/s/qn4whgz8c7g59xy/Screenshot2017-10-2218.01.28.png?dl=0 

I've updated Adobe CC and my Nvidia Drivers 
My GPU is a "Geforce GTX 980Ti" 

Any help is really appreciated 
-Declan 

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

@eartho Whilst this is true, as in it's advisable to better see the effect of noise reduction and sharpening at 100%, previously, you were still able to see the effect at fit or fill when NR was applied. Now, if you drag the noise reduction slider to the far right, you see absolutely no change at fit or fill. This is an incorrect behaviour of LR

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Hi all,  please follow the step 2 mentioned here https://helpx.adobe.com/lightroom/kb/crash-gpu-directx-enabled.html and let me know if this helps.
Venkatesh Penjuri
Adobe Lightroom Team

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Hi all, since driver update did not help solve the issue, please follow the step 2 mentioned here https://helpx.adobe.com/lightroom/kb/crash-gpu-directx-enabled.html and let me know if this helps.
Venkatesh Penjuri
Adobe Lightroom Team

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Isn't it better to follow the directions in this thread? Worked for me to resolve the blocked-up shadows issue in the Develop module/Camera Raw.

Votes

Translate

Translate

Report

Report