Lightroom Classic: Side panels erratically overlay import dialog (latest macos)

39 Votes
LEGEND ,
Nov 03, 2018 Nov 03, 2018

Copy link to clipboard

Copied

Screen recording of bug attached
I _can change side panels width but cant hide them while import dialog is under
 

Lightroom Classic version: 8.0 [ 1193777 ]

License: Creative Cloud
Language setting: en-RU
Operating system: Mac OS 10
Version: 10.14.1 [18B75]
Application architecture: x64
Logical processor count: 8
Processor speed: 2,7 GHz
Built-in memory: 16 384,0 MB
Real memory available to Lightroom: 16 384,0 MB
Real memory used by Lightroom: 2 927,5 MB (17,8%)
Virtual memory used by Lightroom: 8 782,1 MB
Memory cache size: 967,0MB
Internal Camera Raw revision: 61
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 2366MB / 8191MB (28%)
Camera Raw real memory: 2382MB / 16384MB (14%)
Displays: 1) 5120x2880

Graphics Processor Info: 
Metal: AMD Radeon Pro 455



Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Users/medvdv/Pictures/Catalog 2018/Catalog 2018.lrcat
Settings Folder: /Users/medvdv/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) Facebook
5) Flickr
6) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: LG UltraFine Display Audio
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 12.1x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro 455 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-2.2.8
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 
Bug Fixed

Views

15

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 04, 2019 Nov 04, 2019
Lightroom Classic 9.0 was released earlier today and contained a fix for this issue. Please give it a try and confirm it is working for you after updating. Thanks for your patience.

Votes

Translate

Translate
64 Comments
Enthusiast ,
Nov 03, 2018 Nov 03, 2018

Copy link to clipboard

Copied

It's the same for me, and I do not see why we should hide the side panels, they are essential to drive the import. Otherwise we use the reduced panel!
RackMultipart20181103158196maz-eb99c301-1c87-4c5e-9003-774483832db0-215642609.png

Yves Crausaz, Suisse, retraité actif dans le monde de la photo et des arts graphiques.

Votes

Translate

Translate

Report

Report
Engaged ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Yves - It doesn't appear that Alexander is trying to hide the panels in the Import dialog.  In his video, he's actually showing that he can't see the sides of the Import dialog at all.  He's still seeing the side panels for the Library module.

Votes

Translate

Translate

Report

Report
Engaged ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Alexander - my first suggestion would be to try resetting Lightroom's preferences.  Here's a link to a how-to, if you're not familiar with that process - 
https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Yes, and i cant hide side panels of library while import dialog under

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Will try, thanks

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Drop out of Full Screen mode. That will solve this.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

it solvs yes but this is definitely just bug with Z order of planes and Adobe need to correct it - i like fullscreen mode why i should exit it each time when importing something 😉

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

I can repro this and will log a bug with the team. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 30, 2018 Dec 30, 2018

Copy link to clipboard

Copied



The dialogue box that comes up when importing photos to Lightroom glitches behind the library window (navigator and so on). This has been going on since October and requires me to restart the program several times before continuing my normal work flow.RackMultipart20181230139361gcd-d0fca48c-20b8-4f7d-bedd-0fe32779e1de-304759860.png

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Dec 30, 2018 Dec 30, 2018

Copy link to clipboard

Copied



Update to version 8.1. This has indeed been fixed.

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 30, 2018 Dec 30, 2018

Copy link to clipboard

Copied

So this bug has been fixed in LR 8.1 but not yet marked as fixed?

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 30, 2018 Dec 30, 2018

Copy link to clipboard

Copied

I am running 8.1 and can confirm that this problem still has not been fixed on my system.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 31, 2018 Dec 31, 2018

Copy link to clipboard

Copied

same here, issue is still NOT fixed

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Dec 31, 2018 Dec 31, 2018

Copy link to clipboard

Copied

Strange. It does not occur on my system under the exact same circumstances, so I assumed it was fixed. Maybe it also depends on screen settings? What settings do you guys use? I tried it on a MacBook Pro 13” (2016 with touch bar) and default screen setting.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 02, 2019 Jan 02, 2019

Copy link to clipboard

Copied

This issue is still currently open in our system. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 12, 2019 Jan 12, 2019

Copy link to clipboard

Copied

I also have had this issue since upgrading to LR8 and it is still a problem today (running LR 8.1)

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied



I have an issue when i'm importing the 2 side bars for the quick develop module overlay and hide the import options. 

Sometimes i can get one away but most of the time i need to restart lightroom.

RackMultipart201902031070561os-90cde40f-6dc7-4f34-a169-8684a0f62c1c-610696482.jpgRackMultipart2019020338549xd2n-f7569400-b6fb-4f35-9753-ead8793a8f3d-1806379790.jpg

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Another workaround to try: Drop out of full screen mode.

Votes

Translate

Translate

Report

Report
Explorer ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

True (that's what I have to do all the time now in order to be able to import).  But why should we have to?  This is a bug and should be fixed.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Agreed.

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

I’ve done that, sometimes it works sometimes it doesn’t.

But it’s definitely a bug that needs fixed

Votes

Translate

Translate

Report

Report
New Here ,
Feb 11, 2019 Feb 11, 2019

Copy link to clipboard

Copied



For the past year or so I've seen a really annoying bug in Lightroom which as far as I can tell nobody else has reported. I have seen two manifestations what I think are the same issue, where a user interface element is loaded underneath one that is supposed to be lower in the z-index. See screenshots below.

The first is on the keyword suggestion dropdown list, which as you can see in the screenshot is very faint, but if you type far enough you can see that the full opacity panel starts to show up outside the tool area to the right. It is clearly loading the menu under the tool panel, when it should be above it. This manifestation of the problem is common for me, but somewhat intermittent and often goes away when restarting Lightroom.

The second is much more insidious, and happens consistently for me. Whenever I press the Import button, the import modal dialog loads underneath all the other panels except the currently displayed photo, so I typically see a cropped selection of photos available to import but no buttons to interact with the import because they are hidden under the library, tool and filmstrip panels. The screenshot shows where the "Copy as DNG" tab at the top of the import dialog is obscured by the normal Lightroom top menu bar. The only way I have found to clear this version of the bug is to switch out of full screen mode and back to it again, which I have to do on every import.

Has anyone else seen this behaviour?

RackMultipart201902091060851z0-7c80346a-317d-43cb-a15a-1b739d11c643-24720929.png

RackMultipart20190209461351nsu-f7e0c1db-b98e-4fdd-af76-66a8a7b69843-924476735.png

Votes

Translate

Translate

Report

Report
Explorer ,
Feb 11, 2019 Feb 11, 2019

Copy link to clipboard

Copied

Yes, there is already at least one well-subscribed thread on this forum about the import issue you describe.  I confirm that I have it myself, I think I first noticed it with the initial LR 8.0 major increment upgrade.

Votes

Translate

Translate

Report

Report
Explorer ,
Feb 17, 2019 Feb 17, 2019

Copy link to clipboard

Copied

quick fix: the tab key will get rid of them until the problem is addressed

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied



I am running Lightroom CC 8.1 on a MacBook with OS Mojave 10.14.2.  I can import files into lightroom fine when I first start lightroom but if I try to import again the import screen gets locked behind the sidebars and I can't control what to import.  I can re-boot Lightroom and import, but that's a pain.  Anyone have an answer or similar problem?

Votes

Translate

Translate

Report

Report