Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: Droplets no longer work with export presets (CC 2015.4)

10 Votes
Explorer ,
Jan 27, 2016 Jan 27, 2016

Copy link to clipboard

Copied

Export preset where you chose "Open in other application" and you have selected a droplet (I have a folder with many droplets) does not work, because the droplet utilized by photoshop is not the one chosen in the export preset
Bug Fixed
TOPICS
Desktop

Views

65

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Apr 28, 2016 Apr 28, 2016
This should be fixed in the Lightroom CC 2015.5.1/6.5.1 update that was released today: http://blogs.adobe.com/lightroomjournal/2016/04/lightroom-cc-2015-5-1-now-available.html

Votes

Translate

Translate
LEGEND , Mar 16, 2016 Mar 16, 2016

Votes

Translate

Translate
52 Comments
Explorer ,
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

no one?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

I just tested my PS export droplets with LR CC 2015.4 / OS X 10.11.2, and they're working as expected.

What precisely are the symptoms you see on the screen when you do an export?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

if I select a photo and export it with the same export preset containing a droplet 5 times I get 5 different results. Droplets are working fine, the export function in Lr is working but ”open in other app” and selection a droplet five random result. It was fine before the last Lr update!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

I tried changing the location of the droplet and put it on the desktop, creating another export preset with that droplet, but I get the same result It select a random droplet (I have tens of them) and process the photo with it..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

PS: I got OS X 10.11.3 (15D21). I noticed in the last mac update all my usb memories, sd, cf, and hard disk are now showing the real capacity, a 2tb hd shows up as a 2tb hd and not a little less as usual!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 29, 2016 Jan 29, 2016

Copy link to clipboard

Copied

I did some more testing and I've observed the same symptoms (CC 2015.4 / OS X 10.11.2).  I have a number of export presets, each with a different Photoshop droplet for the export's post-processing application.  When LR runs one of the export presets, it ignores the droplet specified in the preset and instead runs the last droplet that was successfully executed.  You can force an export to use its specified droplet by renaming all of the other droplets and restarting LR before doing the export.  Then that droplet becomes the last droplet that was successfully executed, and it will be run for all subsequent exports.

I rolled back to CC 2015.3 and the export presets started working correctly again.  See here for how to roll back: http://www.lightroomqueen.com/how-do-i-roll-back-to-lightroom-2015-1-1-or-lightroom-6-1-1/

Things that don't work around the bug:

- Resetting LR's preferences.

- Exporting from a new catalog.

- Recreating the droplets, contained actions, and export presets from scratch.

- Restarting LR and PS.

- Putting each droplet in a separate folder.

The bug didn't occur for me on Windows 10.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 01, 2016 Feb 01, 2016

Copy link to clipboard

Copied

Unfortunately, using the Run Any Command plugin as a workaround fails.  I tried using this command line to Run Any Command:

open -a path-to-droplet.app {FILE}

But when I exported more than 1 or 2 files, Photoshop crashed.  Apparently, the droplet .app doesn't wait for the droplet to finish, and Photoshop can't tolerate running multiple invocations of a droplet simultaneously.

Same problem occurs with a command line that invokes the executable directly:

path-to-droplet.app/Content/Droplet {FILE}

So the only workaround is to rollback to CC 2015.3.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 01, 2016 Feb 01, 2016

Copy link to clipboard

Copied

I wrote a script that works around the bug by letting the droplet's action be invoked directly rather than via the droplet:

1. Download and install the Run Any Command plugin.

2. Download the runaction.sh script and place it in some convenient folder.

3. Change the export preset to do After Export: Do Nothing (instead of running the droplet).

4. Insert the post-process action Run Any Command.

5. Enter this command line in Run Any Command's "Command to execute":

 sh "/Users/john/Desktop/scans/runaction.sh" "Auto Levels" "Default Actions" {FILE}

Replace "/Users/.../runaction.sh" with the location of where you placed the downloaded script. Replace "Auto Levels" and "Default Actions" with the Photoshop action name and containing action set that was formerly being run by the droplet.

[Updated 1/18/19 to use Dropbox's new URLs.]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 07, 2016 Feb 07, 2016

Copy link to clipboard

Copied



When exporting a file as a PSD to run a PS Droplet it no longer works.

The break completely disrupts my automated processing workflow. It stops with a PS droplet showing in the task bar. Does nothing else. The droplet is working fine if I drop directly onto it.

Had to revert back to a previous version of Lightroom to get it to work again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 07, 2016 Feb 07, 2016

Copy link to clipboard

Copied

See my previous message in this topic for a workaround to the bug: https://feedback.photoshop.com/photoshop_family/topics/lightroom-6-4-export-problem-with-droplets?to...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 09, 2016 Feb 09, 2016

Copy link to clipboard

Copied

I got a call from adobe the other day, they told me to roll back to the previous version and wait for the next one..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 25, 2016 Feb 25, 2016

Copy link to clipboard

Copied

Our engineering team is investigating this issue.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 25, 2016 Feb 25, 2016

Copy link to clipboard

Copied

Good, thanks for the update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 27, 2016 Feb 27, 2016

Copy link to clipboard

Copied

This is bad, its part of a series of problems I have been having. Adobe's quality is getting unreliable. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied



I've created two actions in Photoshop - one for landscape and one for portrait photos.
I created a third action that does a few things, and then using the conditional argument it chooses one of the first two.
I made a droplet of the third action.
When I drop files onto the droplet it works fine.
When I export in LR and ask it to run the droplet after export - it says:
The command “If” is not currently available.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied

In the original topic, Robert reported he is using CC 2015.4 on OS X 10.11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 07, 2016 Mar 07, 2016

Copy link to clipboard

Copied

We have tested and identified this issue. A fix will be included with the next release of Lightroom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 07, 2016 Mar 07, 2016

Copy link to clipboard

Copied

Great, thanks for the update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2016 Mar 09, 2016

Copy link to clipboard

Copied

I am exporting from LRCC and selecting my droplet in the Post Processing section of the export folder and the droplet opens in my toolbar, but does not run.  Lost an hour today messing around with this.  Not loving how much time I lose to CC bugs only to have to find a thread like this.  Adobe should recognize the immense inconvenience and expense we are all going to while they test their software on us.  My bill is not for a 'beta' version of this software so it really is unacceptable.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Ehm no John, it's not fixed! If you export more than one photo the droplet is used only in the first photo not the whole batch!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Btw at least the droplet used is the correct one at least, but it's not applied to all the photos so it's kind of useless.. do we have to wait 2 other months for another update? 😞 Hope not!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Amazing betatesters....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Unfortunately, though the bug was listed as fixed in the LR CC 2015.5 / 6.5 release notes, the export now applies the correct droplet to the first photo only -- subsequent photos in the export don't get any droplet applied. (To avoid confusion, I removed my previous post, to which @ALFEEL had called out the new, incorrect behavior.)

I had previously posted a workaround to this, which requires the use of the Run Any Command plugin: https://feedback.photoshop.com/photoshop_family/topics/lightroom-6-4-export-problem-with-droplets?to...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Calling Adobe tomorrow, last time they told me the next release would have fixed it  but it's not the case, I'll keep you updated!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines