Lightroom: Incorrect description for Reading Metadata in Preferences > File Handling

1 Vote
LEGEND ,
Apr 18, 2017 Apr 18, 2017

Copy link to clipboard

Copied

Preferences > File Handling incorrectly says:

"During import or when reading metadata Lightroom can recognize dot, forward slash, and backslash separated keywords as keyword hierarchies instead of flat keywords."

But backslash is not interpreted as a hierarchical separator.  To reproduce in CC 2015.10 / OS X 10.12.3:

1. Start with a photo p1.jpg not in the catalog, with no keywords assigned to its metadata.

2. Use Exiftool to assign a keyword containing a backslash:
exiftool "-xmp:subject=ZZZ\AAA" p1.jpg

3. In Preferences > File Handling, select these two options:

- Treat '.' as a keyword separator
- Treat '/' as a keyword separator

4. Import the photo into the catalog.

5. Observe in the Keyword List panel that the flat keyword "ZZZ\AAA" has been imported at the top level.

6. Remove p1.jpg from the catalog, and repeat steps 2 - 5 but using "ZZZ/AAA".  Observe that the hierarchical keyword ZZZ > AAA has been assigned to the photo.

Bug Fixed

Views

7

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 12, 2018 Feb 12, 2018
Hi all, This issue should be fixed in today's Lightroom Classic CC 7.2 version. Please update your application and let us know if you still see this issue! Lightroom Classic CC 7.2 is now available! Thanks, Melissa

Votes

Translate

Translate
4 Comments
Adobe Employee ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

Thanks for reporting, John.
We could reproduce this. We are investigating.

Thanks,
Sunil

Votes

Translate

Translate

Report

Report
LEGEND ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

Thanks.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

Hi all,

This issue should be fixed in today's Lightroom Classic CC 7.2 version. Please update your application and let us know if you still see this issue!

Lightroom Classic CC 7.2 is now available!

Thanks,
Melissa
Melissa Rios, Product Manager, Community Experiences & Platforms | Adobe

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

LATEST
Thanks.  It's a little thing, but some people had gotten confused by this over the years, so definitely worth the 15 minutes to fix it.

Votes

Translate

Translate

Report

Report