Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: key conflict -> ctrl+alt+a is a polish letter

4 Votes
Community Beginner ,
Feb 09, 2012 Feb 09, 2012

Copy link to clipboard

Copied

LR 3 / W7 - conflict - Ctrl+Alt+A = Polish letter ą. When I try to type polish name in edit field with letter ą, the beginning of this name is deleted, because of in LR clr+alt+a is a shortcut to "select flagged photos" command.
Bug Fixed
TOPICS
Desktop

Views

25

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 21, 2015 Apr 21, 2015
This should be fixed in Lightroom CC/Lightroom 6.

Votes

Translate

Translate
26 Comments
Community Beginner ,
Apr 01, 2014 Apr 01, 2014

Copy link to clipboard

Copied

This is seriously annoying, especially with metadata fields (title, caption, keywords, etc.). LR5 on Windows 7. The good news is that this can be overcome with a simple AutoHotKey script:

#IfWinActive ahk_class AgWinMainFrame
!a::SendInput {U+0105}
+!a::SendInput {U+0104}

All it does is capture AltGr+a and AltGr+Shift+a and send the respective Unicode characters in place of the original keystrokes. To retain compatibility with other programs, it only does that if Lightroom is the active window.

Adjust for other conflicting shortcuts accordingly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 05, 2014 Apr 05, 2014

Copy link to clipboard

Copied

You could also edit the TranslatedStrings.txt file for your language and change the following line to use another keyboard shortcut:

"$$$/AgLibrary/Menu/File/Edit/SelectFlaggedPhotos/Key=Cmd+Option+a"

In Windows, the language files are locatedunder c:\program files\adobe\adobe photoshop lightroom 5.3\resources.

There is also the Keyboard Tamer plugin, but some people have reported problems using it in recent LR versions. I don't know its status.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2014 Apr 05, 2014

Copy link to clipboard

Copied

John, thanks for sharing this! Looked into this route, but this would probably disable the ctrl+a keyboard shortcut to "select all", which is not what I'd want.

The AutoHotKey solution has been working flawlessly for the past few days on my end, but as usual with such workarounds, YMMV with past/future versions of Lightroom...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 05, 2014 Apr 05, 2014

Copy link to clipboard

Copied

Dawid wrote, "this would probably disable the ctrl+a keyboard shortcut to 'select all'".

I just tested this with the following line, and CTRL+A for Select All continued to work as expected:

"$$$/AgLibrary/Menu/File/Edit/SelectFlaggedPhotos/Key=Cmd+Option+x"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 06, 2014 Apr 06, 2014

Copy link to clipboard

Copied

Excellent, thanks for testing this and providing another solid + easy fix to this long standing problem.

Adobe, can you please copy John's solution and make it part of LR5.4/LR6?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 09, 2014 Apr 09, 2014

Copy link to clipboard

Copied

Thanks for reporting. The localization team is looking into it.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

John,

which file did you change exactly?

Unfortunately, I did not find TranslatedStrings.txt for English - and this is the language I use for LR, since Polish is not supported. In fact, there is even no c:\program files\adobe\adobe photoshop lightroom 5.3\resources\en directory, and even if I create one and add file named TranslatedStrings.txt with one line:

"$$$/AgLibrary/Menu/File/Edit/SelectFlaggedPhotos/Key=Cmd+Option+q"

the Ctrl+Alt+a (AltGr+a) key combination behaves in the same way i.e. it deletes the whole text before adding Polish letter "ą".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

Jeff,

please note that Ctrl+Alt+a is not the only Ctrl+Alt combination for Polish keyboard - so if localization team would modify the key mappings, they should be aware that the following keys are used on Windows with Polish keyboard enabled:

Ctrl+Alt+a - "ą"
Ctrl+Alt+c - "ć"
Ctrl+Alt+e - "ę"
Ctrl+Alt+l - "ł"
Ctrl+Alt+n - "ń"
Ctrl+Alt+o - "ó"
Ctrl+Alt+s - "ś"
Ctrl+Alt+x - "ź"
Ctrl+Alt+z - "ż"

and the same with Shift for capitals, i.e. Ctrl+Alt+Shift+a = "Ą" etc.

Ctrl+Alt+a is the annoying one as it disturbs the normal use of product (entering comments, keywords etc.), but if it would be replaced with another shortcut, please avoid the above one. The best option would be ability to disable this shortcut.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

"there is even no c:\program files\adobe\adobe photoshop lightroom 5.3\resources\en directory, and even if I create one and add file named TranslatedStrings.txt with one line..."

Right, that's what you need to do. However, while that line successfully changes the shortcut for Edit > Select Flagged Photos from CTRL+ALT+A to CTRL+ALT+Q, it uncovers another problem (a bug), which you have observed: In an edit field like Caption, CTRL+ALT+A is now incorrectly interpreted as "select all text" (like CTRL+A).

So it looks like AutoHotkey is the only workaround on Windows.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

Actually the behaviour is slightly different.
Ctrl+a selects all text, indeed - and if I press any key, the selection will disappear and a new character will appea, like in any other Windows program.
However, with this special combination Ctrl+Alt+a, text is not selected, but it is immediately replaced with "ą" character - I never saw such behaviour in any other software. And by the way - creating the file as described above does not change anything, i.e. does not replace the default behaviour to "Select All" in my case.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

Adding the key mapping described above changes the shortcut for Edit > Select Flagged Photos from CTRL+ALT+A to CTRL+ALT+Q. After that change to the key mapping, LR then incorrectly interprets CTRL+ALT+A in edit fields as "select all". On an English keyboard, that's all it does. But on a Polish keyboard, it looks like LR is *also* interpreting it as insertion of the "ą" character -- so when you type CTRL+ALT+A, LR first selects all the text and then inserts the character, overwriting the selection.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

I see. In fact, since it was behaving in the same way before changing the shortcut from CTRL+ALT+A to CTRL+ALT+Q, it seems that on Polish keyboard this "additional" behaviour (clearing text and inserting of the "ą" character) appears regardless if the CTRL+ALT+A is mapped to any function or not. Seems like a more serious bug than just key mappings.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

Thanks. I've passed this along to the loc team.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2014 Jun 18, 2014

Copy link to clipboard

Copied

According to the John R. Ellis advice I join this discussion. The problem relates Lightroom 5.4 [Windows 7 64-bit] and the Polish letter “ą”. Here it is what I have written in a different post:

When I write keywords in the fields provided I came across the problem of deleting the already written text when I use the Polish letter “ą”. I didn’t notice any problems when using other letters typical for Polish language. For example, I write for the given photo or photos a number of words: miasto, ulica, prąd. When I write the letter “ą” in the word “prąd” everything what I have already written is deleted and in the field provided I can only see “ą”. The same problem occurs in other places, for instance, when I want to change the name of the folder or file. When I want to write the Polish letter “ą” (Alt+a) everything that has been written earlier is deleted. I always have to fight with this problem by writing all the words, including the word with the “ą” sign, in the Notepad and then copy it into the field provided.

You are discussing the solution, however, I am not a programmer and I don’t know how to use the solution and I am afraid that an average user can also have some problems with it. To sum up, is there any possibility to find the solution to the problem of Polish letter “ą” and the combination of Alt+a?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 18, 2014 Jun 18, 2014

Copy link to clipboard

Copied

I think using the free third-party program Autohotkey is the only solution that's been identified so far.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2014 Jun 18, 2014

Copy link to clipboard

Copied

John, the solution which you suggest is, in my opinion, not a solution at all. I agree that it might be effective, however, majority of users will not use it. I am more interested in solution in relation to Lightroom which should be easy to find. Besides, I have never come across any other software which had such an error. As far as my memory is good, similar problems concerning Polish letters occur in Illustrator CS6. You can’t use most of Polish letters when you want to change layer name directly from the layer panel. You have to double click and write the name in the new layer option window.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 18, 2014 Jun 18, 2014

Copy link to clipboard

Copied

I fully agree that using Autohotkey is not a great solution.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

This solution is hard to use ase there is no Polish translation in Lightroom and there's no TranslatedStrings.txt for English language 99% of Polish people use.
AutoHotKey doesn't require modifiying Lightroom files and is 100% non-intrusive. TranslatedStrings.txt will probably get overwritten after each Lightroom upgrade.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

Sending unicode characters didn't work for me, after changing the script to send tilde+a/A works flawlessly:

#IfWinActive ahk_class AgWinMainFrame
!a::SendInput ~a
+!a::SendInput ~A

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

As discussed in later posts in this thread, making these additions to TranslatedStrings.txt doesn't fully fix the problem, and AutoHotkey is the only workaround that works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

Install other things to solve problem in other software. This isn't good solution.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

It may not be good but it works and with the modified script I pasted above it preserves both AltGr+a mapping for ą and Ctrl+Alt+A mapping for "Select all flagged phots", so it's a win-win. The only solution without installing anything would be if Adobe fixed this in Lightroom which they didn't manage to for at least last 4 years. So you can either use this imperfect solution or wait, possibly forever, until Adobe does their job.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

I pay for software. So... I wait ;)
Maybe we can use this solution but hundreds and even thousands users still have a big problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

Perhaps should have mentioned that you need the Unicode version of Autohotkey, available afaik at ahkscript.org

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2014 Jun 30, 2014

Copy link to clipboard

Copied

But my version works anyway so no need for that 😉 Now I've noticed that this forum messes up with less-than and greater-than signs, the correct script should be:

#IfWinActive ahk_class AgWinMainFrame
<^>!a::SendInput ~a
+<^>!a::SendInput ~A

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines