Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: LR 4 Does not Import RAW+JPEG

9 Votes
Community Beginner ,
Mar 06, 2012 Mar 06, 2012

Copy link to clipboard

Copied

Lightroom 3 will import RAW+JPEG images from my Canon S90 fine.

The new release of Lightroom 4 only imports the JPEG images and there seems to be no way to access the RAW (CR2) files to process them.
Bug Fixed
TOPICS
Desktop

Views

17

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 26, 2012 Apr 26, 2012
A second RC version of Lightroom 4.1 was just released, now available at http://labs.adobe.com/technologies/li... . This bug is fixed in the new RC build. Please give it a try and report back if you are still seeing problems.

Votes

Translate

Translate
42 Comments
Adobe Employee ,
Mar 06, 2012 Mar 06, 2012

Copy link to clipboard

Copied

What OS/Version are you on?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 06, 2012 Mar 06, 2012

Copy link to clipboard

Copied

Mac OS X 10.7.3 on a 2010 iMac.

Lightroom 4 Beta was already installed. Installed Lightroom 4.0, then used it to upgrade former Lightroom 3.6 catalog to v4 catalog.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 06, 2012 Mar 06, 2012

Copy link to clipboard

Copied

K' Thanks for the additional info. I'll need some help from the LR folks to investigate.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 06, 2012 Mar 06, 2012

Copy link to clipboard

Copied

I've now also installed on a late 2008 MacBook Pro running the same operating system OS X 10.7.3 . This has an *intermittent* problem. It *sometimes* sees CR2+JPEG from the Canon S90 when I try to import, but sometimes only just the .jpg file. Have rebooted, and restarted LR4, a number of times - still only see .jpg on the iMac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 07, 2012 Mar 07, 2012

Copy link to clipboard

Copied

I am having this same problem with LR4 with my Canon 5D cr2+jpeg files. It imported the jpeg files but doesn't see the cr2 files with import dialog. I am able to copy the files off the card by hand without problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

Do you guys have "Treat JPEG files next to raw files as separate photos" checked?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I didn't have that checked.

When I check it for LR3 I see both the CR2 and jpg files in the import dialog for the S90.

When I check it for LR4 I still just see the jpg files and no CR2.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

It is not checked in LR3 or LR4 preferences for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

Does it work for you if it is checked?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 08, 2012 Mar 08, 2012

Copy link to clipboard

Copied

I've been trying to reproduce this, and haven't been able to. When I have "Treat JPEG files next to raw files as separate photos" checked in preferences, I see both jpeg and raw files in import. One thing to check...

In the import dialog, select the folder (or card) containing the files you want to import. Select "All Photos" in the top toolbar (right under Copy as DNG/Copy/Move/Add). Do you see the raw and jpg files in that view? Are the raw files dimmed? If so, it means they are already imported into Lightroom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2012 Mar 11, 2012

Copy link to clipboard

Copied

Thanks Becky. Sorry for delay in responding - have been away.

No - in LR4 using a USB cable plugged into Canon S90 I still do not see the raw files at all. Not even dimmed. I do see them correctly in LR3.

However I do now have a workaround for LR4 which will do for now.

When I put the SD card into a card reader, rather than using a USB cable into the camera, I can see and import the raw (CR2) files.

If it makes any difference for your investigation, this is a 4 GB EyeFi Connect x2 SD card.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2012 Mar 14, 2012

Copy link to clipboard

Copied

I have been having a similar issue which I reported on the forum during beta testing but no one seemed to take it seriously. The weird thing with mine is that it will import almost all of the files in CR2 but when it gets to around 400 files it starts to do every second or third as a JPEG instead of RAW. I have tried different settings but they don't seem to make a difference - I have found the only solution is to import from the card using 3 and then import just the RAW files from the hard drive (I separate them in to separate folders before I do the LR4 import). I was really hoping that this would be fixed in the full release but it is exactly the same.

To add more wierdness... if I quit import and start it again it fixes the problem...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2012 Mar 14, 2012

Copy link to clipboard

Copied

I've had it be pretty random as well. Import will only see the jpegs, quit and it may work. Some times it wont load a preview for some image. Nothing has changed for me except upgrading to LR4. If I load up LR3 and everything works as expected.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2012 Mar 23, 2012

Copy link to clipboard

Copied

I thought I would add I am having trouble downloading CR2 files from my EOS 60D while teathered as well. They don't even appear in LR4. I'm still using the beta which is set to expire on the 31st. I'd sure like this feature to work before I consider buying the software.

One thing of note though, is my videos do appear in the import screen (no preview is available though).

As it stands, I have to import my pictures from my Cannon EOS utility, then manually add the library to lightroom 4.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2012 Mar 23, 2012

Copy link to clipboard

Copied

Oh and I'm using Windows Vista with Service Pack 2. And have never owned a lightroom product before, this was a fresh install of the beta software.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2012 Mar 23, 2012

Copy link to clipboard

Copied

I am finding that it is semi random. I put my CF card into the reader and click import it will only show jpegs. If I hit cancel and hit import again, it will show the CR2 files just fine some times. Just repeating this a few times lets me import the files. This is new for LR4 and definitely seems like a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2012 Mar 28, 2012

Copy link to clipboard

Copied

I am having same random problem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2012 Mar 28, 2012

Copy link to clipboard

Copied

Not happy, needs sorting

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 31, 2012 Mar 31, 2012

Copy link to clipboard

Copied

When a card is inserted in my Card Reader and "importation window" automatically imports files (option checked in preferences), some RAW files are forgotten.
The card must contain imperatively RAW+JPEG files ( same issue ! None problem with LR1, 2 and 3)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 01, 2012 Apr 01, 2012

Copy link to clipboard

Copied

Having exactly the same issue with this when downloading from a Canon EOS 40D to a 2011 Macbook Pro with Mac OS X Lion 10.7.3, only bought Lightroom 4 today - such a disappointment!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

It's an instability issue during importation. No resolve today. (after the new 4.1 RC)
Not serious !!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

Tried importing my Nikon D800 files into Lightroom 4.1RC yesterday. I shot Raw & jpeg. At first only the jpegs showed up in the import window, so I cancelled out of the window, ejected my card from the computer and then reinserted the card into my card reader. Went to import in Lightroom 4.1 and now both the jpegs and the raw showed up. I proceeded to import, but it took a long time, perhaps 15 minutes to import 40 images. Finally Lightroom 4.1 ejected my card and started to make previews. Three quarters of the way through the progress bar, it simply hung up. I was able to quit Lightroom without a force quit. Then I restarted and found all the previews had been rendered. Erratic behavior with import on Lightroom 4.1 on Mac 10.6.8. Never had this problem with Lightroom 3. Thanks, Larry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

Just imported another 34 images from my D800 into Lightroom 4.1 RC and this is what happened:

In import window, all images were selected, even though I had "do not import suspected duplicates" checked. Only jpegs were shown even though I had shot jpegs and raw as in my previous post. I cancelled out of import window. Re opened import window, now jpegs and raws did show up and all the suspected duplicates were greyed out as they should be. Import time was 1 minute 9 secs. Preview creation time was 1 minute---all very normal behavior. I had 17 raw and 17 large fine jpegs.
Seems I have to open the import window once with incorrect behavior by Lightroom--->then re open import window a 2nd time for import to behave correctly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

Same problem I have seen, but the workaround I found was to change the default folder (memory card) to the same memory card DCIM folder (in case of Nikon).

In the drives available for import, at the bottom appears the card reader (same as in the top), just click on it, click on the DCIM folder and then jpg + raw appears

I don't know why LR4 is doing that

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 02, 2012 Apr 02, 2012

Copy link to clipboard

Copied

I saw Dominik say the problem persists after installing the Lightroom 4.1 RC build. Has anyone else tried the 4.1 build? I hear differing results in other forums, so wanted to check the results of the group here.

Thanks,
Becky

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines