Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: LR5 not immediately flagging metadata changes in DNG

1 Vote
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

I have JPG and DNG versions of images. If I edit metadata in these files externally to Lightroom, then only the JPG versions get flagged by LR5 as having had their metadata changed on disk. As far as LR5 is concerned, the DNG files remain untouched, which is incorrect. Is this a bug?
Bug Unresolved
TOPICS
Desktop

Views

7

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
18 Comments
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

As presented, it certainly sounds like a bug.

Would you mind elaborating how you edit the metadata in those DNGs?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

I use Photo Supreme (http://www.idimager.com/WP/?page_id=20) since I find its metadata/keyword editing capabilities superior to LR5.

Here's a link (http://sdrv.ms/1cz4Ury) to a pair of test files (JPG and DNG versions of the same image) that were edited to have the same metadata in both files using Photo Supreme.

Following that operation, LR5 detected that the JPG file was changed on disk, and flagged that in the metadata panel, whereas it did not do the same for the DNG file - even though it had been changed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

I imported both in Lr. Here is a complete dump of the differences metadata:
(courtesy of ChangeManager plugin).

Raw Metadata Changes:
aspectRatio | 1.7777777777778 | 1.7757352941176
dateTime | 412997494 | 412997493
dateTimeDigitized | 412997494 | 412997493
dateTimeDigitizedISO8601 | 2014-02-01T17:31:34+01:00 | 2014-02-01T17:31:33+01:00
dateTimeISO8601 | 2014-02-01T17:31:34+01:00 | 2014-02-01T17:31:33+01:00
dateTimeOriginal | 412997494 | 412997493
dateTimeOriginalISO8601 | 2014-02-01T17:31:34+01:00 | 2014-02-01T17:31:33+01:00
dimensions | 3072,1728 | 7728,4352
fileFormat | JPG | DNG
gps | 51.9561725,6.499135 |
gpsAltitude | 13 |
height | 1728 | 4352
masterPhoto | 5191854 | 5191895
path:
-----
X:\MyPictures\Special Purpose Photos\LrForumSupport\DNG_Metadata_Change_Detect\WP_20140201_17_31_36_Raw.jpg
--------------------------------------------------------------------------------------------------
X:\MyPictures\Special Purpose Photos\LrForumSupport\DNG_Metadata_Change_Detect\WP_20140201_17_31_36_Raw__highres.dng
--------------------------------------------------------------------------------------------------
root_uuid | 924B4DA2-7640-4E46-97DF-61143151DFE3 | C89448D6-8E5E-46C7-9CC6-E6F47E05873B
uuid | A745595D-CF04-4BAF-B937-01B33753A884 | B2FA511B-D166-4BA6-9C36-7E75C29418B7
width | 3072 | 7728

Formatted Metadata Changes:
caption | WP_20140201_17_31_36_Raw |
croppedDimensions | 3072 x 1728 | 7728 x 4352
dateTime | 2/1/2014 5:31:34 PM | 2/1/2014 5:31:33 PM
dateTimeDigitized | 2/1/2014 5:31:34 PM | 2/1/2014 5:31:33 PM
dateTimeOriginal | 2/1/2014 5:31:34 PM | 2/1/2014 5:31:33 PM
dimensions | 3072 x 1728 | 7728 x 4352
fileName | WP_20140201_17_31_36_Raw.jpg | WP_20140201_17_31_36_Raw__highres.dng
fileType | JPEG | Digital Negative (DNG)
gps | 51°57'22" N 6°29'57" E |
gpsAltitude | 42.7 ft |
title | WP_20140201_17_31_36_Raw | WP_20140201_17_31_36_Raw__highres

First item is jpg, 2nd is dng.

Unfortunately, I'm not sure what to conclude from this - since I never had either in catalog there wouldn't be any metadata status change issues...

Funny thing - after importing the DNG, there was NO METADATA WHATSOEVER VISIBLE in Lightroom - for *any* photos - never ever seen that before, but after restart of Lr, all was well. So, dunno if red herring or there is something about that DNG that gave Lr a bad first impression, so to speak. Maybe somebody else can also have a look.

Rob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

Yes, imports go OK. So I've imported my entire collection into LR5, and all the metadata that existed in the files got picked up by LR5 as expected.

The issue is about subsequently changing metadata external to LR5. These test files, which had been imported into LR5, had their metadata edited outside of LR5. The issue is that LR5 correctly flagged that the JPG file had had its metadata changed, but failed to notice that the metadata (and the file modification timestamp) had changed for the DNG file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

If you want to reproduce it, use the DNG test file, and edit the metadata outside of LR5 and see if LR5 will pick up the fact that the file's metadata has been changed.

The DNG file, by the way, was created by a Nokia Lumia 1020. If this issue is not being seen by others using DNG files created by different cameras, then it may be down to something about the Nokia implementation of DNG. Hopefully, further testing will start to narrow this down.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

|> "imports go OK".

For me, the import did NOT go OK (I had to restart Lightroom after importing that DNG - never had to do that before), thus my theory that there is something a little off about those DNGs, but I can't be sure.

When you edited via PhotoSupreme did it create a sidecar, or embed. If it's got the option to do the other, it would be worth exercising to see if any difference. Lr supports reading metadata from DNG sidecars, it just won't write them.

I think most people don't have the problem (e.g. after editing externally in Photoshop), so it's not a common bug in Lightroom, AFAIK.

I don't have time to scrutinize which is why I passed the baton. You might consider exiftooling the DNGs to see if you can glean anything...

Good luck,
Rob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

I thought the whole point of DNGs was that you could embed metadata into them? Certainly PS does - it does not create sidecars for DNG files (although it can for other RAW formats).

I have exiftooled the DNGs, and I can't see anything untoward. LR5 certainly seems to (or rather, it doesn't see anything changing), which is why I raised the issue in the first place.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

Geoff,

I attempted to reproduce - I was unable to edit the metadata in ACDSee (due to an error) and develop edits in Photoshop (ACR) are NOT flagged by Lightroom as changed metadata, despite being read properly when forced.

So, problem confirmed, and my guess: DNGs are a little off, but I dunno how so...

If DNGs from other cameras (or Adobe-converted DNGs) don't have the same problem, consider reporting problem to camera manufacturer.

If only DNGs edited in PhotoSupreme have the problem - probably bug in that software..

Rob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 13, 2014 Feb 13, 2014

Copy link to clipboard

Copied

Rob,

Thanks for looking further. I'll rustle up some Adobe-converted DNGs (and some Canon CR2 RAW files) and do some further testing.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2014 Feb 14, 2014

Copy link to clipboard

Copied

Rob,

You, or someone else, have edited the title of this thread, and altered the meaning from the original.

I had a title along the lines of LR5 not flagging metadata changed externally.

It now reads as though it is an issue with the combination of LR5 and Photo Supreme.

It is NOT. I have just used Geosetter to edit metadata in a DNG file produced by a Nokia 1020, and the same thing happens - LR5 does not notice that the metadata has been changed on disk.

Next step is to try some other DNG files...

But I think that we can rule Photo Supreme out of the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2014 Feb 14, 2014

Copy link to clipboard

Copied

Wasn't me.

PS - Good job trouble-shooting :-).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2014 Feb 14, 2014

Copy link to clipboard

Copied

OK, after messing about with this the whole afternoon, I think I'm beginning to see what's going on.

First, the issue has nothing whatsoever to do with Photo Supreme, so whoever is responsible for changing my title of this thread to imply that it is - kindly change it back to what I originally wrote. Here's a clue: look at the URL for the thread.

The issue is that LR5 responds very quickly (in a few seconds) to external changes in metadata in JPGs. However, for DNG files, LR5 will sit there looking the other way for what seems like (and apparently is) hours at a time before it finally deigns to note that a DNG file has had its metadata changed by an external application.

And note that I say: an external application, *not* Photo Supreme. I have tested this with two external metadata editors: Photo Supreme and Geosetter (which actually uses ExifTool under the covers). The results are the same.

The results are also the same whether the DNG files in question originate from my Nokia 1020 or have been converted by LR5 from Canon CR2 RAW files.

The bottom line:

LR5 does not respond quickly to metadata changes in DNG files.

Now that I know this, I shall adjust my workflow accordingly. I shall not rely on LR5 to tell me whether the files it is tracking have changed. I know that I cannot rely on LR5 telling me the truth.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2014 Feb 14, 2014

Copy link to clipboard

Copied

I gave ya the gold star 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2014 Feb 14, 2014

Copy link to clipboard

Copied

I will wear it with pride! 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

Hi Rob and Geoff,

Thanks for your work and all the specific info, sorry for the trouble. Just wanted to let you know that I've been able to reproduce the problem that you describe, and I've reported it to the Lightroom engineers.

Thanks,
Ben

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

Hi Ben - long time no post.

Thanks for looking into this and reporting back.

Rob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

It's true... been busy. 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

LATEST
Excellent. Thanks for investigating. Relieved to know that I wasn't the only person seeing this...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines