Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: "Edit in PS 2014" opens PS 2014 in Wrong Location

10 Votes
Community Beginner ,
Nov 12, 2014 Nov 12, 2014

Copy link to clipboard

Copied

Software bug. MAC OS X Yosemite (and Mavericks before it). Using LR 5.6 & Photoshop CC2014.2.1 CC subscription. When an external firewire backup drive is connected (the backup drive is a clone of my MacBook Pro that stays connected for scheduled automatic backups, etc.), when I am in Lightroom and I select "Edit (an image) in Photoshop", Photoshop opens in the wrong location. In other words, it opens the Photoshop application on my backup drive instead and I get a warning dialogue box that says "The application has been moved, and its path has changed. To update the product configuration, click update". I have a choice to update or not. Of course, I choose to not update that. That's a bug (in my opinion.) When the backup drive is not connected the correct PS 2014 application opens. Bottom line: I should be able to keep a backup drive connected and have the Edit in Photoshop open the correct application.

One way you could easily solve this issue is to change External Editing in Preferences - change the first listing where it shows by default "Edit in Adobe PS CC 2014" - simply have the the user actually confirm where the application is located, thus forcing the user to choose (and thus confirm) the location of the PS 2014 application on the primary volume that the user intends to lave Lightroom open (would be similar to what the user has to do to choose an additional external editor in the same Preferences panel.

I'e tried everything to solve this bug. Reinstalling PS 2014 does not work. Deleting plists files does not work. There seems to be no user workaround available. Please solve this problem with a fix. Thank you. James Farrell, Prescott, AZ - jamesfarrell7681@gmail.com
Bug Fixed
TOPICS
Desktop

Views

17

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 24, 2015 Jan 24, 2015
We're working with Apple (along with others) to track down the root issue. In the meantime, we've created a plug-in to do a manual override of the OS record/selection of the version of Photoshop to launch. 1) Download the plug-in from here: http://adobe.ly/1Ef651i 2) Unzip the folder 3) Launch Lightroom and select File>Plug-In Manager... 4) Click [Add] to install the plug-in 5) Select File>Plug-In Extras>Select Photoshop for Edit in Photoshop... 6) Click [Select] and navigate to ...

Translate

Translate
32 Comments
Contributor ,
Jun 03, 2015 Jun 03, 2015

Copy link to clipboard

Copied

I have this too: Open with... from Finder behaves like Edit in... out of LR did (although the Plugin has fixed the issue from LR)
So just fyi

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 17, 2015 Aug 17, 2015

Copy link to clipboard

Copied

The plugin works for me. Cannot understand why it is needed in August 2015 after the bug was raised so long ago. I have CC 2015 and a backup mirror permanently mounted that Lightroom seems to have the hots for!

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2015 Oct 03, 2015

Copy link to clipboard

Copied



Whenever I try to edit a photo from lightroom using Photoshop (by pressing command-E), I get an error stating Adobe Photoshop CC 2015 cannot be opened because of a problem. I have tried uninstalling and reinstalling both Photoshop and Lightroom, but the error persists. I can edit if I start Photoshop first, and then, from Lightroom, press command-E.

Here are the problem details and system configuration:

Process: Adobe Photoshop CC 2015 [63083]
Path: /Volumes/VOLUME/_CCC SafetyNet/*/Adobe Photoshop CC 2015.app/Contents/MacOS/Adobe Photoshop CC 2015
Identifier: com.adobe.Photoshop
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Adobe Photoshop CC 2015 [63083]
User ID: 501

Date/Time: 2015-09-30 18:27:46.738 -0500
OS Version: Mac OS X 10.10.5 (14F27)
Report Version: 11
Anonymous UUID: DE4016F7-7980-DF15-C53A-355DFCF79AE0

Sleep/Wake UUID: 6E6AF816-B394-4683-8C58-C51FFCCFF946

Time Awake Since Boot: 150000 seconds
Time Since Wake: 670 seconds

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/aif.framework/Versions/A/aif
Referenced from: /Volumes/VOLUME/_CCC SafetyNet/*/Adobe Photoshop CC 2015.app/Contents/MacOS/Adobe Photoshop CC 2015
Reason: no suitable image found. Did find:
/Volumes/Cinderella/_CCC SafetyNet/2015-08-16 (August 16) 19-52-05/Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/MacOS/../Frameworks/aif.framework/Versions/A/aif: code signature invalid for '/Volumes/Cinderella/_CCC SafetyNet/2015-08-16 (August 16) 19-52-05/Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/MacOS/../Frameworks/aif.framework/Versions/A/aif'

/Volumes/Cinderella/_CCC SafetyNet/2015-08-16 (August 16) 19-52-05/Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/MacOS/../Frameworks/aif.framework/Versions/A/aif: code signature invalid for '/Volumes/Cinderella/_CCC SafetyNet/2015-08-16 (August 16) 19-52-05/Applicat

Binary Images:
0x7fff6ceac000 - 0x7fff6cee2887 dyld (353.2.3) /usr/lib/dyld
0x7fff86e99000 - 0x7fff86ee8ff7 com.apple.opencl (2.4.2 - 2.4.2) /System/Library/Frameworks/OpenCL.framework/Versions/A/OpenCL

Model: MacBookPro8,2, BootROM MBP81.0047.B2A, 4 processors, Intel Core i7, 2 GHz, 16 GB, SMC 1.69f4
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Graphics: AMD Radeon HD 6490M, AMD Radeon HD 6490M, PCIe, 256 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x029E, 0x434D5341384758334D314131333333433920
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x029E, 0x434D5341384758334D314131333333433920
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.106.98.100.24)
Bluetooth: Version 4.3.6f3 16238, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en3
Serial ATA Device: HGST HTS721010A9E630, 1 TB
Serial ATA Device: HL-DT-ST DVDRW GS31N
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: BRCM2070 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Hub
USB Device: USB 2.0 Hub [MTT]
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: USB Receiver
USB Device: Backup+ Desk
USB Device: USB 2.0 Hub
USB Device: LaCie Hard Drive USB
USB Device: IR Receiver
Thunderbolt Bus: MacBook Pro, Apple Inc., 22.1

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2016 Feb 03, 2016

Copy link to clipboard

Copied

Does this plug-in still work. I have the same problem as I had last year in which LR edit in PS opens my backup copy of PS. Now I have latest versions of LR and PS and recently installed El Capitan. Seems that the plugin should still be there.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2016 Feb 03, 2016

Copy link to clipboard

Copied

PS-picker plugin still there and enabled. Disabled the plugin and it seems to be working now... Will keep an eye on it.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2016 Feb 08, 2016

Copy link to clipboard

Copied



This issue was happening in the previous version as well and I was hoping it would be fixed in this update, but it hasn't. After making a backup of my main drive to another, external drive, opening a file for the first time from LR calls the backup version instead of my original version.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 09, 2016 Feb 09, 2016

Copy link to clipboard

Copied

LATEST
As a temporary measure rename the backup app to something like AAALightroom.

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines