Lightroom SDK: issue with preset:getSetting()

1 Vote
LEGEND ,
Jun 18, 2018 Jun 18, 2018

Copy link to clipboard

Copied

Unfortunately, while 7.4 fixes the problem with photo:applyDevelopPreset(), it doesn't address the related problem with preset:getSetting().  See this previous post for the test script: 
https://feedback.photoshop.com/photoshop_family/topics/lr-classic-7-3-resets-settings-when-develop-p...

Note: This conversation was created from a reply on: Lightroom SDK: photo:applyDevelopPreset() changes all settings, not just those of....
Bug Fixed

Views

8

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
4 Comments
Adobe Employee ,
Jul 10, 2018 Jul 10, 2018

Copy link to clipboard

Copied

Thanks. I've raised this with the SDK engineer.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Jul 10, 2018 Jul 10, 2018

Copy link to clipboard

Copied

This is a major problem for any plugins that are integrated with presets, Jeffrey. I would prioritize it.

Votes

Translate

Translate

Report

Report
Explorer ,
Jul 13, 2018 Jul 13, 2018

Copy link to clipboard

Copied

This bug breaks both the Relative adjustments plugin, which many people use.
http://www.photographers-toolbox.com/products/lightroomstatistics/relativeadjustments/ 

People now get totally unwanted results!
This is a major issue!

and the plug-in "Preset viewer" : http://www.photographers-toolbox.com/products/lightroomstatistics/presetviewer/

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

LATEST

Votes

Translate

Translate

Report

Report