Lightroom: should ignore track points missing times.

2 Votes
LEGEND ,
Aug 17, 2018 Aug 17, 2018

Copy link to clipboard

Copied

Map Auto-Tag fails on track logs with track points missing times

If a GPX tracklog has track points with missing times, Auto-Tag Photos fails with "No matching photos", and the progress bar shows an 'Auto-Tag Photos using Tracklog" task that never completes:

RackMultipart2018081749359lu86-47d4e961-d4d8-4624-a5cf-d923502eebfc-1739971885.png

The fix is trivial -- LR should simply ignore track points missing times.

To reproduce:

1. Download the following folder containing a .gpx track log and sample photos:
https://www.dropbox.com/s/58nq51tpmwuw0xr/Trkpt-missing-time.2018.08.17.zip?dl=0

2. Import the photos.

3. In Map, do Map > Tracklog > Load Tracklog and select the .gpx file.

4. Do Map > Tracklog > Time Zone Offset and adjust the displayed start time of the tracklog to be 9:56 AM.

5. In the filmstrip, select the photo 2018-31_001.jpg and do Map > Tracklog > Auto-Tag Photos.

6. Observe "No matching photos" and the task in the progress bar that never completes.

7. Exit LR.

8. Edit the .gpx file in a text editor and remove these lines, which are missing times:

166165 
9. Repeat steps 3 - 5, and observe that Auto-Tag Photos succeeds.

Tested on LR 7.4 / Macos 10.13.6.
Bug Investigating

Views

6

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
2 Comments
LEGEND ,
Aug 17, 2018 Aug 17, 2018

Copy link to clipboard

Copied

Device used to generate the tracklog was a Samsung Galaxy J5 2017 using "Memory Map" as the software App.  

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 20, 2018 Aug 20, 2018

Copy link to clipboard

Copied

LATEST
Hi,

thanks for reporting the issue. We will work on fixing this.

Votes

Translate

Translate

Report

Report