Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lightroom: View navigation works incorrectly after creating new collection

1 Vote
Community Beginner ,
Jan 13, 2015 Jan 13, 2015

Copy link to clipboard

Copied

Lightroom 5.7.1

Repro:
- Navigate to Collection A
- Navigate to Collection B
- Select some photos in Collection B
- Create new album with "Include selected photos" (view will switch to new album)
- Navigate backwards (Window -> Go Back, or Cmd-Opt-Left on Mac)

Expected:
- View returns to Collection B

Actual:
- View returns to Collection A

This applies to folders and catalog items in the left bar as well.
Bug Investigating
TOPICS
Desktop

Views

6

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
10 Comments
Adobe Employee ,
Jan 13, 2015 Jan 13, 2015

Copy link to clipboard

Copied

I can confirm this behavior on Windows. Are you Mac or Windows, Greg?
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 15, 2015 Jan 15, 2015

Copy link to clipboard

Copied

I'm on Mac, OS X Yosemite.

Thanks for the response!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 16, 2015 Jan 16, 2015

Copy link to clipboard

Copied

Also occurs on my LR 5.7.1 / OS X 10.9.5. As a workaround, you could use the Any Source plugin, which provides backtracking of sources, filter settings, and selections.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2015 Jan 19, 2015

Copy link to clipboard

Copied

Thanks for the tip John.

For anyone else looking for a solution -- John's plugin is pay-what-you-want trialware that does a number of other things in addition to providing a work-around for this bug.

To work around the bug, one could assign a keyboard shortcut to AnySource's "back" command, which will indeed properly navigate backwards to the source collection when creating collections from a selection of photos in one keystroke.

One downside to this approach is that AnySource's back/forward commands are not otherwise direct analogues of the built-in commands, since they only navigate between sources, and not module changes, etc. On the upside, they preserve filters and selections in each navigation state (up to 10 states in history), which patches functionality missing from the built-in commands.

Also, I have managed to get into some inconsistent states using the plugin (so far non-reproducible), so if you are very concerned with stability, take that into account.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 19, 2015 Jan 19, 2015

Copy link to clipboard

Copied

@rikk:

I realize this bug is probably not high-priority, but curious if it is likely to be fixed by LR6. As a long-time Photoshop user, I've been disappointed by the big step back in UX that results from the sum of many small issues in LR.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

The bug has been reported.
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Thanks Rikk

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Unfortunately, LR doesn't provide plugins with the ability to read and set the current module.

Even though you can't reproduce the suspected inconsistencies, please send me email (see the Web page) with what you're observing. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Too bad about the lack of API access to modules.
Will email with my recollection of the errors I saw.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2015 Feb 03, 2015

Copy link to clipboard

Copied

LATEST
Thanks for the swift update John!
No issues so far with v1.5.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines