P: Arrow keys move image crop after viewing loupe view options

0 Votes
Explorer ,
Dec 11, 2021 Dec 11, 2021

Copy link to clipboard

Copied

Issue: After viewing [View] => [View Options] the arrow keys move image within crop rather than navigating to next image.

Provide Lightroom Classic version: 11.0.1
Provide OS and version: Microsoft Windows 11 Pro Version 10.0.22000 Build 22000

Issue: Provide good steps to reproduce the behavior:
Set a crop on an image and save it [Enter]
Navigate away from the image
Navigate back to cropped image
[View] => [View Options]
It is not necessary to change any settings in [View Options] but you can
Exit [View Options]
Hit left of right arrow key


Expected result: Lightroom Classic should navigate to the previous or next image in the filmstrip
Actual result: Lightroom Classic moves the displayed image within the crop area

Bug Started
TOPICS
Windows

Views

103

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 13, 2021 Dec 13, 2021
Setting status to investigating
Status Started

Votes

Translate

Translate
8 Comments
LEGEND ,
Dec 12, 2021 Dec 12, 2021

Copy link to clipboard

Copied

That misbehavior also occurs on my LR 11.0.1 / Windows 10. By "Navigate away from the image; Navigate back to cropped image", I interpreted that to mean to use the mouse cursor to click on another photo in the filmstrip and then click back to the original photo.

 

It doesn't occur on my LR 11.0.1 / Mac OS 11.6.

 

To avoid this bug, you could use Ctrl + Left/Right Arrow to advance the selected photo left or right in the filmstrip.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 12, 2021 Dec 12, 2021

Copy link to clipboard

Copied

Moderator, @Rikk Flohr: Photography, this should be moved to Bugs.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Hi John,

This has been standard behaviour since Lightroom 1, so it's curious that you're not seeing it on your Mac. I'm seeing it on Catalina with current release and it's As Designed behaviour. Try the Spot Removal tool and move the arrow. The spot moves. Command/Control arrows is the designed way to navigate between images, while the arrows keys work on the properties of the current selected tool. A change here is a feature request, not a bug. 

 

Sean

 

 

 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

I agree that when the Crop tool is selected, the left- and right-arrows have always moved the crop. And normally, the left- and right-arrows don't move the crop when the Crop tool isn't selected.  The bug is that in these precise circumstances, View > View Options is silently reselecting the Crop tool without actually opening the Crop panel and showing Done in the toolbar.  To see why this surely isn't as-designed behavior, follow these precise steps:

  

1. In Develop, select the Crop tool and set a crop on the photo.

2. Hit Enter.

3. With the mouse, click on the next photo in the filmstrip.

4. Click back to the original photo.

5. Do View > View Options and then dismiss the dialog.

6. Left- and right-arrow move the position of the crop, even though the Crop panel isn't open and Done isn't showing in the toolbar.

7. Repeat steps 1-6, omitting step 5 (View Options), and observe that in step 6, left- and right-arrow change the selected photo in the filmstrip, rather than moving the crop.

 

Surely it isn't as-designed behavior that doing View > View Options causes left- and right-arrow to be sent to the Crop tool.

 

 

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 13, 2021 Dec 13, 2021

Copy link to clipboard

Copied

Setting status to investigating

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Started

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

FWIW, I've tried to reproduce the problem on my Windows 10 system, using the detailed steps exactly, but so far I'm not seeing it at all, i.e. LrC works as expected when using right/left arrows after invoking and dismissing the View Options dialog.

 

I've tried on both LrC 11.0.1, and also now on 11.1. Both versions are working as expected.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

Last night, the first time I tried, I was able to reproduce the problem with 11.0.1, but not the second time when I went to make a screen recording. This morning, I was unable to reproduce the problem with 11.0.1 and, after updating, unable to reproduce it with 11.1.

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

LATEST

After updating to 11.1 on Windows 11 I am no longer seeing the issue.

Votes

Translate

Translate

Report

Report