Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Camera Raw, Lightroom Classic: Internal math error on export

11 Votes
LEGEND ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

ScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.pngScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.png

After exporting this error report populates and states that an internal math error has occurred for 18 of the images. I'm not sure how to fix this. Can someone help me out? 

Bug Fixed
TOPICS
macOS, Windows

Views

1.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 26, 2021 Oct 26, 2021
  Greetings,   The Max 2021 Photography products updates have been released and include remedies for this topic.  The updates will be rolling out worldwide, October 26 and 27, 2021. If you do not see the updates in your Creative Cloud Desktop app, you can refresh the apps to see if the updates are available in your region.  The keyboard shortcut to refresh is [Cmd/Ctrl] + [Opt/Alt] + [ R ].    Note: iOS and Android updates may take up to a week to appear in your App Store.   Thank you for your p...
Status Fixed

Votes

Translate

Translate
96 Comments
New Here ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

I for some reason can't export a picture in Lightroom because it claims theres a mathmatical error. What do I do?

Can sombody help me?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

Please post your System Information as Lightroom Classic (LrC) reports it. In LrC click on Help, then System Info, then Copy. Paste that information into a reply. Please present all information from first line down to and including Plug-in Info. Info after Plug-in info can be cut as that is just so much dead space to us non-Techs.

GoldingD_0-1633806532074.png

 

GoldingD_1-1633806532075.png

 

Sample below as of 7/1/2021

Lightroom Classic version: 10.3 [ 202105281559-8dc50eb4 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.19043
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 4.0GHz
SqLite Version: 3.34.0
Built-in memory: 16317.1 MB
Real memory available to Lightroom: 16317.1 MB
Real memory used by Lightroom: 1302.8 MB (7.9%)
Virtual memory used by Lightroom: 1586.9 MB
GDI objects count: 746
USER objects count: 2288
Process handles count: 1909
Memory cache size: 252.3MB
Internal Camera Raw version: 13.3 [ 807 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 299MB / 8158MB (3%)
Camera Raw real memory: 303MB / 16317MB (1%)
System DPI setting: 96 DPI (high DPI mode)
Desktop composition enabled: Yes
Displays: 1) 2560x1440
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No
Graphics Processor Info: 
DirectX: NVIDIA GeForce GTX 1070 Ti (27.21.14.6089)

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic
Library Path: F:\Files\Pictures\Vacations and Day Trips\Photo Trips\24 Photo Trip September 2019\24 Photo Trip September 2019-v10.lrcat
Settings Folder: C:\Users\goldi\AppData\Roaming\Adobe\Lightroom

Installed Plugins: 
1) Aurora HDR
2) ColorChecker Camera Calibration
3) DxO PhotoLab 3
4) DxO PhotoLab 3 Importer
5) HDR Efex Pro 2
6) Helicon Focus Export

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

Please post a screenshot of the message, and type in the exact error message (helps thise translating the message)

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 10, 2021 Oct 10, 2021

Copy link to clipboard

Copied

Adobe has acknowledged this bug, which was likely introduced in LR 10.2.  The only known possible workaround is to roll back to version 10.1.1:

https://www.lightroomqueen.com/roll-back-update-previous/ 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 10, 2021 Oct 10, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

I installed version 10.1 and it keeps happening with exactly the same photos. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Hello! Was this issue solved? I can't find any useful solution and I'm having a big problem with clients now. Please, help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

consegui burlar o sistema contra o sistema. o famoso jeitinho brasileiro.
1. pegue uma foto que não esteja com o erro e edite na ferramenta de crop, gire 1 grau 
2. copie as configuracoes de edição
3. selecione as imagens com erro matematico e cole em todas essa configuração. 
aqui voltou. se precisarem de mais ajuda me chamem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Hello everyone!
I'm writing for a technical help request related to a problem I'm having with Lightroom that is completely freaking me out!
Since the last update, when exporting, I often run into "an internal math error".
I have noticed that this problem  happen often when I "copy and paste" adjustments from one previous photo to another. I tried to select some and deselect others adjustments to see if this could solve the issue but nothing happened.
My way of working and my presets have always been the same since years. This issue is messing me up and slowing down my work a lot, especially when it comes to managing thousands of photos at the same time!
I’ve already tried to downgrade to the previous version of Lightroom Classic, but this didn’t fix anything, it just messed up my catalogs and all my presets...

I read that this could be a common problem, but I didn't find any info to fix it.
Is there anyone else who had the same problem and maybe managed to solve it?

 

I'm running the latest version of Lightoroom Classic 10.4 Camera Raw 13.4

MacOS Big Sur 11.3.1

MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)

2,3 GHz Intel Core i5 dual-core

16 GB 2133 MHz LPDDR3

Intel Iris Plus Graphics 640 1536 MB

 

Thank you!

Martina

 

 

these are my system info:

 

Versione di Lightroom Classic: 10.4 [ 202108071231-af9219b9 ]
Licenza: Creative Cloud
Impostazioni lingua: it-IT
Sistema operativo: Mac OS 11
Versione: 11.3.1 [20E241]
Architettura dell'applicazione: x64
Conteggio processore logico: 4
Velocità processore: 2,3GHz
Versione SqLite: 3.34.0
Memoria integrata: 16.384,0 MB
Memoria reale disponibile in Lightroom: 16.384,0 MB
Memoria fisica usata Lightroom: 2.738,5 MB (16,7%)
Memoria virtuale usata Lightroom: 14.689,0 MB
Dimensione cache memoria: 305,6MB
Versione Camera Raw interna: 13.4 [ 872 ]
Numero di thread massimo utilizzato da Camera Raw: 3
Ottimizzazione SIMD Camera Raw: SSE2,AVX,AVX2
Memoria virtuale di Camera Raw: 1848MB / 8191MB (22%)
Memoria reale di Camera Raw: 2004MB / 16384MB (12%)
Monitor: 1) 2880x1800

Informazioni processore grafico:
Metal: Intel(R) Iris(TM) Plus Graphics 640

 

Cartella applicazione: /Applications/Adobe Lightroom Classic
Percorso libreria: /Users/Martina/Pictures/Lightroom/Lightroom Catalog-2-2-v10.lrcat
Cartella impostazioni: /Users/Martina/Library/Application Support/Adobe/Lightroom

Plug-in installati:
1) AdobeStock
2) Facebook
3) Flickr
4) Plug-in acquisizione diretta Nikon
5) Plug-in unità di importazione Aperture/iPhoto

Indicatori Config.lua: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default - Uscita integrata#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: LR5x26
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: Intel(R) Iris(TM) Plus Graphics 640
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: Intel Inc.
GL_VERSION: 2.1 INTEL-16.2.16
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

It's a known bug that Adobe has marked "Investigating".  You could try rolling back to version 10.1, though there's mixed reports about whether that works.  Read through the bug report for other possible ways people have tried to workaround the bug:

https://community.adobe.com/t5/lightroom-classic-bugs/p-camera-raw-lightroom-classic-internal-math-e... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

I could solve this issue by reseting the affected photos and NOT applying the same presets. I noticed some presets are not recognized any more (they went grey in the list, I don't know why). If I apply those presets, this error will appear. If I create a new preset or edit the photos from scratch, the photo will export as always without any issue. The problem is in the presets. I don't know why they stopped working.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2021 Oct 21, 2021

Copy link to clipboard

Copied

"they went grey in the list, I don't know why"

 

This usually happens when the preset refers to a camera profile for a camera different from that of the current photo.  To further narrow down this bug so it can be easily reproduced and fixed, please do these steps:

 

1. Do the menu command Help > System Info and copy/paste here the first ten lines.

 

2. What is the exact camera make and model?

 

3. What is the file type of the file being exported (raw, TIFF, JPEG, PSD)?

 

4. In Develop's Presets panel, right-click the grey preset and do Show In Finder / Explorer.

 

5. Edit the selected .xmp file in Textedit or Notepad. Copy/paste all of its lines here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

Hi, has there been found any solution yet? I have encountered the same issue on both my MAC and PC, where I work in a same catalog (I carry it around on a USB). After syncing settings, some photots become blurry when zoomed-in. Lightroom adds a exclamation mark to these files. I am also not able to export these pictures. Sometimes, photos work fine and only after some time (and synced settings) become certain photos problematic as described. I will try updating to LR v11, however, this error has been occuring for the last 5 months? I have tried various versions of LR, nothing helped. 

 

Please help, this error makes my work at least 2x longer (reseting develop settings and trying to edit attempt-failure in a way which does not bring the error...). Horrible experience while paying ordinary price for the product!

My PC LR info:
PC.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

LATEST
 

Greetings,

 

The Max 2021 Photography products updates have been released and include remedies for this topic.  The updates will be rolling out worldwide, October 26 and 27, 2021. If you do not see the updates in your Creative Cloud Desktop app, you can refresh the apps to see if the updates are available in your region.  The keyboard shortcut to refresh is [Cmd/Ctrl] + [Opt/Alt] + [ R ]. 

 

Note: iOS and Android updates may take up to a week to appear in your App Store.

 

Thank you for your patience.

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Fixed

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines