Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Camera Raw, Lightroom Classic: Internal math error on export

11 Votes
LEGEND ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

ScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.pngScreenShot20210401at7.59.44AM-d1428c80-b880-4866-afcf-87b6b570ff45-576464191.png

After exporting this error report populates and states that an internal math error has occurred for 18 of the images. I'm not sure how to fix this. Can someone help me out? 

Bug Fixed
TOPICS
macOS, Windows

Views

1.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 26, 2021 Oct 26, 2021
  Greetings,   The Max 2021 Photography products updates have been released and include remedies for this topic.  The updates will be rolling out worldwide, October 26 and 27, 2021. If you do not see the updates in your Creative Cloud Desktop app, you can refresh the apps to see if the updates are available in your region.  The keyboard shortcut to refresh is [Cmd/Ctrl] + [Opt/Alt] + [ R ].    Note: iOS and Android updates may take up to a week to appear in your App Store.   Thank you for your p...
Status Fixed

Votes

Translate

Translate
96 Comments
Community Beginner ,
Jul 04, 2017 Jul 04, 2017

Copy link to clipboard

Copied

I was batch exporting some images from Lightroom and at the end of the Export I received a Dialog box saying there had been an internal Math Error on 1 of my images.   The image itself was a copy so I thought maybe something was wrong with the copy.  As I had made changes to the copy, I tried to Sync the Develop Settings to the original image.   When I hit D for Develop, I received a blue image with a white x running through it.  I could still execute the sync but It had no effect on the original version of the image.  I then tried to sync the develop settings of another image (that didn't seem to have the problem of a blue image) and copy that to the original image and again no effect.   It seems that this blue screen with x only is effecting 2-3 images out of the 400.   I went to Preference>Performance>and deselected Use Graphics Processor but now the images effected are just black when I try to edit them in Develop and the Develop settings are all greyed out.   Tried to contact Adobe support but they won't give me the option to chat.  Any help would be greatly appreciated. I'm using latest version of Lightroom CC on a iMac retina 5k late 2014 i7 4GHz processor 32GB RAM AMD Radeon R9 295X 4GB

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 14, 2017 Jul 14, 2017

Copy link to clipboard

Copied

Hi gnrd,

You may try and reset the Lightroom preferences back to default for the "Internal Math error" also, the images are showing black are you able to export those images out? because it's possible that the images are missing from Lightroom and you may need to relocate their locations in Lightroom.

Reset Preferences: Preference file and other file locations | Lightroom CC and 6

Relocate missing images: How to find missing photos in Photoshop Lightroom

Regards,

Mohit

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 02, 2019 Jun 02, 2019

Copy link to clipboard

Copied

does not work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 28, 2019 Dec 28, 2019

Copy link to clipboard

Copied

I suggest you post a bug report in the official Adobe feedback forum, where Adobe wants all bug reports and feature suggestions: 

https://feedback.photoshop.com/photoshop_family/categories/photoshop_family_photoshop_lightroom .

 

Be sure to include the first ten lines of the menu command Help > System Info.  Provide all the details, rather than linking back to this thread -- experience shows that Adobe developers tend not follow the links. Also, upload one of the photos causing the error to Dropbox or similar and include the sharing link. That will ensure Adobe can reproduce the problem, making it more likely they'll fix it.

 

[Use the reply button under the first post to ensure replies sort properly.]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

On my Windows machine, back on the Lightroom version 8 and 9 releases, this sometimes happened to me. But it hasn't happened on V10. When it happened, the fix was to just redo the export. It would sometimes happen on import as well.

  1. Which Lightroom product are you using, I'm using LRC? 
  2. Which version of Lightroom?
  3. What operating system and version? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 03, 2021 Apr 03, 2021

Copy link to clipboard

Copied

Lightroom Classic is unable export 18 images. Lightroom says, "Internal math error occured". This has never happened before. I also reset all the "Adobe Lightroom Classic CC" preferences by uninstalling and reinstalling Adobe Lightroom Classic. Please help me thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 03, 2021 Apr 03, 2021

Copy link to clipboard

Copied

Can you open these images with another application such as the Photos apps included with macOS or windows?

Please supply additional information:

  • operating system and version
  • Lightroom version 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

Been having same intermittent issue for last couple of weeks , using Big Sur 11.2.3 and LR Classic 10.2. Only way around it is to reimport the photo's from original memory card and reimport into LR..... pain as internal math error only happens when exporting... so can send ages editing and then find you are xxxxxxx.

Once error occurs the files are marked in Library with a black circle and exclamation mark.

This time it impacted 25 images that I had edited. So 50 successfully edited and exported. All images from same camera (1DX) imported as CR2 and export was jpeg, 2 jpeg sizes used full res and longest edge 1920px.

Have checked the the original CR2 in the LR files location can be edited in photoshop.

Ask if you need anything else

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Olá,

Estou com um problema no Lightroom, sempre que vou exportar alguma foto no modo "Revelação" ocorre o erro "Erro matemático interno"

 

  • Adobe software: Lightroom 10.2
  • Operating system: Windows 10 Pro
  • Relevant hardware: 8GB RAMWhatsApp Image 2021-04-08 at 12.58.22.jpeg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Adobe has acknowledged this bug in the official Adobe feedback forum, where it wants all bugs reported:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-internal-math-error... 

 

It is marked In Progress, meaning that Adobe is actively working on fixing it. Please add your details to the bug report, and be sure to click Like and Follow at the bottom of the first post. That will make it a little more likely that Adobe will prioritize a fix, and you'll be notified when the bug's status changes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Olá,

Estou com o mesmo problema no Lightroom, sempre que vou exportar alguma foto no modo "Revelação" ocorre o erro "Erro matemático interno"

 

  • Adobe software: Lightroom 10.2
  • Operating system: Windows 10 Pro
  • Relevant hardware: 8GB RAM
  • WhatsAppImage20210408at12.58.2-a157c83a-953c-4543-b40c-2299c8485bcc-717580813.jpeg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

Having problems emailing fromLR, first time this has happen,tried two different emails still cant!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Same problem here. I figured out that it only happens when you copy and paste the style from one photo to another, or also when you apply a preset. When you try to export the original file or edit the photo from scratch it doesnt show the error.

So if you want to save some time until this is fixed, my solution is to copy everything from a photo except the Process Version (you will have to uncheck some adjustments) and that's it. You can't copy and paste everything but it's something.

I hope you guys can fix this soon.

  • Adobe software: Lightroom 10.2
  • Operating system: Windows 10 Pro
  • Relevant hardware: 16GB RAM

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Há previsão da correção deste erro matemático interno do Lightroom?

A Adobe já respondeu alguém aqui?

Mesmo problema aqui.

Não exporta as imagens com exclamação e afirma ser erro matemático interno do ligthroom.

  • Adobe software: Lightroom 10.2
  • Operating system: MAC Big Sur 11.2.3
  • Relevant hardware: 8GB RAM

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 24, 2021 Apr 24, 2021

Copy link to clipboard

Copied

Achei que o problema era só comigo.
Tenho tido muita dor de cabeça com esse erro.
Começou a aparecer há uns dias.
Alguém já foi respondido sobre o que fazer nesse caso? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 24, 2021 Apr 24, 2021

Copy link to clipboard

Copied

I've just had the same issue. 3 of my 147 exported files couldn't export due to the math error. I narrowed it down to using the transform function, and more specifically vertical. If I reset that back to 0 it'd allow me to export. Not ideal given the skewed lines, but it got me through the issue for now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 24, 2021 Apr 24, 2021

Copy link to clipboard

Copied

I'm a heavy user of Guided Transform on Windows without this problem. I'm on Windows 10 Pro with all updates and can't recreate the problem. My machine has 64GB of RAM, not sure if it matters. I'm exporting RAW images, mostly Fuji-X and Olympus,  to full JPEGs, at 4K or FHD. The video card is a Quadro P2200 with 5GB of RAM. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 24, 2021 Apr 24, 2021

Copy link to clipboard

Copied

I'm running a fair bit less power than yours - MacBook Pro (2019) - 8gb ram (Intel Iris Plus Graphics 645 1536MB). Lightroom is up to date. Using Sony (A7iii) ARW files which Lightroom converts on import. I exported a +600 image wedding yesterday without issue that included vertical transform adjustments. Just this morning when 3 of the 147 had vertical transform adjustment included that it didn't like them. Potentially another combination of settings that also triggering it, but as I said if I reset the transform slider back to 0 I can get around it and adjust in Photoshop instead. It's not ideal and I'm glad it's only on 3 images otherwise it'd be huge pain.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

*jorgevelafoto UPDATE: I exported 2 more projects and had no errors. I dont know why it happened before.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

Ash, if you have a photo that reliably reproduces this problem, please do Metadata > Save Metadata To File (with the non-zero Transform settings), upload the .arw and its .xmp sidecar to Dropbox or similar, and post the sharing link here.  So far, no one has provided a reliable means to reproduce the issue, which will make it much harder for Adobe to address.

Also, please do Help > System Info and copy the first ten lines to here.  The Creative Cloud app not infrequently fails to keep your apps up-to-date, so it's important to know the exact versions of LR and Mac OS you're running.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Hello,

 

I am trying to export a dng file Lightroom created when I formed a panorama photo. When exporting I keep getting an error message "An internal math erro occured". I exported a raw file out to JPEG with the same settings and it did just fine. I reset my preferences. I have preview files. I also downgraded my Lightroom software and restructured the panorama photo. This error message still occurs. 

 

Screen Shot 2021-05-04 at 12.39.56 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

Adobe has acknowledged this bug:

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-internal-math-error... 

 

It is marked as "in progress", which means the team is actively working on it. Please add your details to the bug report, and be sure to click Like and Follow at the bottom of the first post. That will make it a little more likely that Adobe will prioritize a fix, and you'll be notified when the bug's status changes. Product developers rarely participate in this forum and won't see your feedback.

 

In particular, if your example DNG reliably causes the bug, please upload it Dropbox or similar and post the sharing link in that bug report.  To date, no one has posted a reliable recipe for triggering the bug, which can make it harder for Adobe to troubleshoot.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I had the same issue. When I used the transform tool on images with copy and pasted settings it would go blank and then I’d get the exclamation point saying “Lightroom is having trouble reading this photo.” I tried deleting and re importing the photos several times- same thing. I also got the export error “internal math error” when I’d export about half of my images. I finally unchecked the “process calibration” when I copied the settings and that seemed to fix it. I didn’t get the error again when I pasted the new copied settings. Hopefully this bug gets fixed soon. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Having the exact same issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Any solution to this f....g Adobe disaster!

 

MATH INTERNAL ERROR exporting and black circle 

 

400 fotos edited and time and money lost!!!!

 

UNACCEPTABLE software failure.

 

Awaiting any suggestion (iMAC i7) (Version LRC 10,2)

 

thx

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines