Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Checking just Upright Mode, Straighten Angle, or Aspect Ratio doesn't work in Copy/Sync/Preset

1 Vote
LEGEND ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Checking just Upright Mode, Straighten Angle, or Aspect Ratio doesn't work in Copy/Sync Settings or when creating a preset. The workaround for Upright Mode is to first check Transform and then uncheck the undesired sub-settings. This doesn't work for the Crop sub-settings though.

 

To reproduce:

 

1. Edit photo A, and in the Transform panel, select Auto.

 

2. Select photos A and B with A most-selected, and do Sync Settings, click Check None and then Transform > Upright Mode. 

 

3. Observe that B has the Transform mode set to Off.

 

4. Select photo A, do Copy Settings, click Check None and then Transform > Upright Mode. Select B and do Paste Settings.

 

5. Observe that B has the Transform mode set to Off.

 

6. Edit photo A.

 

7. Create a preset, click Check None and then just Transform > Upright Mode checked.

 

8. Observe that the preset doesn't appear in the Presets panel. But in the presets folder, there is an appropriately named .xmp file for the newly created preset, but it contains no Develop settings.  

 

9. Observe that each time you invoke Copy Settings, Sync Settings, or create a preset, Upright Mode is unchecked -- that is, LR doesn't remember that it was checked the last time you invokved the command.

 

Tested on LR 11.0 / Mac OS 11.6 and on Windows 10 after resetting preferences.

Bug Started
TOPICS
macOS, Windows

Views

90

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 03, 2021 Nov 03, 2021
Setting to status to Investigating
Status Started

Votes

Translate

Translate
7 Comments
Adobe Employee ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi John,

 

I tried the same worfklow as you have mentioned, but I am not able to reproduce the issue.

Attached the video recording here : https://adobe.ly/3jKCo2a

Please let me know if I am missing something.

 

Thanks,

Arjun

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi Arjun,

For some reason your LrC 11 is not behaving the same as ours!

 

From your video, here is your Sync settings dialog:

LrC11_Sync_Transform01.jpg

 

Note that when you checked the Upright Mode option, the Transform check box gets a solid square in it.

 

From my test, my Sync settings dialog is:

LrC11_Sync_Transform02.jpg

 

Note that for my LrC 11, and I suspect John's is the same, the Transform check box is empty, even though I have checked the Upright Mode option. When the Transform check box is empty, nothing gets copied/synchronised. It is the same for the Copy and for the Create Preset dialogs.

 

The same problem also exists for the Crop options.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi @drtonyb ,

 

Thanks for this info. I think I got it now.

If you do a "Check none" and directly click on the Upright Mode this is happening right ?

However if you select the Transform checkbox as a whole, then unselect Upright and Manual transforms, this issue is not occuring. Am I inline with this ?

 

Thanks,
Arjun

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Hi Arjun,

Yes, if you don't start with Transform checked, then checking Upright mode won't work properly.

 

If you start with Transform checked, then all options are checked. Then unchecking the Manual Transform and Upright Transforms, the Upright Mode stays checked and works.

 

This still doesn't work with the Crop options though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks, I edited the bug report to clarify the cause of the problem and provide the workaround.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

I am having the same issue. I'm using a new macbook pro (w/ M1 Pro chip) and the most recent version of lightroom. If I just click "upright mode" without "transform" selected, the settings do not sync and the box is unchecked next time I open the modal. The workaround posted above does work though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

LATEST

Setting to status to Investigating

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Started

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines